手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

大伙会搞源码的去看

[互 助]
设置
4597 6 Q_3032928 Lv.4 发表于 · 2018-12-19 13:56 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

举报

扔鸡蛋(0) 回复

林小平2009
Lv.6
发表于 2018-12-19 16:35 复制 查看全部楼层
原本是通达信的公式........论坛有修改为大智慧的..

附件

20181219163235.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

Q_3032928
Lv.4
发表于 2018-12-19 15:08 复制 查看全部楼层
原帖由 @刘总统 于 2018-12-19 14:04 发表 " onmouseover="img_onmouseoverfunc(this)" lazyloadthumb="1" border="0" alt="" />
理想论坛 提示信息

您无权进行当前操作,这可能因以下原因之一造成

本版块只有特定用户组可以访问。

您已经登录,但您的帐号或其所在的用户组无权访问当前页面。

SJJ%YDGEA]EYYC~~I]`0MSK.png
不好意思,违规发帖
这个指标是益盟的,朋友帮我改成通达信用的了,我自己添加了饱和度,可指标被压缩了不会搞

绿低量:=10;
蓝低量:=50;
灰低量:=100;
H_L:=0.1*LAST(HHV(VOL,240),10,5);
{MAV10:MA(V,10),COLORYELLOW;}

量:VOL,VOLSTICK,COLORRED;
全换手周期:=SUMBARS(V,CAPITAL),LINETHICK0,COLORGREEN;{求完全换手到现在的周期数}
饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))>1,1,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20)))*100,COLORYELLOW,NODRAW;
换手:10000*VOL/FINANCE(7),COLORRED;
量比: V/REF(MA(V,5),1),COLORMAGENTA,LINETHICK0;
几倍: V/REF(V,1),COLORYELLOW,LINETHICK0;
倍数:=1.9;
倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,LINETHICK0;
量皇:量比>3,COLORGREEN,LINETHICK0;
STICKLINE(量皇,VOL,0,2,0),COLORGREEN;
倍缩: REF(V,1)>=VOL*倍数,COLORMAGENTA,LINETHICK0;
缩量:REF(V,1)>VOL,COLORCYAN,LINETHICK0;
平量: RANGE(V/REF(V,1),0.97,1.03) AND BARSCOUNT(V)>=2,COLORWHITE,LINETHICK0;
低量10: VOL=LLV(VOL,绿低量) AND BARSCOUNT(V)>=绿低量,COLORGREEN,LINETHICK0;
低量50: VOL=LLV(VOL,蓝低量) AND BARSCOUNT(V)>=蓝低量,COLORGREEN,LINETHICK0;
地量:VOL=LLV(VOL,灰低量) AND BARSCOUNT(V)>=灰低量,COLORBLUE,LINETHICK0;
DRAWTEXT(倍量,VOL*1.1,'倍'),COLORYELLOW;
V1:=VOL*0.95;{图标位置}
V2:=VOL*0.85;
STICKLINE(倍量, 0,V1*0.7,2,0),COLORYELLOW;
STICKLINE(平量,0,V1,2,0),COLORWHITE;
STICKLINE(低量10,0,V2,2,0),COLORCYAN;
STICKLINE(低量50,0,V2,2,0),COLORGREEN;
STICKLINE(地量,0,V2,2,0),COLORBLUE;
STICKLINE(倍缩,0,V*0.45,2,0),COLORMAGENTA;
STICKLINE(C<O AND C>REF(C,1),0,V1,2,0),COLORRED;{假阴柱};
真阳或假阴:=C>O OR C>REF(C,1);
收阳:= REF(真阳或假阴,3);
倍量1:=REF(倍量,3);
高量:=REF(V,3)>=HHV(V,7);
三日不破:= LLV(C,3)>=REF(L,3);
价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}
量缩:=COUNT(V<=REF(V,1),3)=3;
连阳:= COUNT(真阳或假阴,3)=3;
倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;
高量将军柱:= 高量  AND 三日不破 AND 收阳;
将军柱:= 倍量将军柱 OR 高量将军柱;
黄金柱:= 将军柱 AND 价升 AND 量缩 AND 连阳 ;{标准黄金柱}
STICKLINE(黄金柱,0.3*V,0.7*V,7,0),COLORRED; {红柱}
DRAWICON(黄金柱,V*2,12),COLORRED;
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
百日地量群:=COUNT(V100,5)>=3;
DRAWTEXT(FILTER(百日地量群,4),V+30000,'地量群'),COLORRED;
●长阴短柱:C/REF(C,1)<=0.96 AND V<HHV(V,30)/1.9,COLORGREEN,LINETHICK0;
DRAWTEXT(●长阴短柱 ,V+1.6*H_L,'●'),COLORGREEN;
资金异动:MA(V,120),COLORBLUE,LINETHICK2;
洗盘35:MA(V,35),COLORYELLOW;
启动5:MA(V,5),COLORWHITE;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.0,0,'★价涨量缩 积极做多 长阴短柱是个宝 凡遇大跌就盯好★')COLORYELLOW,LINETHICK3;

N1:=21;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:IF(SAT>1,1,SAT)*100,COLOR00AAFF,NODRAW;
中点:=REFDATE(HHV(V,180)*0.5,DATE);
STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00AAFF;
STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和,0),COLOR0077FF;
DRAWTEXT(CURRBARSCOUNT=N1+3,中点*1.8,'饱和度'),COLORYELLOW;

[ 本帖最后由 Q_3032928 于 2018-12-19 15:20 编辑 ]

举报

点亮(0) 扔鸡蛋(0) 回复

刘总统
Lv.5
发表于 2018-12-19 14:04 复制 查看全部楼层
理想论坛 提示信息

您无权进行当前操作,这可能因以下原因之一造成

本版块只有特定用户组可以访问。

您已经登录,但您的帐号或其所在的用户组无权访问当前页面。

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表