手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙:指标里主升字出现做一个选股指标

[通达信]
设置
2444 10 小林a Lv.4 发表于 · 2019-3-9 12:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡,'主升↑'),COLORCYAN;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH*1.03,'↓'),COLORYELLOW;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,'↓'),COLORYELLOW;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,'注意买入'),COLORCYAN;
S:=MA(VOL,5)/MA(VOL,60),COLORRED,,LINETHICK2;
A:=MA(S,5),COLORGREEN,,LINETHICK2;
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
F:=MA(S,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1);
D:=SMA(K,15,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH*1.06,'!'),COLORYELLOW ;
S1:=IF((J<11 AND BIAS>-11 AND CROSS( S,F) AND (S-F)>0.010),2,0),STICK,LINETHICK3,COLORGREEN;
DRAWTEXT(S1=2,LOW,'关注'), COLORGREEN;
中轨:HHV(MA(H,13),13),COLORRED,LINETHICK2;
趋势:LLV(MA(H,13),1),COLORGREEN,LINETHICK2;

举报

扔鸡蛋(0) 回复

紫衣仙子
Lv.0
发表于 2019-3-10 08:05 复制 查看全部楼层
我看不到选股公式,是因为新来的吗?

举报

扔鸡蛋(0) 回复

老马识途10
Lv.7
发表于 2019-3-9 13:32 复制 查看全部楼层
原帖由 @小林a 于 2019-3-9 13:11 发表 " onmouseover="img_onmouseoverfunc(this)" lazyloadthumb="1" border="0" alt="" />
老马,不行啊,选不出

能选出,福班说了,把盘后数据下载全再试试。

附件

1.png
查看全部打赏
  • 今曰+2理想币 : 谢谢老师的帮助,谢谢老师的分享!

举报

点亮(0) 扔鸡蛋(0) 回复

福阿德
Lv.8
发表于 2019-3-9 13:23 复制 查看全部楼层
原帖由 @小林a 于 2019-3-9 13:11 发表
老马,不行啊,选不出
兄好:
      公式没问题。
      找一下自己的原因。数据问题或是其他 问题。

举报

点亮(0) 扔鸡蛋(0) 回复

小林a
Lv.4
发表于 2019-3-9 13:11 复制 查看全部楼层
老马,不行啊,选不出

举报

扔鸡蛋(0) 回复

小林a
Lv.4
发表于 2019-3-9 13:03 复制 查看全部楼层
谢谢漫步,辛苦你了,选不出股来,能不能重新搞一下

[ 本帖最后由 小林a 于 2019-3-9 13:06 编辑 ]

举报

点亮(0) 扔鸡蛋(0) 回复

老马识途10
Lv.7
发表于 2019-3-9 13:03 复制 查看全部楼层
@小林a

[ 本帖最后由 福阿德 于 2019-3-9 13:24 编辑 ]

附件

指标本文档.txt [预览]

157 Bytes, 下载次数: 5, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 谢谢老师解答

举报

点亮(0) 扔鸡蛋(0) 回复

网络漫步1
Lv.5
发表于 2019-3-9 12:59 复制 查看全部楼层
@许昌舍得 FILTER这是过滤。过滤了你能跑出股来?

举报

点亮(0) 扔鸡蛋(0) 回复

网络漫步1
Lv.5
发表于 2019-3-9 12:55 复制 查看全部楼层
原帖由 @小林a 于 2019-3-9 12:23 发表 " onmouseover="img_onmouseoverfunc(this)" lazyloadthumb="1" border="0" alt="" />
多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(Z ...

回复.txt [预览] (140 Bytes, 下载次数: 2)

举报

扔鸡蛋(0) 回复

许昌舍得
Lv.6
发表于 2019-3-9 12:39 复制 查看全部楼层
回复:
试试行不行

附件

回复.txt [预览]

164 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

举报

扔鸡蛋(0) 回复

知途迷返
Lv.2
发表于 2019-3-9 12:37 复制 查看全部楼层
原帖由 @小林a 于 2019-3-9 12:23 发表 " onmouseover="img_onmouseoverfunc(this)" lazyloadthumb="1" border="0" alt="" />
多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(Z ...

附件

回复.txt [预览]

215 Bytes, 下载次数: 3, 下载积分: 共享币 -5 个

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表