手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

擒牛神器(指标、主图/副图、通达信、贴图)看趋势擒牛不再是....

[通达信] 精华 1 245个推荐245
设置
156073 121 牛必红红 Lv.2 发表于 · 2019-9-2 17:11 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 石一峰 于 2019-9-2 19:43 编辑

     本人多年从各类指标(技术控早期基本上都是指标迷),到具体的各种理论,道氏,波浪,黄金分割,最后汲取了一些自己觉得不错的观念和方法,还是放弃了,不是不好的问题,而是觉得不适合自己。
      
     个人觉得指标要简单,不能太复杂,太复杂了盘中决策会犹豫,一旦过分的分析就会失去瞬间的机会,所以最后还是落脚在了一些经典的指标上面,比如均线,KDJ,MACD,只是看如何对这些经典的指标进行优化提炼,最后形成自己的经验和技术。

      现在给大家共享一个自己总结出来的多年的常用的“看盘擒牛神器”指标,通过这个指标看趋势,看阻力,支撑,擒牛股,看自己的悟性,悟好了牛股就是很容易的事情了!当然指标不是万能的,还要结合大家自己的盘中实时把控,最后祝大家每天的股票都牛必红红!!



上图!图中最能说明问题了!


附件中全部是源码,包括主图和副图指标,下载后直接解压导入通达信即可!

附件

1.png
2.png
3.png
4.png
5.png
6.png
7.png

擒牛神器主图副图指标.rar

6.83 KB, 下载次数: 301, 下载积分: 共享币 -10 个

本主题由 任务系统 于 2019-10-6 16:30 解除限时高亮
理想18181818
Lv.2
发表于 2019-9-29 20:18 复制 查看全部楼层
全部不加密,为了大家的福利
李牛刀
Lv.2
发表于 2019-9-29 08:43 复制 查看全部楼层
请问在哪里下载
最爱喵喵
Lv.2
发表于 2019-9-27 13:41 复制 查看全部楼层
相互学习相互交流共同进步!!!!!!!
烛光之火
Lv.2
发表于 2019-9-26 16:14 复制 查看全部楼层
根本就不能用,后面的再别下载了,下载了三回都不行。别人指标都可以用,就这个指标通不过。
阿铨
Lv.0
发表于 2019-9-25 17:30 复制 查看全部楼层
顶!顶!顶!
阿铨
Lv.0
发表于 2019-9-25 17:29 复制 查看全部楼层
顶!顶!顶!
阿铨
Lv.0
发表于 2019-9-25 17:28 复制 查看全部楼层
顶!顶!顶!
李04
Lv.1
发表于 2019-9-19 00:51 复制 查看全部楼层
新手报到  ...2
赵发展
Lv.3
发表于 2019-9-18 16:44 复制 查看全部楼层
最好指标直接发,多谢了
木子大哥
Lv.2
发表于 2019-9-18 15:40 复制 查看全部楼层
希望能用,就是不知道有没有未来函数。
端端zz
Lv.2
发表于 2019-9-16 23:55 复制 查看全部楼层
指标不是万能
不羁好男人
Lv.2
发表于 2019-9-16 01:16 复制 查看全部楼层
士大夫撒旦法胜多负少
叽叽侠
Lv.1
发表于 2019-9-15 23:56 复制 查看全部楼层
报错,。。 不能用
叽叽侠
Lv.1
发表于 2019-9-15 23:54 复制 查看全部楼层
不能用,报错
来123456
Lv.1
发表于 2019-9-14 22:45 复制 查看全部楼层
最好直接发,谢
理想890687
Lv.2
发表于 2019-9-13 15:39 复制 查看全部楼层
楼主,怎么改为同花顺的主图指标。
昆仑狼烟起
Lv.2
发表于 2019-9-13 14:48 复制 查看全部楼层
看看。。。。。
黄昏都市人
Lv.4
发表于 2019-9-9 15:27 复制 查看全部楼层
赵银峰 发表于 2019-9-9 15:04
楼主 不行啊  搞得指标 丢三落四的  唉  没救了

75楼  ,金华为,发了正确的啊,你直接去复制他的吧。
赵银峰
Lv.2
发表于 2019-9-9 15:04 复制 查看全部楼层
楼主 不行啊  搞得指标 丢三落四的  唉  没救了
赵银峰
Lv.2
发表于 2019-9-9 15:04 复制 查看全部楼层
黄昏都市人 发表于 2019-9-9 12:38
X_3:=MAX(DYNAINFO(3),DYNAINFO(5));
X_4:=MIN(DYNAINFO(3),DYNAINFO(6));
银河线:=(X_3-X_4);

谢谢你 改好现在通过了
春熙
Lv.0
发表于 2019-9-9 14:38 复制 查看全部楼层
厉害 太专业了
孙老千
Lv.2
发表于 2019-9-9 13:53 复制 查看全部楼层
研究研究作为参考
黄昏都市人
Lv.4
发表于 2019-9-9 12:38 复制 查看全部楼层
赵银峰 发表于 2019-9-8 22:23
{筹码带}
N:=10;
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));

X_3:=MAX(DYNAINFO(3),DYNAINFO(5));
X_4:=MIN(DYNAINFO(3),DYNAINFO(6));
银河线:=(X_3-X_4);
DRAWICON(CROSS(中期,长期线MACP),长期线MACP,23);   


最后一句改一下,文字那里:
DRAWICON(CROSS(中期线,长期线MACP),长期线MACP,23);
独者一线天
Lv.4
发表于 2019-9-9 00:37 复制 查看全部楼层
压力支撑看这象布林轨!
赵银峰
Lv.2
发表于 2019-9-8 22:23 复制 查看全部楼层
黄昏都市人 发表于 2019-9-7 16:04
把源码发上来看看错哪了。

{筹码带}
N:=10;
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TA,21);
VAR81:=REF(CLOSE,N)-REF(ATR,1);
筹码线:=HHV(VAR81,21),COLORYELLOW;
上:=(1+7/100)*筹码线;
下:=(1-7/100)*筹码线;
中:=(上+下)/2;
XGD:DRAWBAND(上,RGB(258,88,1),下,RGB(258,88,1));
{XGD:DRAWBAND(上,RGB(136,30,0),下,RGB(0,0,0));}

UPPER: MA(CLOSE,60)+ 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;
LOWER: MA(CLOSE,60)- 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;
{UPPER90: MA(CLOSE,90)+ 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;
LOWER90: MA(CLOSE,90)- 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;}

{盖住双横杠}
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

{牛熊线}
短期线:EMA(CLOSE,7),COLORWHITE,LINETHICK1;
中期线:EMA(CLOSE,25),COLORFF00FF,LINETHICK1;
长期线MACP:EMA(中期线,55),COLORYELLOW,LINETHICK2;
牛熊分水岭905:EMA(CLOSE,905),COLORRED,LINETHICK3;
大牛控盘线:MA(CLOSE,1650),COLORGREEN,LINETHICK3;


X_3:=MAX(DYNAINFO(3),DYNAINFO(5));
X_4:=MIN(DYNAINFO(3),DYNAINFO(6));
银河线:=(X_3-X_4);
DRAWICON(CROSS(中期,长期线MACP),长期线MACP,23);

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWICON(VAR19 AND C>短期线,L*0.998,1);
DRAWICON(VAR1A,H*1.002,2),NODRAW;

TJ5:=REF("CCI.CCI",1)<-100 AND "CCI.CCI">REF("CCI.CCI",1);
TJ6:=REF("KDJ.J"(9,3,3),1)<20 AND "KDJ.J"(9,3,3)>REF( "KDJ.J"(9,3,3),1);
TJ7:=REF("RSI.RSI1",1)<20 AND "RSI.RSI1">REF("RSI.RSI1",1);
TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);
大底:=CROSS(TJ8,0.5);
DRAWICON(大底,L*0.991,11);


T1:EMA(SLOPE(CLOSE,34)*20+CLOSE,75),COLORYELLOW,NODRAW;
T2:MA(C,120),COLORCYAN,LINETHICK2,NODRAW;
T3:MA(C,250),COLORGREEN,LINETHICK2,NODRAW;
乖离线:=((C-REF(T1,1))/20+T1)*1.20;
TT1:=CROSS(T1,T2)  AND CROSS(T1,T3) AND V>REF(V,1);
TT2:=T1>REF(T1,2) AND V>REF(V,1) AND CROSS(C,T1);
DRAWICON((T2>=REF(T2,1) AND CROSS(C,T1) AND CROSS(C,T2) AND V>REF(V,1)),L*0.997,9);
DRAWICON(TT2,L*0.995,11);
DRAWICON(CROSS(C,乖离线) AND L!=H,H*1.005,12);

N1:=10;
N2:=3;
N3:=6;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
STICKLINE(((HSL * 0.4) >= 0),((HSL/1000) * 1.0),0,1,0),COLORRED,NODRAW;
STICKLINE(((HSL * 0.4) < 0),((HSL/1000) * 1.0),0,1,0),COLORBLUE,NODRAW;
力度: (HSL / 1000),LINETHICK0,NODRAW;
A1:=SUM(力度,N1);
A2:=EMA(A1,N2);
A3:=EMA(A1,N3);
累积能量:A1,NODRAW;
BIAS1:(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,NODRAW;
买:DRAWICON(CROSS(A1,A3) AND C>短期线,L*0.998,1),NODRAW;
卖:DRAWICON(CROSS(A3,A1) AND BIAS1>1,H*1.002,10),NODRAW;


VAR1Y:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2Y:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3Y:=SMA(VAR2Y,2,1);
卖出:100+(-ABS(VAR1Y)),NODRAW;
预防:SMA(VAR3Y,2,1),COLORRED,LINETHICK2,NODRAW;
DRAWICON(CROSS(预防,卖出),H*1.02,2),NODRAW;

VV:=(C+L+H)/3;
DSA:=SMA(EMA(VV,2),2,1)LINETHICK2,COLORRED;
Y396:=DSA;
险1:=Y396*1.1,COLORLIRED;
险2:=Y396*1.125,COLORLIRED;
险3:=Y396*1.15,COLORLIRED;
良1:=Y396*0.9,COLORLIBLUE;
良2:=Y396*0.875,COLORLIBLUE;
良3:=Y396*0.85,COLORLIBLUE;
变色:=IF(Y396<REF(Y396,1),Y396,DRAWNULL),LINETHICK2,COLORBLUE;
{WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;}
{WSR2:=CROSS(WSR1,5);}
{WSR3:=CROSS(8,WSR1);}
{WSR4:=CROSS(WSR1,-5);}
{WSR5:=CROSS(WSR1,-8);}
{WSR6:=WSR3;}
{WSR7:=WSR4 OR WSR5;}
{WSR8:=WSR7 AND FILTER(WSR7,5);}
{WSR10:DRAWICON(WSR8,L-0.01,1);}
{WSR9:=WSR6 AND FILTER(WSR6,5);}
{WSR11:DRAWICON(WSR9,H+0.01,2);}
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
WSR8:=WSR7 AND FILTER(WSR7,5);
WSR10:
DRAWICON(WSR8,L-0.01,1),NODRAW;
WSR9:=WSR6 AND FILTER(WSR6,5);
WSR11:DRAWICON(WSR9,H+0.01,10),NODRAW;
WSR12:=O<良3;
DRAWICON(WSR12 AND FILTER(WSR12,12),L-0.03,9);
W1:=C>REF(C,1) AND MACD<REF(MACD,1) AND MACD>0 AND V<REF(V,1);
W2:=C>REF(C,1) AND MACD<0 AND MACD<REF(MACD,1) AND V<REF(V,1);
XG:=W1 OR W2;
VAR1AA:=AMOUNT/VOL/7;
VAR2AA:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3AA:=SUM(AMOUNT,10)/VAR1AA/7;
VAR4AA:=DMA(VAR2AA,VOL/VAR3AA);
VAR5AA:=(CLOSE-VAR4AA)/VAR4AA*100,COLORLIMAGENTA;
XG1:=CROSS(VAR5AA,MA(VAR5AA,2)) AND VAR5AA<0 AND C<(HHV(H,5)*0.88) AND REF(O>C,1) AND REF(O>C,2);
XG3:=XG AND XG1 AND L<良1;
WSR13:=O>良3 AND L<良1 OR XG3;
DRAWICON(WSR13 AND FILTER(WSR13,10),L-0.03,5);
WSR14:=H>险3;
DRAWICON(WSR14 AND FILTER(WSR14,15),H+0.03,10);
WSR15:=H<险3 AND H>险2;
DRAWICON(WSR15 AND FILTER(WSR15,5),H+0.03,4),NODRAW;


ZLCM:=EMA(WINNER(CLOSE)*70,3),NODRAW;{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100,NODRAW;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100,NODRAW;{//主力控盘筹码比率}
ZZLJJ:=EMA(ZZLKP,89),NODRAW;{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ),NODRAW;{//资金流入强度}
天界:INTPART(ZSHTL),COLORCYAN,LINETHICK2,NODRAW;
凡间:ZJLRQD,LINETHICK2,COLORRED,NODRAW;
DRAWICON(CROSS(天界,凡间),H*1.02,12);


{涨停跌停标记}
C2:=REF(C,1);
       涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
       均价线:=AMOUNT/V/100;
       STICKLINE (涨停, OPEN ,CLOSE,4,0),COLORBLACK;
       STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
      
      
       跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
       STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;


{基本面概况}
DRAWTEXT_FIX(ISLASTBAR,0.0,0,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,GNBLOCK),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,FGBLOCK),COLORWHITE;
竹园径庭
Lv.1
发表于 2019-9-8 21:42 复制 查看全部楼层
金华为
Lv.3
发表于 2019-9-8 20:19 复制 查看全部楼层
{筹码带}
N:=10;
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TA,21);
VAR81:=REF(CLOSE,N)-REF(ATR,1);
筹码线:=HHV(VAR81,21),COLORYELLOW;
上:=(1+7/100)*筹码线;
下:=(1-7/100)*筹码线;
中:=(上+下)/2;
XGD:DRAWBAND(上,RGB(258,88,1),下,RGB(258,88,1));
{XGD:DRAWBAND(上,RGB(136,30,0),下,RGB(0,0,0));}

UPPER: MA(CLOSE,60)+ 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;
LOWER: MA(CLOSE,60)- 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;
{UPPER90: MA(CLOSE,90)+ 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;
LOWER90: MA(CLOSE,90)- 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;}

{盖住双横杠}
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

{牛熊线}
短期线:EMA(CLOSE,7),COLORWHITE,LINETHICK1;
中期线:EMA(CLOSE,25),COLORFF00FF,LINETHICK1;
长期线MACP:EMA(中期线,55),COLORYELLOW,LINETHICK2;
牛熊分水岭905:EMA(CLOSE,905),COLORRED,LINETHICK3;
大牛控盘线:MA(CLOSE,1650),COLORGREEN,LINETHICK3;


X_3:=MAX(DYNAINFO(3),DYNAINFO(5));
X_4:=MIN(DYNAINFO(3),DYNAINFO(6));
银河线:=(X_3-X_4);
DRAWICON(CROSS(中期线,长期线MACP),长期线MACP,23);

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWICON(VAR19 AND C>短期线,L*0.998,1);
DRAWICON(VAR1A,H*1.002,2),NODRAW;

TJ5:=REF("CCI.CCI",1)<-100 AND "CCI.CCI">REF("CCI.CCI",1);
TJ6:=REF("KDJ.J"(9,3,3),1)<20 AND "KDJ.J"(9,3,3)>REF( "KDJ.J"(9,3,3),1);
TJ7:=REF("RSI.RSI1",1)<20 AND "RSI.RSI1">REF("RSI.RSI1",1);
TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);
大底:=CROSS(TJ8,0.5);
DRAWICON(大底,L*0.991,11);


T1:EMA(SLOPE(CLOSE,34)*20+CLOSE,75),COLORYELLOW,NODRAW;
T2:MA(C,120),COLORCYAN,LINETHICK2,NODRAW;
T3:MA(C,250),COLORGREEN,LINETHICK2,NODRAW;
乖离线:=((C-REF(T1,1))/20+T1)*1.20;
TT1:=CROSS(T1,T2)  AND CROSS(T1,T3) AND V>REF(V,1);
TT2:=T1>REF(T1,2) AND V>REF(V,1) AND CROSS(C,T1);
DRAWICON((T2>=REF(T2,1) AND CROSS(C,T1) AND CROSS(C,T2) AND V>REF(V,1)),L*0.997,9);
DRAWICON(TT2,L*0.995,11);
DRAWICON(CROSS(C,乖离线) AND L!=H,H*1.005,12);

N1:=10;
N2:=3;
N3:=6;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
STICKLINE(((HSL * 0.4) >= 0),((HSL/1000) * 1.0),0,1,0),COLORRED,NODRAW;
STICKLINE(((HSL * 0.4) < 0),((HSL/1000) * 1.0),0,1,0),COLORBLUE,NODRAW;
力度: (HSL / 1000),LINETHICK0,NODRAW;
A1:=SUM(力度,N1);
A2:=EMA(A1,N2);
A3:=EMA(A1,N3);
累积能量:A1,NODRAW;
BIAS1:(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,NODRAW;
买:DRAWICON(CROSS(A1,A3) AND C>短期线,L*0.998,1),NODRAW;
卖:DRAWICON(CROSS(A3,A1) AND BIAS1>1,H*1.002,10),NODRAW;


VAR1Y:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
VAR2Y:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
VAR3Y:=SMA(VAR2Y,2,1);
卖出:100+(-ABS(VAR1Y)),NODRAW;
预防:SMA(VAR3Y,2,1),COLORRED,LINETHICK2,NODRAW;
DRAWICON(CROSS(预防,卖出),H*1.02,2),NODRAW;

VV:=(C+L+H)/3;
DSA:=SMA(EMA(VV,2),2,1)LINETHICK2,COLORRED;
Y396:=DSA;
险1:=Y396*1.1,COLORLIRED;
险2:=Y396*1.125,COLORLIRED;
险3:=Y396*1.15,COLORLIRED;
良1:=Y396*0.9,COLORLIBLUE;
良2:=Y396*0.875,COLORLIBLUE;
良3:=Y396*0.85,COLORLIBLUE;
变色:=IF(Y396<REF(Y396,1),Y396,DRAWNULL),LINETHICK2,COLORBLUE;
{WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;}
{WSR2:=CROSS(WSR1,5);}
{WSR3:=CROSS(8,WSR1);}
{WSR4:=CROSS(WSR1,-5);}
{WSR5:=CROSS(WSR1,-8);}
{WSR6:=WSR3;}
{WSR7:=WSR4 OR WSR5;}
{WSR8:=WSR7 AND FILTER(WSR7,5);}
{WSR10:DRAWICON(WSR8,L-0.01,1);}
{WSR9:=WSR6 AND FILTER(WSR6,5);}
{WSR11:DRAWICON(WSR9,H+0.01,2);}
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
WSR8:=WSR7 AND FILTER(WSR7,5);
WSR10:
DRAWICON(WSR8,L-0.01,1),NODRAW;
WSR9:=WSR6 AND FILTER(WSR6,5);
WSR11:DRAWICON(WSR9,H+0.01,10),NODRAW;
WSR12:=O<良3;
DRAWICON(WSR12 AND FILTER(WSR12,12),L-0.03,9);
W1:=C>REF(C,1) AND MACD<REF(MACD,1) AND MACD>0 AND V<REF(V,1);
W2:=C>REF(C,1) AND MACD<0 AND MACD<REF(MACD,1) AND V<REF(V,1);
XG:=W1 OR W2;
VAR1AA:=AMOUNT/VOL/7;
VAR2AA:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3AA:=SUM(AMOUNT,10)/VAR1AA/7;
VAR4AA:=DMA(VAR2AA,VOL/VAR3AA);
VAR5AA:=(CLOSE-VAR4AA)/VAR4AA*100,COLORLIMAGENTA;
XG1:=CROSS(VAR5AA,MA(VAR5AA,2)) AND VAR5AA<0 AND C<(HHV(H,5)*0.88) AND REF(O>C,1) AND REF(O>C,2);
XG3:=XG AND XG1 AND L<良1;
WSR13:=O>良3 AND L<良1 OR XG3;
DRAWICON(WSR13 AND FILTER(WSR13,10),L-0.03,5);
WSR14:=H>险3;
DRAWICON(WSR14 AND FILTER(WSR14,15),H+0.03,10);
WSR15:=H<险3 AND H>险2;
DRAWICON(WSR15 AND FILTER(WSR15,5),H+0.03,4),NODRAW;


ZLCM:=EMA(WINNER(CLOSE)*70,3),NODRAW;{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100,NODRAW;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100,NODRAW;{//主力控盘筹码比率}
ZZLJJ:=EMA(ZZLKP,89),NODRAW;{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ),NODRAW;{//资金流入强度}
天界:INTPART(ZSHTL),COLORCYAN,LINETHICK2,NODRAW;
凡间:ZJLRQD,LINETHICK2,COLORRED,NODRAW;
DRAWICON(CROSS(天界,凡间),H*1.02,12);


{涨停跌停标记}
C2:=REF(C,1);
       涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
       均价线:=AMOUNT/V/100;
       STICKLINE (涨停, OPEN ,CLOSE,4,0),COLORBLACK;
       STICKLINE(涨停,OPEN,CLOSE,3,0),COLORRED;
      
      
       跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
       STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;


{基本面概况}
DRAWTEXT_FIX(ISLASTBAR,0.0,0,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,GNBLOCK),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,FGBLOCK),COLORWHITE;



股市动车
Lv.2
发表于 2019-9-8 20:00 复制 查看全部楼层
比较喜欢
股市动车
Lv.2
发表于 2019-9-8 19:59 复制 查看全部楼层
非常不错
涛涛李
Lv.0
发表于 2019-9-8 02:29 复制 查看全部楼层
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表