手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
RSS
  • 搜帖子

请老师帮忙编写个两个选股指标合并成一个(黄蓝同时出现)

[通达信]
设置
2414 1 最下面 Lv.2 发表于 · 2019-9-11 17:43 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
这是黄色的:

PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
LLJX1:=IF(((HSL * 0.4) +LLJX)<0 ,0,1);
STICKLINE(((HSL * 0.4) >= 0) AND LLJX1,((HSL * 0.4) +LLJX),0,3,0),COLOR00FFFF;{黄}

资金流入:=IF((HSL*0.4+LLJX)>0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;
资金流出:=IF((HSL*0.4+LLJX)<0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;
资金进出:=(HSL*0.4+LLJX),LINETHICK0;
资金流量:=LLJX,LINETHICK0,COLOR0000FF;

黄柱初出蓝:=REF(资金流出,1)<0 AND 资金流入>30 AND C>O AND C>REF(C,1) AND C>MA(C,3);



这是蓝色的

PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN),(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
攻击流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);

资金流入:=IF((HSL*0.4+LLJX)>0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;
资金流出:=IF((HSL*0.4+LLJX)<0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;
资金进出:=(HSL*0.4+LLJX),LINETHICK0;
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
STICKLINE((资金流量 < 0),资金流量,0,3,0),COLORFF3300;
黄柱初出蓝:=REF(资金流出,1)<0 AND 资金流入>30 AND C>O AND C>REF(C,1) AND C>MA(C,3);      



黄 ,蓝这两个一天出现的选出来。
小兵一枚
Lv.2
发表于 2019-9-11 18:16 复制 查看全部楼层
本帖最后由 福阿德 于 2019-9-11 22:03 编辑

供参考

附件

回复.txt [预览]

947 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表