手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师指导一下:如何编写出选股公式?

[通达信]
设置
2291 6 小风1976 Lv.4 发表于 · 2019-9-13 22:53 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA5:MA(C,5),DOTLINE;
MA10:MA(C,10),DOTLINE;
死叉:=BARSLAST(CROSS(MA10,MA5));
金叉:=BARSLAST(CROSS(MA5,MA10));
ZG:=FINDHIGHBARS(H,死叉+1,5,1);
ZD:=FINDLOWBARS(L,金叉+1,5,1);
A:REF(H,BARSLAST(CURRBARSCOUNT=CONST(ZG)+1)),COLORRED;
B:REF(L,BARSLAST(CURRBARSCOUNT=CONST(ZD)+1)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=CONST(ZG)+1,H,'死叉5天前最高'),COLORYELLOW,DRAWABOVE;
DRAWTEXT(CURRBARSCOUNT=CONST(ZD)+1,L,' 金叉5天前最低'),COLORYELLOW,DRAWABOVE;
DRAWTEXT(CURRBARSCOUNT=CONST(死叉)+1,MA5*1.01,'死叉'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=CONST(金叉)+1,MA5*0.99,'金叉'),COLORRED;
DRAWICON(COUNT(C>A,ZG)=1 AND C>A AND C/B<1.2,H,1);

如何编写出最后一句作为选股公式!
小风1976
Lv.4
发表于 2019-9-15 22:20 复制 查看全部楼层
老鼠KK 发表于 2019-9-15 06:00
ZD:=FINDLOWBARS(L,金叉+1,5,1);
源码中上一句含DLOW,信号会漂移,按  46  可以沙盘推演一下,会发现漂移 ...

111.JPG
谢谢您的回复!图示603308在8月29日突破了死叉5天前最高,在当天做了标记。
我选股要求是选出突破了死叉5天前最高的股票!
再次感谢您!
老鼠KK
Lv.3
发表于 2019-9-15 06:00 复制 查看全部楼层
本帖最后由 老鼠KK 于 2019-9-15 06:22 编辑

ZD:=FINDLOWBARS(L,金叉+1,5,1);
源码中上一句含DLOW,信号会漂移,按  46  可以沙盘推演一下,会发现漂移现象。但某些检测软件,不能发现该未来函数,比如通达信自身检测功能就不能发现该未来函数。
因此,慎用。
但可以配合其他高胜率指标,借以发现新的低点。

可以将公式稍作修改,显示更加直观,修改后的显示完全不一样。

MA5:=MA(C,5),DOTLINE;
MA10:=MA(C,10),DOTLINE;
死叉:=BARSLAST(CROSS(MA10,MA5));
金叉:=BARSLAST(CROSS(MA5,MA10));
ZG:=FINDHIGHBARS(H,死叉+1,5,1);
ZD:=FINDLOWBARS(L,金叉+1,5,1);
A:=REF(H,BARSLAST(CURRBARSCOUNT=CONST(ZG)+1)),COLORRED;
B:=REF(L,BARSLAST(CURRBARSCOUNT=CONST(ZD)+1)),COLORGREEN;
{DRAWTEXT(CURRBARSCOUNT=CONST(ZG)+1,H,'死叉5天前最高'),COLORYELLOW,DRAWABOVE;
DRAWTEXT(CURRBARSCOUNT=CONST(ZD)+1,L,' 金叉5天前最低'),COLORYELLOW,DRAWABOVE;
DRAWTEXT(CURRBARSCOUNT=CONST(死叉)+1,MA5*1.01,'死叉'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=CONST(金叉)+1,MA5*0.99,'金叉'),COLORRED;
DRAWICON(COUNT(C>A,ZG)=1 AND C>A AND C/B<1.2,H,1);}

XG:(CURRBARSCOUNT=CONST(ZD)+1)*5 COLORRED  LINETHICK5;


亦可用作选股

附件

ceshi.gif
无标题.png
小风1976
Lv.4
发表于 2019-9-14 21:42 复制 查看全部楼层

谢谢您的回复!您的选股公式和我自己试做的是一样的,但是选不出股不是我想要的!
休闲者68
Lv.6
发表于 2019-9-14 08:02 复制 查看全部楼层
本帖最后由 福阿德 于 2019-9-14 13:42 编辑

供参考

附件

回复.txt [预览]

312 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
风之风。
Lv.5
发表于 2019-9-14 01:29 复制 查看全部楼层
#在这里快速回复#MA5:=MA(C,5); MA10:=MA(C,10); 死叉:=BARSLAST(CROSS(MA10,MA5)); 金叉:=BARSLAST(CROSS(MA5,MA10)); ZG:=FINDHIGHBARS(H,死叉+1,5,1); ZD:=FINDLOWBARS(L,金叉+1,5,1); A:=REF(H,BARSLAST(CURRBARSCOUNT=CONST(ZG)+1)),COLORRED; B:=REF(L,BARSLAST(CURRBARSCOUNT=CONST(ZD)+1)),COLORGREEN;  DRAWICON(COUNT(C>A,ZG)=1 AND C>A AND C/B<1.2,H,1);
查看全部打赏
  • 福阿德+5理想币 +5共享币 : 赠人玫瑰,手有余香。
风之风。
Lv.5
发表于 2019-9-14 01:28 复制 查看全部楼层
MA5:=MA(C,5); MA10:=MA(C,10); 死叉:=BARSLAST(CROSS(MA10,MA5)); 金叉:=BARSLAST(CROSS(MA5,MA10)); ZG:=FINDHIGHBARS(H,死叉+1,5,1); ZD:=FINDLOWBARS(L,金叉+1,5,1); A:=REF(H,BARSLAST(CURRBARSCOUNT=CONST(ZG)+1)),COLORRED; B:=REF(L,BARSLAST(CURRBARSCOUNT=CONST(ZD)+1)),COLORGREEN;  DRAWICON(COUNT(C>A,ZG)=1 AND C>A AND C/B<1.2,H,1);
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表