手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把这个通达信指标改成大智慧选股指标(源代码)

[大智慧]
设置
4316 8 健康快乐T Lv.2 发表于 · 2019-10-13 00:54 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

老师帮忙把下面这个通达信指标改成大智慧选股指标(源代码),谢谢!


要求:下面是通达信日K线多指标金叉副图源代码,请老师们帮我改写成大智慧的多指标金叉副图源代码,
并编写一个30分钟K线多指标金叉选股公式源代码(一定要30分钟的)。

如附图中所示,当副图30分钟K线 指标内 满足“涨买入”条件,选股。(编写一个大智慧的30分钟K线的多指标金叉看涨信号选股指标源代码)


通达信日K线多指标金叉副图源代码如下:


DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
A1:=DIFF>DEA;
MACD金叉:IF(A1,1,0),COLORRED;
RSV1:=(CLO//SE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
DRAWICON(K>D,1,1);
DRAWICON(K<D,1,2);
DRAWTEXT(ISLASTBAR=1,1,'.KDJ'),COLORFFFFFF;
A2:=K>D;
KDJ金叉:IF(A2,2,0),COLORRED;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
DRAWICON(RSI1>RSI2,2.5,1);
DRAWICON(RSI1<RSI2,2.5,2);
DRAWTEXT(ISLASTBAR=1,2.5,'.RSI'),COLORFFFFFF;
A3:=RSI1>RSI2;
RSI金叉:IF(A3,3,0),COLORRED;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
DRAWICON(LWR1>LWR2,4,1);
DRAWICON(LWR1<LWR2,4,2);
DRAWTEXT(ISLASTBAR=1,4,'.LWR'),COLORFFFFFF;
A4:=LWR1>LWR2;
LWR金叉:IF(A4,4,0),COLORRED;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DRAWICON(CLOSE>BBI,5.5,1);
DRAWICON(CLOSE<BBI,5.5,2);
DRAWTEXT(ISLASTBAR=1,5.5,'.BBI'),COLORFFFFFF;
A5:=CLOSE>BBI;
BBI金叉:IF(A5,5,0),COLORRED;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
DRAWICON(MMS>MMM,7.5,1);
DRAWICON(MMS<MMM,7.5,2);
DRAWTEXT(ISLASTBAR=1,7,'.MTM'),COLORFFFFFF;
A6:=MMS>MMM;
MTM金叉:IF(A6,6,0),COLORRED;
涨买入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0),COLORYELLOW,LINETHICK2;
上涨:IF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,7,0),COLORYELLOW,LINETHICK2;
晴天:BARSLASTCOUNT(A1 AND A2 AND A3 AND A4 AND A5 AND A6),LINETHICK0;
雨天:BARSLASTCOUNT(MACD金叉+KDJ金叉+RSI金叉+LWR金叉+BBI金叉+MTM金叉>0 AND MACD金叉+KDJ金叉+RSI金叉+LWR金叉+BBI金叉+MTM金叉<21 ),LINETHICK0;
雪天:BARSLASTCOUNT(MACD金叉+KDJ金叉+RSI金叉+LWR金叉+BBI金叉+MTM金叉=0),LINETHICK0;


附件

通达信30分钟K线的多指标金叉看涨.

通达信30分钟K线的多指标金叉看涨.

相关股票

注册111
Lv.6
发表于 2019-10-13 07:59 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 22:24 编辑

供参考

附件

回复.txt [预览]

2.61 KB, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
健康快乐T
Lv.2
发表于 2019-10-13 07:57 复制 查看全部楼层
拜托各位老师了!
健康快乐T
Lv.2
发表于 2019-10-13 00:57 复制 查看全部楼层
请老师帮忙把这个通达信指标改成大智慧选股指标(源代码),谢谢!
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表