手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式

[通达信]
设置
2980 7 德农种业 Lv.3 发表于 · 2019-10-14 13:40 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DRAWGBK(CURRBARSCOUNT=1 , RGB(0,0,0),RGB(0,0,0),0,'1',0);
{DRAWGBK(ISLASTBAR, RGB(2,0,0),RGB(100,100,100),0,'0',0);}
MA(H,M) * (1 + 13 / 100) * 1.0382,LINETHICK1,COLORYELLOW;
MA(H,M) * (1 + 13 / 100),LINETHICK1,COLORYELLOW;
EMA(L,30) * (1 - 15 / 100),COLORGREEN;
EMA(L,30) * (1 - 15 / 100) * 0.82,LINETHICK1,COLORGREEN;
GUAIXIANTAITOU:(EMA(C,5) * 7 + EMA(C,10) * 3) / 10,LINETHICK2,COLORWHITE;
A1:=(H + L + O + C) / 4;
A2:=EMA(A1,13) - EMA(A1,34);
A3:=EMA(A2,5);
A4:=(A2 - A3) * 5;
A5:=IF(A4 >= 1000,1000,IF(A4 <= A1,A1,A4));
A6:=FORCAST(FORCAST(A5,32),10);
A7:=(C - EMA(C,13)) / EMA(C,13) * (0 - 100);
A8:=EMA(A7 / 10 + EMA(C,13),8);
A9:=EMA(C,3);
A10:=EMA(SLOPE(C,22) * 20 + C,45);
A11:=IF(PERIOD >8 AND PERIOD < 11,MA(A10,1),IF(PERIOD = 8,MA(A10,4),IF(PERIOD = 7,MA(A10,8),IF(PERIOD = 6,MA(A10,16),IF(PERIOD = 5,MA(A10,32),0)))));
A12:=A11 * 0.865;
A13:=IF(A9 > A11,A9,A12);
买卖线:REVERSE(A13) + 2 * A6,LINETHICK1, COLORMAGENTA;
DRAWTEXT(ISLASTBAR,买卖线,'  ←买卖线'),COLORMAGENTA;
拐点:IF(EMA((1 - C / SMA(C,5,1)) * 100 * C / 100 + EMA(C,13),9) < GUAIXIANTAITOU AND GUAIXIANTAITOU > 买卖线,EMA((1 - C / SMA(C,5,1)) * 100 * C / 100 + EMA(C,13),9),GUAIXIANTAITOU),LINETHICK2, COLORRED  ;
IF(GUAIXIANTAITOU <= 买卖线,GUAIXIANTAITOU,DRAWNULL),LINETHICK3,COLORGREEN;
DRAWTEXT(ISLASTBAR,拐点,'  ←开口主升线'),COLORRED;
A14:=C * V;
A15:=EMA((EMA(A14,3) / EMA(V,3) + EMA(A14,6) / EMA(V,6) + EMA(A14,12) / EMA(V,12) + EMA(A14,24) / EMA(V,24)) / 4,13);
A16:=1.06 * A15;
A17:=(C - REF(C,1)) / REF(C,1) * 100 > 8.5;
A18:=EMA(H,10) * (1 + 5 / 100);
捉妖:CROSS(GUAIXIANTAITOU,MA(H,30) * (1 + 13 / 100)) * 10,NODRAW;
A19:=(C - O) / REF(C,1) * 100;
A20:=REF(H,N) = HHV(H,2 * N + 1);
A21:=FILTER(A20,N);
A22:=BACKSET(A21,N + 1);
A23:=FILTER(A22,N);
A24:=REF(L,N) = LLV(L,2 * N + 1);
A25:=FILTER(A24,N);
A26:=BACKSET(A25,N + 1);
A27:=FILTER(A26,N);
A28:=(REF(LLV(L,2 * N),1) + REF(HHV(H,2 * N),1)) / 2;
A29:=(H + L) / 2;
A30:=(A23 AND NOT(A27 AND A28 >= A29)) OR ISLASTBAR OR BARSCOUNT(C) = 1;
A31:=A27 AND NOT(A23 AND A28 < A29);
A32:=REF(BARSLAST(A30),1) + 1;
A33:=BACKSET(A30 AND COUNT(A31,A32) > 0,LLVBARS(IF(A31,L,10000),A32));
A34:=A33 > REF(A33,1);
A35:=BACKSET(A34,2);
A36:=A35 > REF(A35,1);
A37:=A36 OR ISLASTBAR OR BARSCOUNT(C) = 1;
A38:=REF(BARSLAST(A37),1) + 1;
A39:=BACKSET(A37 AND COUNT(A23 AND NOT(A27 AND A28 >= A29),A38) > 0,HHVBARS(IF(A23 AND NOT(A27 AND A28 >= A29),H,0),A38));
A40:=A39 > REF(A39,1);
A41:=BACKSET(A40,2);
A42:=A41 > REF(A41,1);
A43:=BACKSET(ISLASTBAR,BARSLAST(A42) + 1);
A44:=A43 > REF(A43,1);
A45:=BACKSET(A44,REF(BARSLAST(A42),1) + 2);
A46:=A45 > REF(A45,1);
短期压力:DRAWLINE(A46,H,A44,H,1),LINETHICK2,COLORRED;
STICKLINE(GUAIXIANTAITOU >= 买卖线,C,H,0,0),COLORRED;
STICKLINE(GUAIXIANTAITOU >= 买卖线 AND C > O,C,O,2.5,1),COLORRED;
STICKLINE(GUAIXIANTAITOU >= 买卖线,L,O,0,0),COLORRED;
STICKLINE(GUAIXIANTAITOU >= 买卖线 AND C <= O,O,C,3,1),COLORRED;
STICKLINE(GUAIXIANTAITOU >= 买卖线 AND C <= O,O,C,1,0),COLORAAAA00;
STICKLINE(GUAIXIANTAITOU < 买卖线 AND C <= O,C,O,1.5,0),COLORCYAN;
STICKLINE(GUAIXIANTAITOU < 买卖线 AND C <= O,O,H,0,0),COLORCYAN;
STICKLINE(GUAIXIANTAITOU < 买卖线 AND C <= O,L,C,0,0),COLORCYAN;
STICKLINE(GUAIXIANTAITOU < 买卖线 AND C >= O,L,O,0,0),COLORCYAN;
STICKLINE(GUAIXIANTAITOU < 买卖线 AND C >= O,C,H,0,0),COLORCYAN;
STICKLINE(GUAIXIANTAITOU < 买卖线 AND C >= O,O,C,2.5,1),COLORCYAN;
STICKLINE(A17 > 0 AND CROSS(MA(C,1),A18) AND CROSS(MA(C,1),A16),(L + H + O) / 3,O,3,0),COLORRED;
STICKLINE(A17 > 0 AND CROSS(MA(C,1),A18) AND CROSS(MA(C,1),A16),(H + O) / 2,C,3,0),COLORYELLOW;
STICKLINE(A17 > 0 AND CROSS(MA(C,1),A18) AND CROSS(MA(C,1),A16),(H + O) / 2,(L + H + O) / 3,3,0),COLORFF0000;
STICKLINE(CROSS(GUAIXIANTAITOU,MA(H,30) * (1 + 13 / 100)),MA(H,30) * (1 + 13 / 100),MA(H,30) * (1 + 13 / 100) * 1.0052,8,0),COLORYELLOW;
STICKLINE(C >= REF(C,1) * 1.095 AND C = O AND L < C,C,O,5,0),COLORWHITE;
STICKLINE(C >= REF(C,1) * 1.095 AND C = O AND L < C,C,L,0,0),COLORWHITE;
STICKLINE(A19 > 7.5 AND REF(A19,1) < -5 AND C > REF(O,1),H,L,0,0),COLORFF0099;
STICKLINE(A19 > 7.5 AND REF(A19,1) < -5 AND C > REF(O,1),C,O,3,0),COLORFF0099;
DRAWTEXT(CROSS(GUAIXIANTAITOU,买卖线),L*0.98,'B'),LINETHICK3,COLORYELLOW;
DRAWTEXT(CROSS(买卖线,GUAIXIANTAITOU),H * 1.02,'S'),LINETHICK3,COLORGREEN;
DRAWTEXT(FILTER(CROSS(GUAIXIANTAITOU,EMA((1 - C / SMA(C,5,1)) * 100 * C / 100 + EMA(C,13),9)),10),GUAIXIANTAITOU,'拐点'),COLORYELLOW;
DRAWTEXT(A17 > 0 AND CROSS(MA(C,1),A18) AND CROSS(MA(C,1),A16),(H + O) / 2,'追▲击'),LINETHICK1,COLORYELLOW;
DRAWTEXT(FILTER(CROSS(GUAIXIANTAITOU,MA(H,30) * (1 + 13 / 100)),5),MA(H,30) * (1 + 13 / 100) * 0.98,'捉妖'),COLORYELLOW;


拐点  追击  捉妖 三个选股指标谢谢老师
影库
Lv.4
发表于 2019-10-14 15:20 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:49 编辑

供参考

附件

回复.txt [预览]

297 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

影库
Lv.4
发表于 2019-10-14 15:19 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:48 编辑

供参考

附件

回复.txt [预览]

127 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

飞远国际
Lv.6
发表于 2019-10-14 15:18 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:45 编辑

供参考

附件

回复.txt [预览]

127 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

彭林炜
Lv.3
发表于 2019-10-14 15:17 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:46 编辑

供参考

附件

回复.txt [预览]

1.08 KB, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
影库
Lv.4
发表于 2019-10-14 15:17 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:47 编辑

供参考

附件

回复.txt [预览]

158 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
飞远国际
Lv.6
发表于 2019-10-14 15:16 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:44 编辑

供参考

附件

回复.txt [预览]

297 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

飞远国际
Lv.6
发表于 2019-10-14 15:13 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-14 21:44 编辑

供参考

附件

回复.txt [预览]

158 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表