手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把这个通达信主图指标改成大智慧30分钟选股指标(源代码)

[大智慧]
设置
2278 3 健康快乐T Lv.2 发表于 · 2019-10-15 12:53 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

老师帮忙把这个通达信主图指标改成大智慧30分钟选股指标(源代码),谢谢!

要求:下面是通达信量能饱和度主图源代码,请老师们帮我改写成大智慧的量能饱和度主图源代码,
并编写一个大智慧的30分钟量能饱和度主图选股公式源代码(一定要30分钟的)。

如附图中所示,当通达信量能饱和度主图30分钟K线 指标内 满足“量能饱和度:100”条件,选股。
(即编写一个大智慧的30分钟量能饱和度满足“量能饱和度:100”条件的选股公式源代码)


通达信量能饱和度主图源代码如下:



{30分钟MA}
量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW;
MA4:MA(C,4),COLORBLUE,LINETHICK4;
A8:MA(C,8),COLORRED;
A24:MA(C,24),COLORRED;
A40:MA(C,40);
A80:MA(C,80);
A160:MA(C,160);
DK:=A8;
买:IF(MA4>REF(MA4,1),MA4,DRAWNULL),COLORRED,LINETHICK4;
卖:IF(MA4<REF(MA4,1),MA4,DRAWNULL),COLORGREEN,LINETHICK4;
今日保护价:(REF(C,1)+REF(C,2)+O)/3,NODRAW;
STICKLINE(DK<=C AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORRED;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,3.2,0),COLOR6600FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,2.7,0),COLORDD33FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,2.1,0),COLORFF55FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,1.5,0),COLORFF88FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,0.9,0),COLORFFAAFF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,0.3,0),COLORFFCCFF;
STICKLINE(DK<=C AND CLOSE<OPEN,HIGH,LOW,0,1),COLORRED;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,3.2,0),COLOR000033;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,2.7,0),COLOR000066;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,2.1,0),COLOR000099;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,0.9,0),COLOR0000FF;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,0.3,0),COLORCC66FF;
STICKLINE(DK>C AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORGREEN;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,3.2,0 ),COLOR990000;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,2.7,0 ),COLORCC0000;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,2.1,0),COLORFF4400;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,1.5,0 ),COLORFF8800;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,0.9,0 ),COLORFFCC00;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,0.3,0 ),COLORCYAN;
STICKLINE(DK>C AND CLOSE<OPEN,HIGH,LOW,0,1),COLORWHITE;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,3.2,0 ),COLOR555555;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,2.7,0 ),COLOR777777;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,2.1,0 ),COLOR999999;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,1.5,0 ),COLOR999999;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,0.9,0 ),COLORDDDDDD;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,0.3,0 ),COLORFFFFFF;
















附件

通达信30分钟量能饱和度主图001

通达信30分钟量能饱和度主图001
健康快乐T
Lv.2
发表于 2019-10-15 14:01 复制 查看全部楼层
闹海老龙神 发表于 2019-10-15 13:06
{供参考}
量能饱和度:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20 ...


谢谢老师的帮助,好人必有好报!

闹海老龙神
Lv.5
发表于 2019-10-15 13:06 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-16 09:17 编辑

{供参考}

附件

回复.txt [预览]

142 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
健康快乐T
Lv.2
发表于 2019-10-15 12:54 复制 查看全部楼层

请老师帮忙把这个通达信主图指标改成大智慧30分钟选股指标(源代码),谢谢!


您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表