手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
RSS

请老师帮助编写下面通达信公式的预警公式

[通达信]
设置
2248 2 我叫火太阳 Lv.2 发表于 · 2019-10-15 23:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
DRAWTEXT_FIX(1,0,100,0,'★寻找妖股直播室★'),COLORYELLOW;

B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
个股红:=B2>SMA2;
个股绿:=B2<SMA2;
IF(个股红,B2,DRAWNULL),COLORRED,LINETHICK2;
IF(个股绿,B2,DRAWNULL),COLORGREEN,LINETHICK1;
王子控盘线:HHV(MA(B2,1),13),COLORYELLOW,DOTLINE;


HM1:=ABS((3.48*C+H+L)/4-EMA(C,20)/EMA(C,20)); HM2:=DMA((2.15*C+L+H)/4,HM1);
王子强弱线:EMA(HM2,200)*1.118,LINETHICK2,COLORMAGENTA;
J1:=MA(C,5);
J2:=MA(C,10);
J3:=MA(C,30);
J4:=MA(C,60);
J5:=MA(C,120);
时间:=BARSLAST((((CROSS(J2,J1) AND (J2 > J3)) AND (J3 > J4)) AND (J4 > J5)));
前高:=REF(HHV(C,200),时间);
PT:=REFDATE(前高,DATE);


N:=20;
MIDA:=MA(C,N);
VART1:=POW((C - MIDA),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPERA:=(MIDA + (2 * VART3));
LOWERA:=(MIDA - (2 * VART3));
长线:=MA(C,133),LINETHICK2,COLORC0C0C0;
XX:=HHV(EMA(H,75),100);
中线:=IF((XX > REF(XX,1)),XX,DRAWNULL),LINETHICK2,COLORCYAN;
短线:=EMA(REF(MIDA,1),2),LINETHICK2,COLORFF6EC7;
平台:IF((短线 > 长线),PT,DRAWNULL),COLORRED,LINETHICK2;


ZF:=(((C - REF(C,1)) / REF(C,1)) * 100);
S1:=(((L > REF(H,1)) OR (ZF > 9.6)) OR (REF(ZF,1) > 9.6));
强势预选:=((CROSS(C,PT) AND (S1 > 0)) * 8);
我叫火太阳
Lv.2
发表于 2019-10-16 10:34 复制 查看全部楼层
谢谢帮编写预警指标!
注册111
Lv.6
发表于 2019-10-16 07:45 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-16 17:30 编辑

看看那个是要的。

附件

回复.txt [预览]

694 Bytes, 下载次数: 3, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表