手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这个幅图里面的买入做个选股指标

[通达信]
设置
3369 2 戏水红蜓 Lv.4 发表于 · 2019-10-16 12:56 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{五指共振}
DRAWGBK(O>C,RGB(40,40,40),RGB(0,0,40),0,'01',0);    {背景不要可删除}
{1指.能量线}
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
{2指.RSI}
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK0;
{3指.KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D,LINETHICK0;
{4指.W&R}
威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
{5指.CCI}
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;

五指A:WMA((能量线+RSI+J-威廉WR+CCI)/5,5);
五指B:WMA((能量线+RSI+J-威廉WR+CCI)/5,13);
DRAWBAND(五指A,RGB(255,155,0),五指B,RGB(0,40,255));
WMA((能量线+RSI+J-威廉WR+CCI)/5,5),COLOR00FF00,LINETHICK3;
IF(五指A>REF(五指A,1),五指A,DRAWNULL),COLOR0000FF,LINETHICK3;


DRAWTEXT_FIX(1,0.02,0,0,'◆能量线,RSI3.KDJ,W&R,CCI,【五个指标共振线.[红].[绿].变化是买卖信号.颜色及标记是配合信号】'),COLOR00FFFF,LINETHICK3;


KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:=AAX3>3  AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
DRAWTEXT(VBA,五指A*1.08,'★卖出'),COLOR0044FF;

VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
DRAWTEXT(VB4,五指A*0.97,'★买入'),COLOR00FFFF;
戏水红蜓
Lv.4
发表于 2019-10-16 13:22 复制 查看全部楼层
谢谢  /thx
老马识途10
Lv.7
发表于 2019-10-16 13:04 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-16 19:38 编辑

供参考

附件

回复.txt [预览]

181 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表