手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙把两个选股合成一个

[通达信]
设置
2719 4 狼要吃肉 Lv.2 发表于 · 2019-10-18 14:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
选股
       
N:=5;
VAR1:=4*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,5,1)-
3*SMA(SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,5,1),3.2,1);
HJ_1:=REF(LOW,1);
HJ_2:=SMA(ABS(LOW-HJ_1),13,1)/SMA(MAX(LOW-HJ_1,0),13,1)*100;
HJ_3:=EMA(IF(CLOSE*1.2,HJ_2*13,HJ_2/13),13);
HJ_4:=LLV(LOW,34);
HJ_5:=HHV(HJ_3,34);
HJ_6:=IF(LLV(LOW,55),1,0);
HJ_7:=EMA(IF(LOW<=HJ_4,(HJ_3+HJ_5*2)/2,0),3)/618*HJ_6;
HJ_8:=HJ_7>REF(HJ_7,1);
HJ_9:=HJ_8>REF(HJ_8,1);
启动点:=HJ_9>REF(HJ_9,1) AND VAR1>REF(VAR1,1);


N2:=90;M:=3;
低:=REF(LLV(L,N2),M);
低点:=REFDATE(低,DATE);
绝底启动点:低点=L AND ((C-L)>(0-C) OR (O-L)>(C-O)) AND 启动点;


选股二
M5F:=MA(C,4);
M10F:=MA(C,8),COLORRED,LINETHICK2;
M20F:=MA(C,20);
M60F:=MA(C,60),COLORBLUE,LINETHICK2;
D3:=MIN(MIN(M5F,M10F),M20F)>M60F;
LLM:=LLV("MACD.MACD"*100,200);
HHM:=HHV("MACD.MACD"*100,200);
TJA:=C>REF(C,1)*1.05;
T:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
AAF1:=REF(T,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
选股1:=CROSS(AAF1,9.8);
A11F:=REF(V,1);
VAR8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))))>2;
A13F:=VAR8/A11F;
AA3F:=(A13F-REF(A13F,1));
选股2:=CROSS(AA3F,500);
潜伏2:=选股1 AND 选股2;
XGT:=BARSLAST(AAF1 AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5F,M10F),M20F)>M60F,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJJ:=COUNT(XGX,30)=2 AND XGX;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=REF(SR2,10+1);
HDF:=REF(SR3,10);
前高:=REF(H,BARSLAST(HDF));
倍量:=VOL/REF(VOL,1)>=1.9;
突破前高:=CROSS(C,前高);
YG:= 倍量 AND 突破前高;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
SJ:=BARSLAST(YG);
DIF:=MACD.DIF;
H300:=HHVBARS(DIF,300);
AL:=BOLL.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EXPMA(C,25);
ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;
躁动:=TJ1Q AND XL>75;
GX:=潜伏2 OR 躁动 OR CURRBARSCOUNT=CONST(SJ)+2 OR TJJ OR (CCI<=100 AND L<=低2);
潜伏:FILTER(GX=1,3);
本主题由 任务系统 于 2019-10-18 14:46 审核通过
闹海老龙神
Lv.5
发表于 2019-10-18 14:52 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-18 21:57 编辑

{供参考}

附件

回复.txt [预览]

2.32 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
  • 狼要吃肉+2理想币 +2共享币 : 感谢交流,感恩分享,收获正能量。
老马识途10
Lv.7
发表于 2019-10-18 14:51 复制 查看全部楼层
本帖最后由 老马识途10 于 2019-10-18 15:04 编辑

删除重复。
查看全部打赏
  • 狼要吃肉+2共享币 : 很给力,理想因你而精彩;
老马识途10
Lv.7
发表于 2019-10-18 14:51 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-18 21:56 编辑

供参考

附件

回复.txt [预览]

2.35 KB, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
  • 狼要吃肉+4理想币 +2共享币 : 很给力,理想因你而精彩;
许昌舍得
Lv.6
发表于 2019-10-18 14:50 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-18 21:55 编辑

供参考

附件

回复.txt [预览]

2.38 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表