手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改一下:使公式触发条件后的当时的价格显示在主图顶栏上

[通达信]
设置
2490 2 波波学股 Lv.4 发表于 · 2019-10-18 23:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
求助老师,我想把下面的 :风险 ,加二,强势阻击,清仓 显示在顶栏上,就像动力线这三线一样的会有价格显示出来。 正常的我知道是把=号去掉就可以,但这几个把=号去掉显示的是0.00 ,和1 。 我想显示的是当它到了这个公式触发条件后的当时的价格显示在主图顶栏上。求老师帮忙。下图原码。
我是想把那个,比如说 在主图上显示了 加仓它显示的是1.00出信号了。 我想要的是在这个1.00改成它出信号时候的价格。



动力线:MA(C,5),LINETHICK1,COLOR00CCFF;

牛熊线:MA(C,13),DOTLINE,COLORYELLOW;

生命线:MA(C,34),DOTLINE,COLORMAGENTA;

MA05:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

五日乖离率:=(C-MA05)/MA05*100;

BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;

IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK1,COLORRED;

BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK1,COLORGREEN;

三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;

VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);

BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;

清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);

DRAWTEXT(加仓 ,LOW*0.98,'◆加二'),COLORYELLOW;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;

买入:=FILTER(MR,10);

DRAWTEXT(减仓,HIGH*1.02,'◆风险'),COLORCYAN;

DRAWTEXT(买入,LOW*0.96,'◆买二'),COLORYELLOW;

DRAWTEXT(清仓,HIGH*1.00,'◆清仓'),COLORGREEN;

DRAWTEXT(强势狙击,LOW*1.00,'◆强势狙击'),COLORGREEN;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);

MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
缩螺丝
Lv.6
发表于 2019-10-19 13:53 复制 查看全部楼层
看看搬来的砖能不能用
A1:=IF(加仓=1,1,0);

加仓位置:=BARSLAST(A1);

加仓价格:REF(C,加仓位置);
注册111
Lv.6
发表于 2019-10-19 07:42 复制 查看全部楼层
本帖最后由 注册111 于 2019-10-19 07:43 编辑

这指标前二天我改过。在改过后叠加上下面原码:
A1:=IF(加仓=1,1,0);
加仓价格:C*A1,NODRAW;
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表