手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助在图中绿色变红色做个选股预警

[通达信]
设置
2779 5 快乐天天乐 Lv.4 发表于 · 2019-10-21 10:58 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
WY1001:=(2*CLOSE+HIGH+LOW)/3;
WY1002:=EMA(WY1001,3);
WY1003:=EMA(WY1002,3);
WY1004:=EMA(WY1003,3);
XYS0:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;
STICKLINE(XYS0>=0,XYS0,0,2,0),COLORRED;
STICKLINE(XYS0<0,XYS0,0,2,0),COLORGREEN;
PJGJ:=AMOUNT/VOL/100;
SSRYDJX:=MA(PJGJ,13);
SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=SSRCJE/SSRCJL/100;
CYS13:=(CLOSE-SSRCBJX)/SSRCBJX*100;
XYSHSL:=EMA(VOL/CAPITAL*100,13);
STICKLINE(XYSHSL>6.1 AND CYS13>5 ,2 ,0 ,1.2,0 ),COLORGREEN;
STICKLINE(XYSHSL>3.8 AND CYS13>5 ,1.5 ,0 ,1.2 ,0 ),COLORYELLOW;
STICKLINE(XYSHSL>2.1 AND CYS13>5 ,1 ,0 ,1.2 ,0 ),COLORCYAN;
STICKLINE(XYSHSL>1.8 AND CYS13>5 ,0.5 ,0 ,1.2 ,0 ),COLORBLUE;

{百日低量群}
均量日:=20; {可调节5-20}
MAV:=MA(V,均量日);
MAC:=MA(C,均量日);
百日低量群:= MAV=LLV(MAV,100) AND BARSCOUNT(V)>=100;
DRAWTEXT(FILTER(百日低量群,4),0.99,'低量群'),COLORCBCBC0,LINETHICK1;

{黄金柱 绿色箭头}
{看图说明:绿色箭头(的前三天)为黄金柱}
倍数:=1.9;
倍量:=VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1));
真阳或假阴:=C>O OR C>REF(C,1);
收阳:= REF(真阳或假阴,3);
倍量1:=REF(倍量,3);
高量:=REF(V,3)>=HHV(V,7);
三日不破:= LLV(C,3)>=REF(L,3);
价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}
量缩:=COUNT(V<=REF(V,1),3)=3;
连阳:= COUNT(真阳或假阴,3)=3;
倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;
高量将军柱:= 高量 AND 三日不破 AND 收阳;
将军柱:= 倍量将军柱 OR 高量将军柱;
黄金柱:= 将军柱 AND 价升 AND 量缩 AND 连阳 ;
DRAWICON(黄金柱,1.5,2);

{预定黄金柱 红色箭头}
预定黄金柱: DRAWICON(REF(V,2)>=REF(V,3)*1.99 AND REF(C,2)>REF(O,2) AND
REF(V,2)=HHV(V,3) AND C/REF(C,2) >=1.0995 AND REF(L,2)=LLV(L,3),1.5,1);

捕捞线:MA(XYS0,1),COLOREA91B5,COLORRED;
季节线:MA(XYS0,2),COLORYELLOW,LINETHICK1;
今柱:XYS0,COLORRED,NODRAW,LINETHICK1;
昨柱:REF(今柱,1),COLORGREEN,NODRAW,LINETHICK1;
倍柱:今柱/昨柱,COLOR00FFFF,NODRAW,LINETHICK1;


{半分位}{主图}
今三二:=MIN(OPEN,CLOSE)+(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))/3*2,COLORMAGENTA,NODRAW;
昨上三一:REF(今三二,1),COLORWHITE,NODRAW,LINETHICK1;
半分位:=MIN(OPEN,CLOSE)+(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))/2,COLORMAGENTA,NODRAW;
昨半分位:REF(半分位,1),COLORRED,NODRAW,LINETHICK1;
今三一:=MIN(OPEN,CLOSE)+(MAX(OPEN,CLOSE)-MIN(OPEN,CLOSE))/3,COLORMAGENTA,NODRAW;
昨下三一:REF(今三一,1),COLORGREEN,NODRAW,LINETHICK1;

{拉升提示}
M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
T1:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
TJA:=C>REF(C,1)*1.05;
AA4:=REF(T1,1)>100 AND REF(T2,1)>100 AND REF(T3,1)>100 AND REF(T4,1)>100 AND REF(T5,1)>80 AND TJA;
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200);
D5:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA4 AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XG:=CROSS((XGT=0 AND D5) OR D6=0,0.5);
TJ:=COUNT(XG,30)=2 AND XG;
DRAWTEXT(TJ>0,0.95,'拉升'),COLORYELLOW,LINETHICK1;

举报

扔鸡蛋(0) 回复

快乐天天乐
Lv.4
发表于 2019-10-21 22:26 复制 查看全部楼层
谢谢休闲者68老师,选出来股不对,不是刚刚绿色变红色

举报

点亮(0) 扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2019-10-21 12:10 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-21 13:41 编辑

供参考

附件

回复.txt [预览]

190 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。

举报

点亮(0) 扔鸡蛋(0) 回复

快乐天天乐
Lv.4
发表于 2019-10-21 11:27 复制 查看全部楼层
老马识途10老师,选出来不对,不是刚刚绿色变红色

举报

点亮(0) 扔鸡蛋(0) 回复

老马识途10
Lv.7
发表于 2019-10-21 11:08 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-21 13:40 编辑

供参考

附件

回复.txt [预览]

184 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表