手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙将分时副图指标改为主图

[通达信]
设置
1965 5 刨刨子 Lv.2 发表于 · 2019-10-21 20:27 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
本帖最后由 刨刨子 于 2019-10-21 20:29 编辑

请老师帮忙将本指标修改能在分时主图上正常显示,而不压缩分时线,谢谢。
  希望的结果是能够像图片上这样显示,目前不行。

A61:=AMOUNT/VOL/100;
A62:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
A63:=SUM(AMOUNT,40)/A61/100;
A64:=SUM(AMOUNT,80)/A61/100;
B61:=DMA(A62,VOL/A63);
B62:=DMA(A62,VOL/A64);
B63:=(CLOSE-B61)/B61*100;
B64:=(CLOSE-B62)/B62*100;
STICKLINE(B64>0,0,B64,1,0),COLORGREEN;
STICKLINE(B63>0,0,B63,1,0),COLORRED;
STICKLINE(B63<=0,0,B63,1,0),COLORGREEN;
QQ截图20191021202432.png
刨刨子
Lv.2
发表于 2019-10-21 21:26 复制 查看全部楼层

你好老师,还是没有固定,我想借鉴的源码在这里,不知我刚才的指标能否参考这个实现?望回复,再次麻烦老师了。

RCC:=IF(PERIOD=0 ,DYNAINFO(3),DYNAINFO(3)*0.9);
昨收:=RCC;
HH:=DYNAINFO(5);
LL:=DYNAINFO(6);
FK:=MAX(HH-昨收,昨收-LL)*0.1;
ZS:=昨收-FK*3.2;
Q1:=昨收-FK*3.22;
Q2:=昨收-2*FK*3.22;
Q3:=昨收-3*FK*3.2;
DIFF:=EMA(CLOSE,240)-EMA(CLOSE,240)*100;
DEAA:=EMA(DIFF,18);
多头MACD:=(-3*(DIFF-DEAA))*20,NODRAW;
ZD:=HHV(多头MACD,0);
ZX:=LLV(多头MACD,0);
CZ:=(Q2-Q3)/6;
FDM:=MAX(ABS(ZD),ABS(ZX))*1.5;
RB:=IF(PERIOD=0 ,(Q2+Q3)/2+2*(Q2-Q3)/3/FDM*多头MACD,DRAWNULL);
STICKLINE(PERIOD=0 AND 多头MACD>0,RB,(Q2+Q3)/2,4,1),LINETHICK1,COLORFF00FF;
STICKLINE(PERIOD=0 AND 多头MACD<0,RB,(Q2+Q3)/2,4,1),LINETHICK1,COLOR00FF00;
刨刨子
Lv.2
发表于 2019-10-21 21:18 复制 查看全部楼层

许昌老师,我测试了下,还是没有固定。这是我借鉴的固定位置不变的指标源码,不知道我刚才的指标能否像这样?还要麻烦一下老师,望回复,谢谢您。

RCC:=IF(PERIOD=0 ,DYNAINFO(3),DYNAINFO(3)*0.9);
昨收:=RCC;
HH:=DYNAINFO(5);
LL:=DYNAINFO(6);
FK:=MAX(HH-昨收,昨收-LL)*0.1;
ZS:=昨收-FK*3.2;
Q1:=昨收-FK*3.22;
Q2:=昨收-2*FK*3.22;
Q3:=昨收-3*FK*3.2;
DIFF:=EMA(CLOSE,240)-EMA(CLOSE,240)*100;
DEAA:=EMA(DIFF,18);
多头MACD:=(-3*(DIFF-DEAA))*20,NODRAW;
ZD:=HHV(多头MACD,0);
ZX:=LLV(多头MACD,0);
CZ:=(Q2-Q3)/6;
FDM:=MAX(ABS(ZD),ABS(ZX))*1.5;
RB:=IF(PERIOD=0 ,(Q2+Q3)/2+2*(Q2-Q3)/3/FDM*多头MACD,DRAWNULL);
STICKLINE(PERIOD=0 AND 多头MACD>0,RB,(Q2+Q3)/2,4,1),LINETHICK1,COLORFF00FF;
STICKLINE(PERIOD=0 AND 多头MACD<0,RB,(Q2+Q3)/2,4,1),LINETHICK1,COLOR00FF00;
许昌舍得
Lv.6
发表于 2019-10-21 21:05 复制 查看全部楼层
刨刨子 发表于 2019-10-21 21:00
感谢许昌老师的帮助。有个小问题,就是发现显示在每只股票的位置都不一样。不知能否像这里第一张图片里的 ...

P:=3;{自定义}



低1:=REF(LLV(L,150),3);
H3:=低1;
中轴:=REFDATE(H3,DATE),COLORGRAY,LINETHICK1;

A61:=AMOUNT/VOL/100;
A62:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
A63:=SUM(AMOUNT,40)/A61/100;
A64:=SUM(AMOUNT,80)/A61/100;
B61:=DMA(A62,VOL/A63);
B62:=DMA(A62,VOL/A64);

B63:=(C-B61)/B61*P;

B64:=(CLOSE-B62)/B62*P;

STICKLINE(B64>0,中轴,B64+中轴,1,0),COLORGREEN;
STICKLINE(B63>0,中轴,B63+中轴,1,0),COLORRED;
STICKLINE(B63<=0,中轴,B63+中轴,1,0),COLORGREEN;

DRAWKLINE(H,O,L,C);

你再试试
查看全部打赏
  • 福阿德+5理想币 +5共享币 : 赠人玫瑰,手有余香。
刨刨子
Lv.2
发表于 2019-10-21 21:00 复制 查看全部楼层

感谢许昌老师的帮助。有个小问题,就是发现显示在每只股票的位置都不一样。不知能否像这里第一张图片里的,都是显示在每只股票的分时线下面?谢谢老师

01

01

QQ截图20191021205404.png
QQ截图20191021205718.png
许昌舍得
Lv.6
发表于 2019-10-21 20:41 复制 查看全部楼层
本帖最后由 许昌舍得 于 2019-10-21 20:52 编辑

P:=3;{自定义}


高1:=REF(HHV(H,150),3);
低1:=REF(LLV(L,150),3);
H3:=(高1+低1)/2;
中轴:=REFDATE(H3,DATE),COLORGRAY,LINETHICK1;

A61:=AMOUNT/VOL/100;
A62:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
A63:=SUM(AMOUNT,40)/A61/100;
A64:=SUM(AMOUNT,80)/A61/100;
B61:=DMA(A62,VOL/A63);
B62:=DMA(A62,VOL/A64);

B63:=(C-B61)/B61*P;

B64:=(CLOSE-B62)/B62*P;

STICKLINE(B64>0,中轴,B64+中轴,1,0),COLORGREEN;
STICKLINE(B63>0,中轴,B63+中轴,1,0),COLORRED;
STICKLINE(B63<=0,中轴,B63+中轴,1,0),COLORGREEN;

DRAWKLINE(H,O,L,C);
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表