手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做个选股公式

[通达信]
设置
2145 1 财神王老哥 Lv.2 发表于 · 2019-10-23 10:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{输入参数框中:K2:1、2、1; }
DRAWTEXT_FIX(1,0.002,0,0,'-☆☆☆☆~乔治公爵的老枪准星-庆祝建国70华诞倾情奉献--之左侧交易精髓:财神来敲门主图~☆☆☆☆-'),COLORYELLOW;
DRAWTEXT_FIX(1,0.002,0.1,0,'抓妖原则:1、首看指数及股价的高低位置;2、看题材热点,先抓率先起涨龙头;3、看竞价量比、盘中成交量换手率。4、龙虎榜席位提示。买卖果断!'),COLORWHITE;
DRAWTEXT_FIX(1,0.002,0.15,0,'K线站稳黄、绿色线(长期筹码线),并在黄金坑右侧边沿出现财神来敲门,重视杀手潜伏指标对次新股回调买点的低位提示!'),COLORRED;
DRAWTEXT_FIX(1,0.002,0.2,0,'买进原则:妖股要买在黄金坑右侧坑沿。牛市中箱型盘整震荡期间信号较多,属于庄家洗筹。这样的票放入自选股跟踪。'),COLORGREEN;
DRAWTEXT_FIX(1,0.002,0.25,0,'投资股票原则:1、耐得住寂寞,2、该出手时必出手,3、买错要果断斩仓才能赚大钱。每年只抓10只大妖股!'),COLORMAGENTA;

{跃上海平面}
N:=10;{源码120.调整时间长短。最底10、21;}
TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=EMA(TA,5);{筹码峰高度调整线,源码181。参数最低21.如果抓大牛把参数加大。}
VAR81:=REF(CLOSE,N)-REF(ATR,1);
仙界线:=HHV(VAR81,5),COLORYELLOW;{筹码峰高度调整线,最低21.源码181}
上:=(1+7/100)*仙界线;
下:=(1-7/100)*仙界线;
中:=(上+下)/2;
XGD:DRAWBAND(上,RGB(258,88,0),下,RGB(258,88,0));{颜色亮度}

{资金流入带主图;相当于5日均线。}
初始流入:=FINANCE(21)/100000000,COLORCYAN,NODRAW;
逐步流入:=FINANCE(23)/100000000,COLORRED,NODRAW;
加快流入:=FINANCE(30)/100000000,COLORRED,NODRAW;
准备上攻:=FINANCE(19)/100000000,COLORGREEN,NODRAW;
MACC1:=EMA(C,2),COLOR0000FF,LINETHICK1;
MACC2:=REF(MACC1,1),COLORFFFFFF;
MACC3:=EMA(EMA(C,7),6),COLOR00FFFF,LINETHICK1;
XGL:DRAWBAND(MACC1,RGB(255,160,0),MACC2,RGB(10,200,0));{大红色255、0、0  /  0、255、0}

{筹码移动集散}
{DRAWKLINE(H,O,L,C);}
HB:=COST(99.9);
LBX:=COST(0.1);
B3:=(HB-LBX)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
AX1:=WINNER(HB)*100-WINNER(B31)*100;
AX2:=WINNER(B31)*100-WINNER(B32)*100;
AX3:=WINNER(B32)*100-WINNER(B33)*100;
AX4:=WINNER(B33)*100-WINNER(B34)*100;
AX5:=WINNER(B34)*100-WINNER(B35)*100;
AX6:=WINNER(B35)*100-WINNER(B36)*100;
AX7:=WINNER(B36)*100-WINNER(B37)*100;
AX8:=WINNER(B37)*100-WINNER(B38)*100;
AX9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LBX)*100;
{STICKLINE(ISLASTBAR,HB ,HB ,AX1*15 ,0 ),COLORLIGREEN;}
STICKLINE(ISLASTBAR,B31 ,B31 ,AX1*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B32 ,B32 ,AX2*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B33 ,B33 ,AX3*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B34 ,B34 ,AX4*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B35 ,B35 ,AX5*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B36 ,B36 ,AX6*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B37 ,B37 ,AX7*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B38 ,B38 ,AX8*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B39 ,B39 ,AX9*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B310 ,B310 ,A10*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B311 ,B311 ,A11*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B312 ,B312 ,A12*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B313 ,B313 ,A13*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B314 ,B314 ,A14*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B315 ,B315 ,A15*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B316 ,B316 ,A16*15 ,0 ),COLORLIGREEN;
STICKLINE(ISLASTBAR,B317 ,B317 ,A17*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B318 ,B318 ,A18*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B319 ,B319 ,A19*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B320 ,B320 ,A20*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B321 ,B321 ,A21*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B322 ,B322 ,A22*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B323 ,B323 ,A23*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B324 ,B324 ,A24*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B325 ,B325 ,A25*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B326 ,B326 ,A26*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B327 ,B327 ,A27*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B328 ,B328 ,A28*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B329 ,B329 ,A29*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B330 ,B330 ,A30*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B331 ,B331 ,A31*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B332 ,B332 ,A32*15 ,0 ),COLORLIGREEN;
STICKLINE(ISLASTBAR,B333 ,B333 ,A33*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B334 ,B334 ,A34*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B335 ,B335 ,A35*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B336 ,B336 ,A36*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B337 ,B337 ,A37*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B338 ,B338 ,A38*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B339 ,B339 ,A39*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B340 ,B340 ,A40*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B341 ,B341 ,A41*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B342 ,B342 ,A42*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B343 ,B343 ,A43*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B344 ,B344 ,A44*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B345 ,B345 ,A45*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B346 ,B346 ,A46*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B347 ,B347 ,A47*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B348 ,B348 ,A48*15 ,0 ),COLOR666600;
{STICKLINE(ISLASTBAR,LBX ,LBX ,A50*15 ,0 ),COLORLIGREEN;}

{盖住双横杠}
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

{3、重要的主图K线上的红色买点柱}
XA_1J:=EMA(EMA(CLOSE,23),23);{原23}
XA_2J:=(XA_1J-REF(XA_1J,1))/REF(XA_1J,1)*1000;
XA_3J:=DYNAINFO(11);
XA_4J:=(EMA(CLOSE,10)-EMA(CLOSE,60))*10;
XA_5J:=EMA(XA_4J,5);
XA_6J:=(CLOSE-XA_3J)/XA_3J<(-0.03);
XA_7J:=(CLOSE-XA_3J)/XA_3J<(-0.03);
XA_8J:=LAST(XA_3J>=REF(XA_3J,1),5,1) AND (CLOSE-XA_3J)/XA_3J<0.005;
XA_9J:=(CLOSE-XA_3J)/XA_3J>0.005;
XA_10J:=XA_2J<REF(XA_2J,1) AND XA_2J>0.5;
XA_11J:=XA_2J>0;
XA_12J:=XA_2J>REF(XA_2J,1) AND XA_2J<(-0.2);
XA_13J:=XA_2J>REF(XA_2J,1) AND XA_2J<0;
XA_14J:=CROSS(XA_4J,XA_5J) AND XA_4J<(-0.3);
XA_15J:=FILTER(XA_6J AND XA_12J AND XA_14J,15);
买点柱:=FILTER(XA_7J AND XA_12J AND XA_14J,15);
STICKLINE(买点柱,L*1.2,L*1.05,3,0),COLORRED;
{DRAWTEXT(买点柱,L*1.18,'★买点柱'),COLORYELLOW;}


{5日变色线}
越过成仙M240:=MA(C,240),COLORGRAY,LINETHICK1;
M144:=MA(C,144),COLORWHITE,LINETHICK1;
M88:=MA(C,88),COLORLIGRAY,LINETHICK1;
越过有道M120:=MA(C,110),COLORMAGENTA,LINETHICK3;
越过强势M60:=MA(C,60),COLORLIGRAY,LINETHICK3;
M30:=MA(C,27),COLORGREEN,LINETHICK2;
M20:=MA(C,17),COLORMAGENTA,LINETHICK2;
M10:=MA(C,10),COLORWHITE,LINETHICK1;
M5:=MA(C,3),COLORRED,LINETHICK3;
{BB55:=ATAN((M5/REF(M5,1)-1)*100)*180/3.1416;
IF(BB55>30 AND M5>REF(M5,1), M5,DRAWNULL),COLORRED,LINETHICK3;
BB100:=ATAN((M10/REF(M10,1)-1)*100)*180/3.1416;
IF(BB55<0 AND M5<REF(M5,1), M5,DRAWNULL),COLORCYAN,LINETHICK3;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));}

{2、短期下插线}
AN1:=MA(C,3);
AN2:=MA(C,21);
AN3:=(AN1+AN2)/2;
{6、短下插操作线无未来}
BR:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1);
分水岭R:=IF(MA(CLOSE,17)<BR,BR,MA(CLOSE,17)),COLORFF00FF,NODRAW;
YR:=分水岭R-(EMA(C,3)-分水岭R),DOTLINE,LINETHICK1;
OUTF:=CROSS(M5,YR);

{4、黄色块及坑后上涨;K线低位黄金坑。有未来。
该组源码的作用是:在大盘股指的时间周期末端,波段拉升前的挖坑洗盘重要标志。
该标志,仅仅作为分辨右侧交易前,研判大牛股启动的左侧黄色K线坑的建仓洗盘。并非左侧买进信号!}
NQ:=20;
M1P:=30;
P1P:=80;
P2P:=100;
VAR1P:=(C+H+O+L)/4;
买入P:=XMA(VAR1P,M1P)*(1-P2P/1000),COLORYELLOW,LINETHICK2;
STICKLINE(买入P>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;{与黑马通道低位黄块异曲同工}
STICKLINE(买入P>HIGH,HIGH,LOW,0,0),COLORYELLOW;{与黑马通道低位黄块异曲同工};
STICKLINE(CCI<=100 AND L<=买入P,(L + H + O) / 3.18,O,3,0),COLORYELLOW;
反弹P:=MA(EMA(EMA(HIGH,5),5),5)*0.95,LINETHICK1;
XG1P:=CROSS(买入P,反弹P);
STICKLINE(XG1P,L*1.1,L*1.05,000.1,0),COLORWHITE;
{DRAWTEXT(XG1P,L*1.1,'★坑后上涨'),COLORCYAN;

{13、飓风眼启爆,K线下方蓝色柱,股价启动信号,无函数}
AHC1:=CLOSE*VOL;
AHC2:=EMA((EXPMA(AHC1,2)/EXPMA(VOL,2)+EXPMA(AHC1,5)/EXPMA(VOL,5)+EXPMA
(AHC1,10)/EXPMA(VOL,10)+EXPMA(AHC1,20)/EXPMA(VOL,20))/4,10),COLORYELLOW;
风向R:=1.06*AHC2,LINETHICK2,COLORWHITE;
吹:=1.13*AHC2,LINETHICK2,COLORWHITE;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
飓风:=CROSS(C,风向R) AND ZT;
STICKLINE(飓风,L*0.98,L*0.80,2,0),COLORBLUE;
{DRAWTEXT(飓风,L*0.88,'---飓风眼'),COLORYELLOW;}

{7、黑夜之眼;波段低点。研判拉升前是否有资金活动吸筹。左侧交易信号。无未来}
MMM:=1;
SVOL:=INTPART(SUM(V,0)/CAPITAL);
TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;
SF1:=BARSLAST(TJ0)+1;
TJJ2:=SF1<REF(SF1,1);
S2:=IF(TJJ2,REF(SF1,1)+1,SF1);
S3:=SUM(TJJ2,0);
ZK1:="KD.K#WEEK"(9,3,3);
ZD2:="KD.D#WEEK"(9,3,3);
ZF1:="MACD.DIF#WEEK"(5,34,5);
ZA2:="MACD.DEA#WEEK"(5,34,5);
换手:=V/CAPITAL*100,LINETHICK0;
JCD:=CROSS(ZK1,ZD2) AND REF(ZD2,1)<60;
波段低点:=EXIST(JCD,MMM),COLORYELLOW,NODRAW;
STICKLINE(波段低点,L*0.98,L*0.80,1,0),COLORBROWN;
DRAWTEXT(波段低点,L*0.87,'--黑夜之眼'),COLORGREEN;

{2、A3及A15D}
A:=EMA((EMA(C,29)+EMA(C,31)+EMA(C,33))/3,3);
A1:=EMA((EMA(C,1)+EMA(C,3)+EMA(C,5))/3,3),COLOR1010FF;
A2:=EMA((EMA(C,3)+EMA(C,5)+EMA( C,7))/3,3),COLOR1020FF;
A3:=IF(K2!=2,EMA((EMA(C,5)+EMA(C,6)+EMA( C,7))/3,3),DRAWNULL),COLORCYAN,LINETHICK3;{COLOR1030FF;}
A4:=IF(K2!=2, EMA((EMA(C,7)+EMA(C,9)+EMA( C,11))/3,3),DRAWNULL),COLOR1040FF;
A5:=IF(K2!=2, EMA((EMA(C,9)+EMA(C,11)+EMA( C,13))/3,3),DRAWNULL)COLOR1050FF;
A6:=IF(K2!=2, EMA((EMA(C,11)+EMA(C,13)+EMA( C,15))/3,3),DRAWNULL)COLOR1060FF;
A7:=IF(K2!=2, EMA((EMA(C,13)+EMA(C,15)+EMA( C,17))/3,3),DRAWNULL)COLOR1070FF;
A8:=IF(K2!=2, EMA((EMA(C,15)+EMA(C,17)+EMA( C,19))/3,3),DRAWNULL)COLOR1080FF;
A9:=IF(K2!=2, EMA((EMA(C,17)+EMA(C,19)+EMA( C,21))/3,3),DRAWNULL),COLORLIMAGENTA;
A10D:=IF(K2!=2, EMA((EMA(C,19)+EMA(C,21)+EMA( C,23))/3,3),DRAWNULL),COLORLIMAGENTA;
A11D:=IF(K2!=2, EMA((EMA(C,21)+EMA(C,23)+EMA( C,25))/3,3),DRAWNULL),COLORWHITE,LINETHICK2;
A15D:IF(K2!=2, A-(A1-A*0.977),DRAWNULL),COLORBLUE,LINETHICK3;

{11、变色下插线}
B55:=ATAN((A15D/REF(A15D,1)-1)*100)*180/3.1416;
IF(55>30 AND A15D>REF(A15D,1), A15D,DRAWNULL),COLORCYAN,LINETHICK3;
B100:=ATAN((M5/REF(M5,1)-1)*100)*180/3.1416;
IF(B55<0 AND A15D<REF(A15D,1), A15D,DRAWNULL),COLORRED,LINETHICK3;
{12、黄色起飞跑道}
OUT1:=CROSS(M5,A15D);
{DRAWICON(OUT1,L*0.96,13);{红球}
{XG:IF(M5>REF(A3,1),A3,DRAWNULL),COLORYELLOW,LINETHICK5;{黄金支撑线};

{三轨主图。妖股启动初期刚好将飓风口K线与下叉的大叉线一分为二,
所以说:"股价站上该线出妖股!!!!"}
MC:=100;
NN:=0.4;
MIDZ:MA(CLOSE,MC),COLORWHITE,LINETHICK3;{中轨;灰色,股价站上此线才能出现妖股;

{4、大叉出现在坑边!}
BCC:=MA(CLOSE,34)+MA(CLOSE,34)-REF(MA(CLOSE,34),1);
分水岭C:=IF(MA(CLOSE,161)<BCC,BCC,MA(CLOSE,161)),LINETHICK1,POINTDOT;{200}
下插线C:分水岭C-(EMA(C,3)-分水岭C),LINETHICK3,COLORYELLOW;
XGC:IF(下插线C>AN3,下插线C,DRAWNULL),COLORBROWN,LINETHICK3;


{越过有道120上穿MIDZ}
{OUT11:=CROSS(M5,A15D);
STICKLINE(OUT11,L*1.38,L*1.05,0.3,0),COLORWHITE;
DRAWTEXT(OUT11,L*1.38,'---红色三线'),COLORMAGENTA;}

{★坑边信赖。原则:买低不买高。出现在金坑中或右侧边沿,距离右侧其他拉升放量信号越近越好!
出现在低位进入自选股一月内跟踪。无未来;例:2019年2月12日赫美集团;2019年5月16日金力永磁;
2018年11月1日和2019年2月18日市北高新;2019年2月11日国风塑业;2019年2月18日龙津药业;
2019年2月12日深南电A;2019年2月12日华菱星马;2017年11月29日泰禾集团;2019年6月12日电魂网络}
QFO3:=100-3*SMA((CLOSE-LLV(LOW,42))/(HHV(HIGH,42)-LLV(LOW,42))*100,5,1)
+2*SMA(SMA((CLOSE-LLV(LOW,42))/(HHV(HIGH,42)-LLV(LOW,42))*100,20,1),8,1);{42;15;21}
QFO4:=100-3*SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,8,1)
+2*SMA(SMA((OPEN-LLV(LOW,66))/(HHV(HIGH,66)-LLV(LOW,66))*100,20,1),5,1);{66;20;15}
QFO5:=QFO3<REF(QFO4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
XG2C:=IF(QFO5 AND COUNT(QFO5,30)=1,20,0),STICK,LINETHICK2,COLORRED;
STICKLINE(XG2C,L*1.02,L*1.27,0.0001,0),COLORCYAN;
DRAWTEXT(C>REF(C,1) AND REF(RSI,1)>0 AND XG2C,L*1.26,'★坑边信赖'),COLORWHITE;

{▲主图有金坑吸筹,无金坑放弃。}
LCF:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LCF),0),5,1) / SMA(ABS((CLOSE - LCF)),5,1)) * 100);
TR1F:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1F);
MDI:=((DMM * 100) / TR1F);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60)));{10}
NEWVOL:=(RSI5 - WR10);
金坑买入:=(AV + NEWVOL);
买入选股:=IF(CROSS(金坑买入,0),1,0),STICK,COLORRED;{NODRAW}
VAR1Z:=SMA(买入选股,8,1);{3}
VAR2Z:=SMA(VAR1Z,8,1),COLOR0000FF;{3}
VAR3Z:=SMA(VAR2Z,10,1),COLOR00FFFF;{3}
金坑吸筹:=IF(CROSS(VAR2Z,VAR3Z) AND (VAR2Z<40),5,0* 10000),COLOR0000FF,LINETHICK1;{40}
STICKLINE(金坑吸筹,L*1.02,L*1.42,0.0001,0),COLORMAGENTA;
DRAWTEXT(金坑吸筹>0,L*1.42,'▲有金坑吸筹'),COLORLIRED;

{做多资金上穿空方趋势线出洋红球13,为趋势走强信号}
A50A:=33,COLORBLUE,LINETHICK1;
VAR0:=(2*CLOSE+HIGH+LOW)/4;
BCA:=MA((VAR0-LLV(LOW,17))/(HHV(HIGH,17)-LLV(LOW,17))*100,2);{36;12}
做多资金:=EMA(BCA,3),LINETHICK1,COLORYELLOW;
做空资金:=EMA(做多资金,18),COLORGRAY,LINETHICK1;
VAR4C:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*100;
空方趋势线:=SMA(VAR4C,3,1)+0.17,COLORLIGREEN,LINETHICK3;
OUT66:=CROSS(做多资金,A50A);
STICKLINE(OUT66,L*1.36,L*1.05,1,0),COLORRED;
DRAWTEXT(OUT66,L*1.35,'★下有金坑才拉升'),COLORYELLOW;
{DRAWTEXT(OUT66,L*1.26,'★下无金坑不考虑'),COLORWHITE;}

{XGL上穿下插线C}
OUTL:=CROSS(M5,下插线C);
STICKLINE(OUTL,L*1.35,L*1.06,0.06,0),COLORRED;
DRAWTEXT(OUTL,L*1.34,'★大叉出现'),COLORRED;

{4、潜伏。无未来}
M5F:=MA(C,4);
M10F:=MA(C,8),COLORRED,LINETHICK2;
M20F:=MA(C,20);
{M30F:=MA(C,30);}
M60F:=MA(C,60),COLORBLUE,LINETHICK2;
D3:=MIN(MIN(M5F,M10F),M20F)>M60F;
LLM:=LLV("MACD.MACD"*100,200);
HHM:=HHV("MACD.MACD"*100,200);
TJA:=C>REF(C,1)*1.05;
T:=BARSLAST(C>REF(C,1)*1.095 AND C=H);
T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);
T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);
T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);
T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);
AAF1:=REF(T,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;
XGT:=BARSLAST(AAF1 AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5F,M10F),M20F)>M60F,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJJ:=COUNT(XGX,30)=2 AND XGX;
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=REF(SR2,10+1);
HDF:=REF(SR3,10);
前高:=REF(H,BARSLAST(HDF));
倍量:=VOL/REF(VOL,1)>=1.9;
突破前高:=CROSS(C,前高);
YG:= 倍量 AND 突破前高;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
SJ:=BARSLAST(YG);
DIF:=MACD.DIF;
H300:=HHVBARS(DIF,300);
AL:=BOLL.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EXPMA(C,25);
ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;
躁动:=TJ1Q AND XL>75;
A1F:=REF(C,1);
AYFF:=REF(C,10);
A31F:=(AYFF-A1F)/A1F*100;
AA1F:=(A31F-REF(A31F,1));
选股1:=CROSS(AAF1,9.8);
A11F:=REF(V,1);
VAR8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))))>2;
A13F:=VAR8/A11F;
AA3F:=(A13F-REF(A13F,1));
选股2:=CROSS(AA3F,500);
潜伏2:=选股1 AND 选股2;
GX:=潜伏2 OR 躁动 OR CURRBARSCOUNT=CONST(SJ)+2 OR TJJ OR (CCI<=100 AND L<=低2);
准备:=FILTER(GX=1,3);
A2A:=BARSCOUNT(C);
AH:=HHV(H,200);
A1L:=LLV(L,200);
A0:=(AH-A1L)/190;
B1F:=L-A0;
STICKLINE(准备,B1F,B1F-20*A0,2,0),COLORGREEN;
DRAWTEXT(准备,H*0.88, '---潜伏'),COLORWHITE;

DRAWTEXT(飓风,L*0.80,'---飓风眼'),COLORWHITE;

{财神来敲门;有函数;不影响使用}
金童子:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4)
,0.2*FORCAST(V,12),2.1*FORCAST(V,12));{4;12;12}
财神:=FILTER(金童子,10);{58}
STICKLINE(财神,L*1.28,L*1.05,0.001,0),COLORWHITE;
DRAWTEXT(财神,L*1.21,'---财神来敲门'),COLORYELLOW;
DRAWICON(财神,L*1.28,9);

{乔治公爵的老枪准星之;杀手潜伏。无函数主图}
火弹:=MA(C,3),COLORRED,LINETHICK3;
弹夹:=MA(LOW,13)*1.2,COLORMAGENTA;
来福线:=MA(LOW,17)*1.1,COLORYELLOW;
{老炮筒1:MA(HIGH,100)*0.9,COLORWHITE;}
撞针:=MA(HIGH,13)*0.9,COLORWHITE;
扳机:=MA(HIGH,89)*0.8,COLORBROWN;
准星:=CROSS(火弹,撞针);
STICKLINE(准星,L*0.98,L*0.85,3,0),COLORLIMAGENTA;
DRAWTEXT(准星,L*0.85,'---杀手潜伏'),COLORWHITE;


{跃上金坑.与K线黄金坑配合使用。}
A1J:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,10))/EMA(CLOSE,10)); {23}
A2J:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1J);
金坑:=EMA(A2J,5)*1;{200}
金坑2:=EMA(A2J,200)*1.118;{200}
探路:=(C-REF(C,1))/REF(C,1)*100>8;
金库:=CROSS(C,金坑) AND 探路;
RRFJ:=金库,STICK;
STICKLINE(RRFJ,L*1,L*0.91,0.01,0),COLORRED;
DRAWTEXT(RRFJ,L*0.97,'-金坑迎财神'),COLORYELLOW;

DRAWICON(OUT1,L*1.02,13);{红球}

DRAWTEXT(XG1P,L*1.1,'★坑后上涨'),COLORCYAN;

DRAWTEXT(买点柱,L*1.12,'★买点柱'),COLORYELLOW;

{逃}
LCC:=REF(CLOSE,1);
RSIC:=SMA(MAX(CLOSE-LCC,0),6,1)/SMA(ABS(CLOSE-LCC),6,1)*100;
DRAWTEXT(CROSS(84,RSIC) , HIGH*1.1,'逃'),COLORYELLOW;


红球选出红球出现时的股票
本主题由 任务系统 于 2019-10-23 11:05 审核通过
飞远国际
Lv.6
发表于 2019-10-23 11:21 复制 查看全部楼层
本帖最后由 福阿德 于 2019-10-23 11:27 编辑


供参考

附件

回复.txt [预览]

193 Bytes, 下载次数: 3, 下载积分: 共享币 -5 个

查看全部打赏
  • 快乐398+18理想币 : 谢谢老师帮助,您辛苦了
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表