手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股公式

[通达信]
设置
1739 3 爱睡觉蜗牛 Lv.2 发表于 · 2019-11-5 21:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
同时出现时来运转和进场的时候做个选股公式。另外麻烦老师看下这个指标带未来含税吗?会消失吗?谢谢

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
DRAWTEXT_FIX(1,0.88,5,0,'~☆~隆逸优化作品~☆~'),COLORRED;
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(HH,90),COLORRED,LINETHICK1;
D90L:=EMA(LL,90),COLORRED,LINETHICK1;
DGH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;DDL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90C:=D90H-D90L;D90D:=D90H+D90C*2,COLORRED,LINETHICK1;
D90T:=D90L-D90C*2,COLORRED,LINETHICK1;
G0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;
D0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;
DTD:=D0>=D90T AND G0>=D90D;
KTD:=G0<=D90D AND D0<=D90T;
ZDD:=D0>=D90T AND G0<=D90D;
BDD0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60),LINETHICK2,COLORGREEN;
BDT0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3,LINETHICK2,COLORGREEN;
ZK1:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORBLUE;
ZD1:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,DOTLINE,COLORRED,LINETHICK2;
ZK2:=EMA(ZK1,25);
ZD2:=EMA(ZD1,25),LINETHICK2;
GF:=ZD1>ZD2 AND L<ZD1 AND C<O;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*240/FROMOPEN*0.9,5,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
TT:=(V2*1.01-REF(V2,1));
TT2:=(REF(V2*1.01,1)-REF(V2,2));
YY:=TT>3*ABS(TT2);
TT1:=EMA(V2,15);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
N:=10;
P:=3;
UPR:=BBI+P*STD(BBI,N);
DWN:=BBI-P*STD(BBI,N);
XF:=L<DWN;
开口值:=ZD1-ZD2;
强势区域:EVERY(开口值>REF(开口值,1),5);
DRAWBAND(强势区域,120,0,RGB(36,136,36));
潜伏:=GF AND XF;
进:=ZIG(3,5)>REF(ZIG(3,5),1) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3) AND REF(潜伏,1);
进2:=TT>0 AND CROSS(TT,TT1) AND YY AND REF(潜伏,1);
STICKLINE(潜伏=1,0,4,0.5,0),COLORGREEN;
DRAWTEXT(潜伏=1,4,' 潜伏'),COLORGREEN;
STICKLINE(进=1 OR 进2=1,0,6,0.5,0),COLORRED;
DRAWTEXT(进=1 OR 进2=1,5,' 进场'),COLORRED;
UU:=BARSLAST(CROSS(ZD1,ZD2))<30;
时来运转:=进 AND UU;
时来运转2:=进2 AND UU;
STICKLINE(时来运转=1 OR 时来运转2=1,0,3,3,0),COLORYELLOW;
DRAWTEXT(时来运转=1 OR 时来运转2=1,3,' 时来运转'),COLORYELLOW;
GF2:= L<ZD1 AND ZD1<ZD2;
V型反转:REF(GF2,1) AND C>O AND C/REF(C,1)>1.04 AND TT>0 AND CROSS(TT,TT1) AND YY;
STICKLINE(V型反转=1,0,3,1,0),COLORYELLOW;
DRAWTEXT(V型反转=1,4,' V型反转'),COLORGREEN;
本主题由 任务系统 于 2019-11-5 21:17 审核通过
休闲者68
Lv.6
发表于 2019-11-6 09:01 复制 查看全部楼层
本帖最后由 福阿德 于 2019-11-6 15:02 编辑

{未来函数ZIG!慎用!}

附件

回复.txt [预览]

1.21 KB, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+4理想币 +4共享币 : 赠人玫瑰,手有余香。
小占占
Lv.2
发表于 2019-11-6 08:32 复制 查看全部楼层
有未来函数。慎用。
许昌舍得
Lv.6
发表于 2019-11-5 21:23 复制 查看全部楼层
本帖最后由 福阿德 于 2019-11-6 15:01 编辑

供参考

附件

回复.txt [预览]

1.59 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表