手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助合并个预警指标

[通达信]
设置
1863 2 汹涌澎湃8 Lv.3 发表于 · 2019-11-7 13:23 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

除业绩后退股:=FINANCE(30)>=REF(FINANCE(30),130);

D0:=除业绩后退股;

D2:=IF(NAMELIKE('S'),0,1);

D3:=IF(NAMELIKE('*'),0,1);

D4:=DYNAINFO(17)>0;

去除大盘股:=CAPITAL/1000000<50;

去高价:=C<=75;

去掉:=D0 AND D2 AND D3 AND D4 AND 去除大盘股 AND 去高价 AND NOT(C>=REF(C,1)*1.097 AND C=O AND H=L);

MA5:=EMA(C,5);

YCXN:=MA5>=REF(MA5,1);

AA1:=REF(CLOSE,1)<(LLV(LOW,10)+(HHV(HIGH,10)-LLV(LOW,10))*1);

AA2:=CLOSE<HHV(HIGH,5) AND CROSS(C,MA(C,5)) AND  CROSS(C,MA(C,10)) AND  CROSS(C,MA(C,20))

AND  CROSS(C,MA(C,34)) AND C/REF(C,1)>=1;

AA3:=CLOSE>=HHV(HIGH,5) AND YCXN AND C/REF(C,1)>=1;

涨停狙击:=DYNAINFO(4)>0

AND HHV(HIGH,5)/LLV(LOW,5)<3.4 AND AA1 AND (AA2 OR AA3);

L0:=(LLV(LOW,10));

L10:=(LLV(LOW,60));

L2:=(LLV(LOW,120));

A1:=REF(CLOSE,1);

B10:=COUNT(L10,13)>=8;

B20:=SUM(L10,13)>=6;

B30:=COUNT(-B20,13)>=10;

B4:=1;

B5:=COUNT(B20,13)>=1;

C1:=(((CLOSE-A1)/A1)*100)>2.5;

D10:=(((CLOSE-LOW)/LOW)*100)>2;

火牛:=IF((D10 AND L2 AND C1)*2,10,0);

金牛:=IF((D10 AND L0 AND C1)*2.5,10,0);

陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);

NN:=IF((陡峭度 > 0.35),6,65);

VAR17:=((-((100)*(HHV(HIGH,NN) - CLOSE))/(HHV(HIGH,NN) - LLV(LOW,NN))))*((DATE < 20070110));

狂喜:=(30)*(CROSS(VAR17,(-2)));

黑马显形:=金牛 AND 火牛 AND 涨停狙击 AND 狂喜 AND 去掉;

XG:黑马显形;    涨幅:=9;高度:=20;跨度:=10;N4:=34;
短线:=EMA(CLOSE,17);
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线:=EMA(KKC,50);
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
KDD:=REF(中期,1)<1 AND 中期>1;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA
((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
中期线:=MA(持股,12);
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
短期线:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30;
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV1,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
KAAA1:=EXIST(KDD,3);
KBBB1:=C/REF(C,1)>1+0.01*涨幅;
KAAA2:=支撑>中期线 AND 持股=支撑;
KBBB2:=CROSS(C2,C3);
KCCC2:=EXIST(C/REF(C,1)>1+0.01*涨幅,跨度);
KDDD2:=BARSLAST(中期线>短期线)<跨度;
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*涨幅;
KCCC3:=中线/长线<1+0.01*高度;
游资介入: IF(KBBB1+KCCC2+KBBB3=3,50,0);
汹涌澎湃8
Lv.3
发表于 2019-11-7 14:37 复制 查看全部楼层
影库 发表于 2019-11-7 14:19
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;  除业绩后退股:=FINANCE(30)>=REF(FINAN ...

谢谢老师的帮助.祝老师投资愉快
影库
Lv.4
发表于 2019-11-7 14:19 复制 查看全部楼层
本帖最后由 福阿德 于 2019-11-7 22:00 编辑

供参考

附件

回复.txt [预览]

2.86 KB, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
  • 汹涌澎湃8+10理想币 : 很给力,理想因你而精彩;
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表