手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改成选股公式

[通达信]
设置
2018 1 誉凯 Lv.2 发表于 · 2019-11-10 16:00 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师把出蓝柱改成选股,谢谢


X_1:=100;
X_2:=DMA(CLOSE,VOL/MA(VOL,4)/4);
X_3:=DMA(CLOSE,VOL/MA(VOL,33)/33);
X_4:=(CLOSE-X_2)/X_2*100<(-11)/X_1*100;
X_5:=(X_2-X_3)/X_3*100<(-22.299999)/X_1*100;

X_66:=(REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));

X_6:=X_4 AND X_5 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>(-0.07) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND (REF(OPEN,2)>REF(CLOSE,2) OR REF(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND X_66;{}
X_7:=DMA(CLOSE,VOL/MA(VOL,3)/3);
X_8:=DMA(CLOSE,VOL/MA(VOL,33)/33);
X_9:=(CLOSE-X_7)/X_7*100<(-5);
X_10:=(X_7-X_8)/X_8*100<(-18);
X_11:=(INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100;
X_12:=SMA(X_11,30,1);
X_13:=SMA(X_12,50,1);
X_14:=X_9 AND X_10 AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>(-0.05) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
X_15:=X_14 AND COUNT(X_14,2)=1;
X_16:=CLOSE/MA(CLOSE,30)*100<75;
X_17:=CLOSE/MA(CLOSE,50)*100<78;
X_18:=HIGH>LOW*1.053;
X_19:=X_18 AND COUNT(X_18,5)>2;
X_20:=X_19 AND (X_16 OR X_17);
X_21:=DMA(EMA(CLOSE,5),SUM(VOL,8)/2.8/CAPITAL);
X_22:=(CLOSE-X_21)/X_21*100;
X_23:=REF(X_22,1)<(-34) AND X_22>REF(X_22,1) AND REF(X_22,1)<REF(X_22,2) AND X_22-REF(X_22,1)>1.76 OR X_20;
X_24:=IF(NAMELIKE(1) OR NAMELIKE(2),0,1);
X_25:=DYNAINFO(4)>0;
X_26:=X_24 AND X_25;
X_27:=X_23 AND (X_6 OR X_15) AND CLOSE>DTPRICE(REF(CLOSE,1),0.1);
X_28:=REF(X_23 AND (X_6 OR X_15),1) AND REF(CLOSE,1)<=DTPRICE(REF(CLOSE,2),0.1) AND CLOSE>DTPRICE(REF(CLOSE,1),0.1);
X_29:=X_27 OR X_28 AND X_26;
极致贪婪:X_29 AND COUNT(X_29,3)=1 AND LOW<=LLV(LOW,5) AND CLOSE/LOW<1.02 AND CLOSE/REF(CLOSE,1)<1 AND HIGH/OPEN<1.02 AND COUNT(CLOSE/REF(CLOSE,1)<=0.93,10)>0,COLORCYAN;
STICKLINE(极致贪婪,0,50,1,0),COLORCYAN;
明日涨停价:ZTPRICE(CLOSE,0.1),NODRAW,COLORWHITE;
获利盘:WINNER(CLOSE)*100,NODRAW,COLORLIRED;
本主题由 任务系统 于 2019-11-10 16:36 审核通过
休闲者68
Lv.6
发表于 2019-11-10 16:48 复制 查看全部楼层
本帖最后由 福阿德 于 2019-11-11 09:35 编辑

供参考

附件

回复.txt [预览]

1.79 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表