手机版
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改成大智慧指标

[大智慧]
设置
3489 5 小豌豆1号 Lv.7 发表于 · 2019-12-3 14:46 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
X_1:=VOL/CLOSE/3;
X_2:=SUM(IF(X_1>0.2 AND CLOSE>REF(CLOSE,1),X_1,0),0);
X_3:=SUM(IF(X_1>0.2 AND CLOSE<REF(CLOSE,1),X_1,0),0);
X_4:=X_2+X_3;
X_5:=1;
X_6:=X_2/X_3;
X_7:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
X_8:=SUM(CLOSE*VOL,240)/SUM(VOL,240);
X_9:=BARSCOUNT(CLOSE);
X_10:=MA(CLOSE,X_9);
X_11:=X_10+2*STD(CLOSE,3);
X_12:=X_10-2*STD(CLOSE,3);
X_13:=TIME>93000;
X_14:=CLOSE/REF(CLOSE,1)>1.02;
X_15:=CLOSE/REF(CLOSE,1)<0.98;
X_16:=(HHV(CLOSE,X_9)-LLV(CLOSE,X_9))/CLOSE<0.05;
X_17:=SMA(VOL,30,1);
X_18:=(X_17-LLV(LLV(X_17,1),30))/(HHV(HHV(X_17,1),30)-LLV(LLV(X_17,1),30))>0.95;
X_19:=X_14 OR X_15;
X_20:=X_19=0 AND X_16 AND X_18 AND CROSS(X_8,X_10);
DRAWTEXT(FILTER(X_20,10),CLOSE,13),COLORYELLOW;
DRAWICON(FILTER(X_20,10),X_8,1);
IF(MACD.DEA<0,CLOSE,DRAWNULL),COLORYELLOW,LINETHICK9;
X_21:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE));
X_22:=EXPMA(CLOSE/X_21,20);
X_23:=EXPMA(CLOSE/X_21,60);
X_24:=EXPMA(CLOSE/X_21,120);
X_25:=1;
1.02,NODRAW;
X_26:=1.03;
X_27:=X_22>X_23 AND X_22>1.003 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60);
DRAWICON(X_22>X_23 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND X_22=HHV(X_22,30) AND CROSS(X_22,1.003),CLOSE,38);
DRAWICON(X_22>X_23 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND X_22=HHV(X_22,30) AND CROSS(X_22,1.003),CLOSE*0.999,25);
DRAWICON(CROSS(X_22,1.02),CLOSE*0.999,24);
DRAWICON(CROSS(X_22,1.04),CLOSE*0.999,26);
X_28:=SUM(IF(CLOSE>REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0);
X_29:=SUM(IF(CLOSE<REF(CLOSE,1) AND VOL>4000,VOL/1+00,0),0);
X_30:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/1000,0),0);
X_31:=SUM(IF(CLOSE<REF(CLOSE,1),VOL/1000,0),0);
X_32:=X_30-X_28;
X_33:=X_31-X_29;
X_34:=X_28;
X_35:=X_29;
X_36:=X_32;
X_37:=X_33;
X_38:=X_28-X_29;
X_39:=X_32-X_33;
X_40:=X_30-X_31;
X_41:=CONST(MAX(ABS(X_34),MAX(ABS(X_35),MAX(ABS(X_36),ABS(X_37)))));
地:EMA(X_8,50)/0.97,COLORGREEN,LINETHICK2;
IF(地>REF(地,1),地,DRAWNULL),COLORRED,LINETHICK2;
平衡线:(X_8+地)/2,DOTLINE,COLORGREEN;
X_42:=COUNT(VOL>4000 AND CLOSE>REF(CLOSE,1),0);
黄次数:COUNT(VOL>DYNAINFO(16)*10 AND CLOSE>REF(CLOSE,1),0),NODRAW,COLORYELLOW;
DRAWICON(X_42>REF(X_42,1) AND 黄次数>REF(黄次数,1) AND CROSS(CLOSE,地),CLOSE,7);
DRAWICON(X_32>X_33 AND X_28>X_32 AND X_33>X_29,X_8,38);

相关股票

举报

扔鸡蛋(0) 回复

令令2
Lv.3
发表于 2019-12-4 13:18 复制 查看全部楼层
我幇你改了一下
X_1:=VOL/CLOSE/3;
X_2:=SUM(IF(X_1>0.2 AND CLOSE>REF(CLOSE,1),X_1,0),0);
X_3:=SUM(IF(X_1>0.2 AND CLOSE<REF(CLOSE,1),X_1,0),0);
X_4:=X_2+X_3;
X_5:=1;
X_6:=X_2/X_3;
X_7:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
X_8:=SUM(CLOSE*VOL,240)/SUM(VOL,240);
X_9:=BARSCOUNT(CLOSE);
X_10:=MA(CLOSE,X_9);
X_11:=X_10+2*STD(CLOSE,3);
X_12:=X_10-2*STD(CLOSE,3);
X_13:=TIME>93000;
X_14:=CLOSE/REF(CLOSE,1)>1.02;
X_15:=CLOSE/REF(CLOSE,1)<0.98;
X_16:=(HHV(CLOSE,X_9)-LLV(CLOSE,X_9))/CLOSE<0.05;
X_17:=SMA(VOL,30,1);
X_18:=(X_17-LLV(LLV(X_17,1),30))/(HHV(HHV(X_17,1),30)-LLV(LLV(X_17,1),30))>0.95;
X_19:=X_14 OR X_15;
X_20:=X_19=0 AND X_16 AND X_18 AND CROSS(X_8,X_10);
DRAWTEXT(FILTER(X_20,10),CLOSE,'13'),COLORYELLOW;
DRAWICON(FILTER(X_20,10),X_8,1);
PARTLINE(CLOSE,"MACD.DEA"<0,rgb(255,255,0)),LINETHICK6;
X_21:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE));
X_22:=EXPMA(CLOSE/X_21,20);
X_23:=EXPMA(CLOSE/X_21,60);
X_24:=EXPMA(CLOSE/X_21,120);
X_25:=1;
1.02,NODRAW;
X_26:=1.03;
X_27:=X_22>X_23 AND X_22>1.003 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60);
DRAWICON(X_22>X_23 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND X_22=HHV(X_22,30) AND CROSS(X_22,1.003),CLOSE,38);
DRAWICON(X_22>X_23 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND X_22=HHV(X_22,30) AND CROSS(X_22,1.003),CLOSE*0.999,25);
DRAWICON(CROSS(X_22,1.02),CLOSE*0.999,24);
DRAWICON(CROSS(X_22,1.04),CLOSE*0.999,26);
X_28:=SUM(IF(CLOSE>REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0);
X_29:=SUM(IF(CLOSE<REF(CLOSE,1) AND VOL>4000,VOL/1+00,0),0);
X_30:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/1000,0),0);
X_31:=SUM(IF(CLOSE<REF(CLOSE,1),VOL/1000,0),0);
X_32:=X_30-X_28;
X_33:=X_31-X_29;
X_34:=X_28;
X_35:=X_29;
X_36:=X_32;
X_37:=X_33;
X_38:=X_28-X_29;
X_39:=X_32-X_33;
X_40:=X_30-X_31;
X_41:=CONST(MAX(ABS(X_34),MAX(ABS(X_35),MAX(ABS(X_36),ABS(X_37)))));
地:EMA(X_8,50)/0.97,COLORGREEN,LINETHICK2;
PARTLINE(地,地>REF(地,1),rgb(255,0,0)),LINETHICK2;
平衡线:(X_8+地)/2,DOTLINE,COLORGREEN;
X_42:=COUNT(VOL>4000 AND CLOSE>REF(CLOSE,1),0);
黄次数:COUNT(VOL>DYNAINFO(38)/240*10 AND CLOSE>REF(CLOSE,1),0),NODRAW,COLORYELLOW;
DRAWICON(X_42>REF(X_42,1) AND 黄次数>REF(黄次数,1) AND CROSS(CLOSE,地),CLOSE,7);
查看全部打赏
  • 小豌豆1号+4理想币 : 很给力,理想因你而精彩;

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2019-12-3 20:39 复制 查看全部楼层
小豌豆1号 发表于 2019-12-3 20:26
不得行额兄弟,100%显示,而不是10%显示

不行,就废掉吧。

举报

扔鸡蛋(0) 回复

小豌豆1号
Lv.7
发表于 2019-12-3 20:26 复制 查看全部楼层
休闲者68 发表于 2019-12-3 17:28
X_1:=VOL/CLOSE/3;
X_2:=SUM(IF(X_1>0.2 AND CLOSE>REF(CLOSE,1),X_1,0),0);
X_3:=SUM(IF(X_1>0.2 AND CL ...

不得行额兄弟,100%显示,而不是10%显示

举报

扔鸡蛋(0) 回复

休闲者68
Lv.6
发表于 2019-12-3 17:28 复制 查看全部楼层
X_1:=VOL/CLOSE/3;
X_2:=SUM(IF(X_1>0.2 AND CLOSE>REF(CLOSE,1),X_1,0),0);
X_3:=SUM(IF(X_1>0.2 AND CLOSE<REF(CLOSE,1),X_1,0),0);
X_4:=X_2+X_3;
X_5:=1;
X_6:=X_2/X_3;
X_7:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
X_8:=SUM(CLOSE*VOL,240)/SUM(VOL,240);
X_9:=BARSCOUNT(CLOSE);
X_10:=MA(CLOSE,X_9);
X_11:=X_10+2*STD(CLOSE,3);
X_12:=X_10-2*STD(CLOSE,3);
X_13:=TIME>93000;
X_14:=CLOSE/REF(CLOSE,1)>1.02;
X_15:=CLOSE/REF(CLOSE,1)<0.98;
X_16:=(HHV(CLOSE,X_9)-LLV(CLOSE,X_9))/CLOSE<0.05;
X_17:=SMA(VOL,30,1);
X_18:=(X_17-LLV(LLV(X_17,1),30))/(HHV(HHV(X_17,1),30)-LLV(LLV(X_17,1),30))>0.95;
X_19:=X_14 OR X_15;
X_20:=X_19=0 AND X_16 AND X_18 AND CROSS(X_8,X_10);
DRAWTEXT(FILTER(X_20,10),CLOSE,'13'),COLORYELLOW,LINETHICK2;
DRAWICON(FILTER(X_20,10),X_8,1);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
IF(DEA<0,CLOSE,0),COLORYELLOW,LINETHICK2;
X_21:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(VOL*100,BARSCOUNT(CLOSE));
X_22:=EXPMA(CLOSE/X_21,20);
X_23:=EXPMA(CLOSE/X_21,60);
X_24:=EXPMA(CLOSE/X_21,120);
X_25:=1;
1.02,NODRAW;
X_26:=1.03;
X_27:=X_22>X_23 AND X_22>1.003 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60);
DRAWICON(X_22>X_23 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND X_22=HHV(X_22,30) AND CROSS(X_22,1.003),CLOSE,38);
DRAWICON(X_22>X_23 AND X_23>X_24 AND CLOSE>EXPMA(CLOSE,20) AND EXPMA(CLOSE,10)>EXPMA(CLOSE,20) AND EXPMA(CLOSE,20)>EXPMA(CLOSE,60) AND X_22=HHV(X_22,30) AND CROSS(X_22,1.003),CLOSE*0.999,25);
DRAWICON(CROSS(X_22,1.02),CLOSE*0.999,14);
DRAWICON(CROSS(X_22,1.04),CLOSE*0.999,16);
X_28:=SUM(IF(CLOSE>REF(CLOSE,1) AND VOL>4000,VOL/1000,0),0);
X_29:=SUM(IF(CLOSE<REF(CLOSE,1) AND VOL>4000,VOL/1+00,0),0);
X_30:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/1000,0),0);
X_31:=SUM(IF(CLOSE<REF(CLOSE,1),VOL/1000,0),0);
X_32:=X_30-X_28;
X_33:=X_31-X_29;
X_34:=X_28;
X_35:=X_29;
X_36:=X_32;
X_37:=X_33;
X_38:=X_28-X_29;
X_39:=X_32-X_33;
X_40:=X_30-X_31;
X_41:=CONST(MAX(ABS(X_34),MAX(ABS(X_35),MAX(ABS(X_36),ABS(X_37)))));
地:EMA(X_8,50)/0.97,COLORGREEN,LINETHICK2;
IF(地>REF(地,1),地,0),COLORRED,LINETHICK2;
平衡线:(X_8+地)/2,DOTLINE,COLORGREEN;
X_42:=COUNT(VOL>4000 AND CLOSE>REF(CLOSE,1),0);
黄次数:COUNT(VOL>DYNAINFO(16)*10 AND CLOSE>REF(CLOSE,1),0),NODRAW,COLORYELLOW;
DRAWICON(X_42>REF(X_42,1) AND 黄次数>REF(黄次数,1) AND CROSS(CLOSE,地),CLOSE,7);
DRAWICON(X_32>X_33 AND X_28>X_32 AND X_33>X_29,X_8,14);
查看全部打赏
  • 小豌豆1号+2理想币 : 知识的价值在于分享,点赞是价值认同。

举报

点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表