手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

恳请老师帮忙写个选股公式

[通达信]
设置
2244 2 张彪77 Lv.3 发表于 · 2019-12-3 17:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
X_1:=(3*CLOSE+LOW+OPEN+HIGH)/6;
X_2:=EMA(X_1,13);
X_3:=EMA(X_2,3);
X_4:=EMA(X_3,3);
X_5:=EMA(X_4,3);
X_6:=EMA(X_5,3);
X_7:=EMA(X_6,3);
DRAWBAND(X_2,RGB(150,50,20),X_7,RGB(36,150,40));
NOTEXTMB101:IF(X_2>X_3,X_2,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB102:IF(X_2<X_3,X_2,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB201:IF(X_3>X_4,X_3,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB202:IF(X_3<X_4,X_3,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB301:IF(X_4>X_5,X_4,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB302:IF(X_4<X_5,X_4,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB401:IF(X_5>X_6,X_5,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB402:IF(X_5<X_6,X_5,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB501:IF(X_6>X_7,X_6,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB502:IF(X_6<X_7,X_6,DRAWNULL),DOTLINE,COLORGREEN;
NOTEXTMB601:IF(X_7>REF(X_7,1),X_7,DRAWNULL),DOTLINE,COLORMAGENTA;
NOTEXTMB602:IF(X_7<REF(X_7,1),X_7,DRAWNULL),DOTLINE,COLORGREEN;
X_8:=(20*X_1+19*REF(X_1,1)+18*REF(X_1,2)+17*REF(X_1,3)+16*REF(X_1,4)+15*REF(X_1,5)+14*REF(X_1,6)+13*REF(X_1,7)+12*REF(X_1,8)+11*REF(X_1,9)+10*REF(X_1,10)+9*REF(X_1,11)+8*REF(X_1,12)+7*REF(X_1,13)+6*REF(X_1,14)+5*REF(X_1,15)+4*REF(X_1,16)+3*REF(X_1,17)+2*REF(X_1,18)+REF(X_1,20))/210;
X_9:=MA(X_8,20);
X_10:=MA(X_9,2);
DRAWBAND(X_9,RGB(250,0,0),X_10,RGB(250,250,0));
NOTEXTDTTJ:CONST(CLOSE),DOTLINE,COLORGRAY;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
STICKLINE(CLOSE>OPEN,HIGH,LOW,0,0),COLOR7D7DFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0),COLOR7D7DFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.1,0),COLOR1313FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR2424FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),COLOR2D2DFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.6,0),COLOR4444FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.2,0),COLOR5757FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.6,0),COLOR6666FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0),COLOR7D7DFF;
STICKLINE(CLOSE<OPEN,HIGH,LOW,0,0),COLORAA9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0,0),COLORAA5500;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3.1,0),COLORAA6600;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.4,0),COLORAA7700;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2,0),COLORAA8800;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.6,0),COLORAA9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.2,0),COLORAAAA00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.6,0),COLORAACC00;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.1,0),COLORAADD00;

请老师辛苦帮忙写个选股,收盘价在带上,在线上 ,谢谢
老马识途10
Lv.7
发表于 2019-12-3 17:50 复制 查看全部楼层
回复.txt [预览] (525 Bytes, 下载次数: 0)
查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
休闲者68
Lv.6
发表于 2019-12-3 17:34 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-3 22:04 编辑

供参考

附件

回复.txt [预览]

491 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表