手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙做成选股公式

[通达信]
设置
2294 1 金红叶 Lv.2 发表于 · 2019-12-3 17:54 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

请老师帮忙把此公式做成选股公式,选股条件为(所有黄杠均能选股),谢谢!



N:=72;
M:=15;
N2:=3;
RSV1:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:3*K1-2*D1,NODRAW;
J值:=IF(J1>100 AND J1<REF(J1,1),100,J1);
RSV:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(100);
TJ:=IF((RSV<5),0,RSV);
操作:IF((TJ>95),100,TJ),NODRAW;
危量:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,
(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW;
走势1:=EMA(CLOSE,6);
白线:(走势1-REF(走势1,1))/REF(走势1,1)*10000,NODRAW;
BX:=IF(白线>100,100,白线);
多方:100-(100*(HHV(HIGH,N2)-CLOSE)/(HHV(HIGH,N2)-LLV(LOW,N2))),NODRAW;
DL:=IF(多方<REF(多方,1) AND REF(多方,1)>90,100,多方);
RE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)+20;
乖离:IF(RE>100,100,0);
概率:(J值+操作+危量+DL+BX+乖离)/6,NODRAW;
STICKLINE(概率>75 AND 危量>90
AND (J值<REF(J值,1) OR 操作<REF(操作,1) OR 多方<REF(多方,1) ),0,概率,3,0),COLORRED;
STICKLINE(IF(危量=100 AND 操作=100,100,0 ),100,0,2,0),COLORYELLOW;
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA:=SMA(VARF,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (AA>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (AA>SS),50,'回');
休闲者68
Lv.6
发表于 2019-12-3 18:00 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-3 22:06 编辑

供参考

附件

回复.txt [预览]

255 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
  • 金红叶+2理想币 +2共享币 : 很给力,理想因你而精彩;
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表