手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

麻烦老师给合并指标

[通达信]
设置
2249 4 胡不拉 Lv.2 发表于 · 2019-12-4 10:34 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
主力能量指标:

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量),NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORGREEN;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),'主力'),COLORRED;


大户量能:

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
大户能量:(大户-均量),NODRAW;
操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1,0),COLORRED;
减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1,0),COLORRED;
反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1,0),COLORGREEN;
寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,2.7,3.3),'大户'),COLORYELLOW;


中户量能:

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
中户能量:(中户-均量),NODRAW;
操盘2:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORRED;
减仓2:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORRED;
反弹2:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORGREEN;
寻底2:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,1.2,1.8),'中户'),COLORMAGENTA;

散户量能:

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
散户能量:(散户-均量),NODRAW;
操盘3:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORRED;
减仓3:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORRED;
反弹3:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORGREEN;
寻底3:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,-0.3,0.3),'散户'),COLORGREEN;


老师看看能不能把这几个指标合并成一个,或只是合并成散户+中户。大户+主力两两合并。主要是为了看盘方便、谢谢
尔想才富
Lv.2
发表于 2019-12-4 13:09 复制 查看全部楼层
换手:=V*100/CAPITAL; 主力:=MA(换手,4); 大户:=MA(换手,9); 中户:=MA(换手,17); 散户:=MA(换手,34); 均量:=(主力+大户+中户+散户)/4; 主力能量:(主力-均量),NODRAW; 操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED; 减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORRED; 反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORGREEN; 寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),4.5,4.5+主力能量,1,0),COLORGREEN; DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,4.2,4.8),'主力'),COLORRED;  大户能量:(大户-均量),NODRAW; 操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1,0),COLORRED; 减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1,0),COLORRED; 反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),3,3+大户能量,1,0),COLORGREEN; 寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),3,3+大户能量,1,0),COLORGREEN; DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,2.7,3.3),'大户'),COLORYELLOW;  中户能量:(中户-均量),NODRAW; 操盘2:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORRED; 减仓2:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORRED; 反弹2:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORGREEN; 寻底2:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),1.5,1.5+中户能量,1,0),COLORGREEN; DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,1.2,1.8),'中户'),COLORMAGENTA;  散户能量:(散户-均量),NODRAW; 操盘3:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORRED; 减仓3:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORRED; 反弹3:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORGREEN; 寻底3:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORGREEN; DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,-0.3,0.3),'散户'),COLORGREEN;
胡不拉
Lv.2
发表于 2019-12-4 11:08 复制 查看全部楼层
非常感谢,祝您投资愉快
许昌舍得
Lv.6
发表于 2019-12-4 10:43 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-4 11:44 编辑

供参考

附件

回复.txt [预览]

2.28 KB, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
影库
Lv.4
发表于 2019-12-4 10:36 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-4 11:41 编辑

供参考

附件

回复.txt [预览]

2.29 KB, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表