手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助在AAA和CCC字出现时写一个选股指标

[通达信]
设置
4501 13 小林a Lv.4 发表于 · 2019-12-4 08:26 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
参数   M1  0  999  0
         M2  0  999   0
         M3  0  999   0
         M4  0   100  0




DRAWNUMBER(BARSLAST(ZTPRICE(REF(C,1),0.1)=C)<=15 AND BARSLAST(ZTPRICE(REF(C,1),0.1)=C)>=1,1.005*H,BARSLAST(ZTPRICE(REF(C,1),0.1)=C)),COLORGREEN;




STICKLINE(C>REF(C,1)*1.095,C,O,2,0),COLORYELLOW;



{智能版:="核心指标.VAR100#DAY";}
智能版:="指标.核心#DAY";
MA1:MA(CLOSE,M1),COLORWHITE;
MA2:MA(CLOSE,M2),COLORYELLOW;
MA3:MA(CLOSE,M3),COLORCYAN;
MA4:MA(CLOSE,M4),COLORCYAN;
成本:((COST(90)+COST(70)+COST(50)+COST(30)+COST(10))/5)*成本线,LINETHICK2,COLORWHITE;
{阳线上下影}
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,HIGH,0,0), COLORRED;
STICKLINE(CLOSE*成本线>=OPEN,OPEN,LOW,0,0), COLORRED;
{阴线上下影}
STICKLINE(CLOSE<OPEN*成本线,OPEN,HIGH,0,0), COLOR00EC00;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,LOW,0,0), COLOR00EC00;
{阳K线}
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,2.9.2,0),COLOR0000A1;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,1.9.2,0),COLOR0000B5;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.9.8,0),COLOR0000C5;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.4,0),COLOR0000D4;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.2,0),COLOR0000FF;
{阴K线}
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,2.9.2,0),COLOR009000;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,1.9.2,0),COLOR00B400;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.9.8,0),COLOR00C100;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.4,0),COLOR00DB00;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.2,0),COLOR00EC00;

日线:=IF(PERIOD=5,1,0);
CA3:=REF(C,1)*日线;
涨停:=IF((C-CA3)*100/CA3>=(10-0.01*100/CA3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.9.1,1),COLORYELLOW;
跌停:=IF((CA3-C)*100/CA3>=(10-0.01*100/CA3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.9.1,0),COLORCYAN;
A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1)*智能版;
B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1)*智能版;
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
DRAWLINE(LD,L,HD,H,0),COLORYELLOW,LINETHICK1;
DRAWLINE(HD,H,LD,L,0),COLORYELLOW,LINETHICK1;
J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);

A3:=H;
B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1);
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用}
{DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;
DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;长期连线}
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
{DRAWLINE(K2,IF(HZ,H,L),BARSTATUS=2,C,0),COLORGREEN,LINETHICK1; 最后的长期连线,连在收盘价上}
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
XXQ:=WWQ>REF(WWQ,1);
下轨:DRAWLINE(XX,L,VV,L,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);
XX3Q:=WW3Q>REF(WW3Q,1);
WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);
XX4Q:=WW4Q>REF(WW4Q,1);
上轨:DRAWLINE(XX2,H,VV2,H,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
上轨1:=DRAWLINE(XX2,H,VV2,H,1);

Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
Q2:=BARSLAST(WW2>0);
Q3:=BARSLAST(VV>0);
Q4:=BARSLAST(XXQ>0);
Q5:=BARSLAST(XX3Q>0);
Q6:=BARSLAST(XX4Q>0);
OA周:=Q0-Q1+1;AB周:=Q1-Q2+1;BC周:=Q2-Q3+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.01,1,STRCAT('◆A: ',STRCAT(CON2STR(OA周,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.08,1,STRCAT(' A―B: ',STRCAT(CON2STR(AB周,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.16,1,STRCAT(' B―C: ',STRCAT(CON2STR(BC周,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.24,1,STRCAT('C---: ',STRCAT(CON2STR(Q3,0),'周')))COLORYELLOW;
{123周期}
Z01:=Q1-Q0+1;Z12:=Q0-Q3+1;Z23:=Q3-Q2+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.01,1,STRCAT('◎―1: ',STRCAT(CON2STR(Z01,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.08,1,STRCAT('1―2: ',STRCAT(CON2STR(Z12,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.16,1,STRCAT('2―3: ',STRCAT(CON2STR(Z23,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.24,1,STRCAT('3---  : ',STRCAT(CON2STR(Q2,0),'周')))COLORYELLOW;

低一:REF(L,BARSLAST(VV)),DOTLINE,COLOR99FF66;
高一:REF(H,BARSLAST(VV2)),DOTLINE,COLOR99FF66;
低二:REF(L,BARSLAST(XX)),DOTLINE,COLORFF66FF;
高二:REF(H,BARSLAST(XX2)),DOTLINE,COLORFF66FF;
ABC:IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0),DOTLINE,COLORCYAN;
①②③:IF(Q5<Q4,REF(H,BARSLAST(XX3Q)),0),DOTLINE,COLORCYAN;

{ABC涨跌}
OA幅:=(低二-高二)/低二*100;AB幅:=(高一-低二)/低二*100;BC幅:=(低一-高一)/高一*100;AO幅:=(C-低一)/C*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.01,0,STRCAT('跌',STRCAT(CON2STR(OA幅,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.08,0,STRCAT('涨',STRCAT(CON2STR(AB幅,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.16,0,STRCAT('跌',STRCAT(CON2STR(BC幅,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.24,0,STRCAT('涨',STRCAT(CON2STR(AO幅,0),'%')))COLORYELLOW;
{123涨跌}
D01:=(高二-低二)/低二*100;D12:=(低一-高二)/低一*100;D23:=(高一-低一)/低一*100;D30:=(C-高一)/C*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.01,0,STRCAT('涨',STRCAT(CON2STR(D01,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.08,0,STRCAT('跌',STRCAT(CON2STR(D12,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.16,0,STRCAT('涨',STRCAT(CON2STR(D23,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.24,0,STRCAT('跌',STRCAT(CON2STR(D30,0),'%')))COLORYELLOW;
笔:DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORYELLOW,LINETHICK1;
{近半分位:高一-(高一-低一)*(0.01*半分位),COLOR99FF66;}
近半分位:低一-(低一-高一)*(0.01*半分位),COLOR99FF66;
STICKLINE(VV,高一,低一,0,1),COLOR99FF66;
STICKLINE(VV2 ,高一,低一,0,0),COLOR99FF66;
DRAWTEXT( VV=1 AND Q0>Q1,L,'CCCCC')COLORRED;
DRAWTEXT(VV2=1 AND Q0>Q1,H,'BB')COLORGREEN;
DRAWTEXT( XX=1 AND Q0>Q1,L,'AAA')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q5>Q4 ,H,'◆◆')COLORMAGENTA;
DRAWTEXT(XXQ=1 AND Q5>Q4 ,L,'★★')COLORMAGENTA;

DRAWTEXT( VV=1 AND Q0<Q1,L,'②')COLORMAGENTA;
DRAWTEXT(VV2=1 AND Q0<Q1,H,'③')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q0<Q1,H,'①')COLORMAGENTA;
DRAWTEXT(XX=1  AND Q5<Q4,L,'◎◎')COLORMAGENTA;
DRAWTEXT(XX3Q=1  AND Q5<Q4,H,'☆')COLORMAGENTA;

V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,3)>=1 AND LLVBARS(LOW,3) = 1 AND V03;
V2:= COUNT(V00,4)>=1 AND LLVBARS(LOW,4) = 2 AND V04;
V3:= COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4) = 1 AND V03;
V4:= COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5) = 2 AND V04;
XG1:= V1 OR V2 OR V3 OR V4;
XG2:= C > REF(HIGH,1);
XG:=XG1 AND XG2;
一阳定势:CROSS(C,高一) AND CROSS(C,高二) AND CROSS(C,①②③),COLORYELLOW,NODRAW;
STICKLINE(一阳定势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(一阳定势=1,L,'一阳定势'),COLORYELLOW;
收敛:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二>高一 AND CROSS(C,上轨1);
STICKLINE(收敛,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(收敛=1,L,'收敛'),COLORYELLOW;
强势:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二<高一 AND CROSS(C,高一);
STICKLINE(强势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(强势=1,L,'强势'),COLORYELLOW;
三买:(低一>高二 AND 近半分位>低一 AND XG>0 AND C>O),COLORYELLOW,NODRAW;
STICKLINE(三买,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(三买=1,L,'三买'),COLORYELLOW;
{涨停向右画线}
涨停线:REF(L+(H-L)*(0.01*涨停位),BARSLAST(CONST(BARSLAST(IF(CURRBARSCOUNT<=390*日线,涨停,0)))+1=CURRBARSCOUNT)),DOTLINE,COLORYELLOW;
涨停幅:(L-涨停线)/涨停线*100,NODRAW;


{C>REF(C,1)*1.097,0}
{◎ ①②③④⑤⑥⑦⑧⑨⑩ Α★☆? A●◎ABCDEFGHIJKLMN};
本主题由 任务系统 于 2019-12-7 13:42 合并
影库
Lv.4
发表于 2019-12-5 09:27 复制 查看全部楼层
新开一贴可以考虑
小林a
Lv.4
发表于 2019-12-4 18:40 复制 查看全部楼层
本帖最后由 小林a 于 2019-12-4 18:41 编辑
影库 发表于 2019-12-4 11:58
已经搞定请查收


辛苦影库老师了,请老师做2个选股就是AAA一个CCC一个2个分开单独选股,就是做2个选股指标,不是AAACCC合在一起选,再麻烦老师一次,谢谢
小林a
Lv.4
发表于 2019-12-4 18:36 复制 查看全部楼层
小兵一枚 发表于 2019-12-4 11:43
A1:=REF(HIGH,3)=HHV(HIGH,3*3+1);
B1:=FILTER(A1,3);
C1:=BACKSET(B1,3+1);

非常感谢小兵老师,谢谢您
影库
Lv.4
发表于 2019-12-4 11:58 复制 查看全部楼层
已经搞定请查收

附件

选股.txt [预览]

1.12 KB, 下载次数: 1, 下载积分: 共享币 -5 个

影库
Lv.4
发表于 2019-12-4 11:55 复制 查看全部楼层
好容易好了

附件

选股.txt [预览]

1.12 KB, 下载次数: 1, 下载积分: 共享币 -5 个

小兵一枚
Lv.2
发表于 2019-12-4 11:43 复制 查看全部楼层



A1:=REF(HIGH,3)=HHV(HIGH,3*3+1);
B1:=FILTER(A1,3);
C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,3*3+1);
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}


A3:=H;
B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1);
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1);
I4:=BACKSET(G4,2);
HZ:=I4>REF(I4,1);
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);
K2:=K1>REF(K1,1);
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
XXQ:=WWQ>REF(WWQ,1);
下轨:=DRAWLINE(XX,L,VV,L,1);{画趋势线}
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
XXG:(VV OR XX) AND Q0>Q1;



小兵一枚
Lv.2
发表于 2019-12-4 11:42 复制 查看全部楼层



A1:=REF(HIGH,3)=HHV(HIGH,3*3+1);
B1:=FILTER(A1,3);
C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,3*3+1);
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}


A3:=H;
B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1);
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1);
I4:=BACKSET(G4,2);
HZ:=I4>REF(I4,1);
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1);
K2:=K1>REF(K1,1);
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
XXQ:=WWQ>REF(WWQ,1);
下轨:=DRAWLINE(XX,L,VV,L,1);{画趋势线}
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
XXG:(VV OR XX) AND Q0>Q1;



闹海老龙神
Lv.5
发表于 2019-12-4 11:23 复制 查看全部楼层
源码不全,无法测试选股结果
影库
Lv.4
发表于 2019-12-4 10:54 复制 查看全部楼层
含有未来只能参考没有实际意义,要找引导公式比较麻烦
小林a
Lv.4
发表于 2019-12-4 10:40 复制 查看全部楼层
本帖最后由 小林a 于 2019-12-4 11:09 编辑

参数   M1  0  999  0
         M2  0  999   0
         M3  0  999   0
         M4  0   100  0
比周期  1  999  3
画趋势  0   1     0
涨停位  0   1000  50
半分位  0   1000  50
成本线  0   1       0




DRAWNUMBER(BARSLAST(ZTPRICE(REF(C,1),0.1)=C)<=15 AND BARSLAST(ZTPRICE(REF(C,1),0.1)=C)>=1,1.005*H,BARSLAST(ZTPRICE(REF(C,1),0.1)=C)),COLORGREEN;




STICKLINE(C>REF(C,1)*1.095,C,O,2,0),COLORYELLOW;



{智能版:="核心指标.VAR100#DAY";}
智能版:="指标.核心#DAY";
MA1:MA(CLOSE,M1),COLORWHITE;
MA2:MA(CLOSE,M2),COLORYELLOW;
MA3:MA(CLOSE,M3),COLORCYAN;
MA4:MA(CLOSE,M4),COLORCYAN;
成本:((COST(90)+COST(70)+COST(50)+COST(30)+COST(10))/5)*成本线,LINETHICK2,COLORWHITE;
{阳线上下影}
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,HIGH,0,0), COLORRED;
STICKLINE(CLOSE*成本线>=OPEN,OPEN,LOW,0,0), COLORRED;
{阴线上下影}
STICKLINE(CLOSE<OPEN*成本线,OPEN,HIGH,0,0), COLOR00EC00;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,LOW,0,0), COLOR00EC00;
{阳K线}
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,2.9.2,0),COLOR0000A1;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,1.9.2,0),COLOR0000B5;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.9.8,0),COLOR0000C5;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.4,0),COLOR0000D4;
STICKLINE(CLOSE*成本线>=OPEN,CLOSE,OPEN,0.2,0),COLOR0000FF;
{阴K线}
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,2.9.2,0),COLOR009000;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,1.9.2,0),COLOR00B400;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.9.8,0),COLOR00C100;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.4,0),COLOR00DB00;
STICKLINE(CLOSE<OPEN*成本线,CLOSE,OPEN,0.2,0),COLOR00EC00;

日线:=IF(PERIOD=5,1,0);
CA3:=REF(C,1)*日线;
涨停:=IF((C-CA3)*100/CA3>=(10-0.01*100/CA3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.9.1,1),COLORYELLOW;
跌停:=IF((CA3-C)*100/CA3>=(10-0.01*100/CA3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.9.1,0),COLORCYAN;
A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1)*智能版;
B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1)*智能版;
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);{过滤后高点}
DRAWLINE(LD,L,HD,H,0),COLORYELLOW,LINETHICK1;
DRAWLINE(HD,H,LD,L,0),COLORYELLOW,LINETHICK1;
J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);

A3:=H;
B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1);
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用}
{DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;
DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;长期连线}
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
{DRAWLINE(K2,IF(HZ,H,L),BARSTATUS=2,C,0),COLORGREEN,LINETHICK1; 最后的长期连线,连在收盘价上}
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
XXQ:=WWQ>REF(WWQ,1);
下轨:DRAWLINE(XX,L,VV,L,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);
XX3Q:=WW3Q>REF(WW3Q,1);
WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);
XX4Q:=WW4Q>REF(WW4Q,1);
上轨:DRAWLINE(XX2,H,VV2,H,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
上轨1:=DRAWLINE(XX2,H,VV2,H,1);

Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
Q2:=BARSLAST(WW2>0);
Q3:=BARSLAST(VV>0);
Q4:=BARSLAST(XXQ>0);
Q5:=BARSLAST(XX3Q>0);
Q6:=BARSLAST(XX4Q>0);
OA周:=Q0-Q1+1;AB周:=Q1-Q2+1;BC周:=Q2-Q3+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.01,1,STRCAT('◆A: ',STRCAT(CON2STR(OA周,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.08,1,STRCAT(' A―B: ',STRCAT(CON2STR(AB周,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.16,1,STRCAT(' B―C: ',STRCAT(CON2STR(BC周,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.10,0.24,1,STRCAT('C---: ',STRCAT(CON2STR(Q3,0),'周')))COLORYELLOW;
{123周期}
Z01:=Q1-Q0+1;Z12:=Q0-Q3+1;Z23:=Q3-Q2+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.01,1,STRCAT('◎―1: ',STRCAT(CON2STR(Z01,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.08,1,STRCAT('1―2: ',STRCAT(CON2STR(Z12,0),'周')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.16,1,STRCAT('2―3: ',STRCAT(CON2STR(Z23,0),'周')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.10,0.24,1,STRCAT('3---  : ',STRCAT(CON2STR(Q2,0),'周')))COLORYELLOW;

低一:REF(L,BARSLAST(VV)),DOTLINE,COLOR99FF66;
高一:REF(H,BARSLAST(VV2)),DOTLINE,COLOR99FF66;
低二:REF(L,BARSLAST(XX)),DOTLINE,COLORFF66FF;
高二:REF(H,BARSLAST(XX2)),DOTLINE,COLORFF66FF;
ABC:IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0),DOTLINE,COLORCYAN;
①②③:IF(Q5<Q4,REF(H,BARSLAST(XX3Q)),0),DOTLINE,COLORCYAN;

{ABC涨跌}
OA幅:=(低二-高二)/低二*100;AB幅:=(高一-低二)/低二*100;BC幅:=(低一-高一)/高一*100;AO幅:=(C-低一)/C*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.01,0,STRCAT('跌',STRCAT(CON2STR(OA幅,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.08,0,STRCAT('涨',STRCAT(CON2STR(AB幅,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.16,0,STRCAT('跌',STRCAT(CON2STR(BC幅,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.24,0,STRCAT('涨',STRCAT(CON2STR(AO幅,0),'%')))COLORYELLOW;
{123涨跌}
D01:=(高二-低二)/低二*100;D12:=(低一-高二)/低一*100;D23:=(高一-低一)/低一*100;D30:=(C-高一)/C*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.01,0,STRCAT('涨',STRCAT(CON2STR(D01,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.08,0,STRCAT('跌',STRCAT(CON2STR(D12,0),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.16,0,STRCAT('涨',STRCAT(CON2STR(D23,0),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.24,0,STRCAT('跌',STRCAT(CON2STR(D30,0),'%')))COLORYELLOW;
笔:DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORYELLOW,LINETHICK1;
{近半分位:高一-(高一-低一)*(0.01*半分位),COLOR99FF66;}
近半分位:低一-(低一-高一)*(0.01*半分位),COLOR99FF66;
STICKLINE(VV,高一,低一,0,1),COLOR99FF66;
STICKLINE(VV2 ,高一,低一,0,0),COLOR99FF66;
DRAWTEXT( VV=1 AND Q0>Q1,L,'CCCCC')COLORRED;
DRAWTEXT(VV2=1 AND Q0>Q1,H,'BB')COLORGREEN;
DRAWTEXT( XX=1 AND Q0>Q1,L,'AAA')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q5>Q4 ,H,'◆◆')COLORMAGENTA;
DRAWTEXT(XXQ=1 AND Q5>Q4 ,L,'★★')COLORMAGENTA;

DRAWTEXT( VV=1 AND Q0<Q1,L,'②')COLORMAGENTA;
DRAWTEXT(VV2=1 AND Q0<Q1,H,'③')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q0<Q1,H,'①')COLORMAGENTA;
DRAWTEXT(XX=1  AND Q5<Q4,L,'◎◎')COLORMAGENTA;
DRAWTEXT(XX3Q=1  AND Q5<Q4,H,'☆')COLORMAGENTA;

V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,3)>=1 AND LLVBARS(LOW,3) = 1 AND V03;
V2:= COUNT(V00,4)>=1 AND LLVBARS(LOW,4) = 2 AND V04;
V3:= COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4) = 1 AND V03;
V4:= COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5) = 2 AND V04;
XG1:= V1 OR V2 OR V3 OR V4;
XG2:= C > REF(HIGH,1);
XG:=XG1 AND XG2;
一阳定势:CROSS(C,高一) AND CROSS(C,高二) AND CROSS(C,①②③),COLORYELLOW,NODRAW;
STICKLINE(一阳定势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(一阳定势=1,L,'一阳定势'),COLORYELLOW;
收敛:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二>高一 AND CROSS(C,上轨1);
STICKLINE(收敛,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(收敛=1,L,'收敛'),COLORYELLOW;
强势:ABC>0 AND ABC<低二 AND 低二<低一 AND 高二<高一 AND CROSS(C,高一);
STICKLINE(强势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(强势=1,L,'强势'),COLORYELLOW;
三买:(低一>高二 AND 近半分位>低一 AND XG>0 AND C>O),COLORYELLOW,NODRAW;
STICKLINE(三买,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(三买=1,L,'三买'),COLORYELLOW;
{涨停向右画线}
涨停线:REF(L+(H-L)*(0.01*涨停位),BARSLAST(CONST(BARSLAST(IF(CURRBARSCOUNT<=390*日线,涨停,0)))+1=CURRBARSCOUNT)),DOTLINE,COLORYELLOW;
涨停幅:(L-涨停线)/涨停线*100,NODRAW;


{C>REF(C,1)*1.097,0}
{◎ ①②③④⑤⑥⑦⑧⑨⑩ Α★☆? A●◎ABCDEFGHIJKLMN};

小林a
Lv.4
发表于 2019-12-4 10:29 复制 查看全部楼层
影库 发表于 2019-12-4 09:59
笔周期:=3;
智能版:='指标.核心#DAY';
A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1)*智能版;

影库老师,那怎么办,辛苦您能不能帮我写一个引导公式,我是真想要这个选股指标
影库
Lv.4
发表于 2019-12-4 09:59 复制 查看全部楼层
笔周期:=3;
智能版:='指标.核心#DAY';
A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1)*智能版;
B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1)*智能版;
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
X1:=VV=1 AND Q0>Q1;
X2:=XX=1 AND Q0>Q1;
X1 OR X2;

你的公式不完整缺少引用公式指标
影库
Lv.4
发表于 2019-12-4 09:58 复制 查看全部楼层
本帖最后由 影库 于 2019-12-4 10:11 编辑

笔周期:=3;
智能版:='指标.核心#DAY';
A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1)*智能版;
B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);
A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1)*智能版;
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH+LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
X1:=VV=1 AND Q0>Q1;
X2:=XX=1 AND Q0>Q1;
X1 OR X2;
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表