手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把下面辐图改成预警公式

[通达信]
设置
2549 5 新手GM Lv.2 发表于 · 2019-12-4 15:32 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
NOTEXT成本区:50,COLORYELLOW,LINETHICK1;
NOTEXT获利区:160,COLORGREEN,LINETHICK1;
R4:=(2*C+H+L)/4;
R5:=LLV(L,94);  
R6:=HHV(H,89);
快:=EMA((C-R5)/(R6-R5)*100,8);
慢:=EMA(0.667*REF(快,1)+0.333*快,10);

DF:=3;
N1:=12;
RSV0:=(C-LLV(L,N1))/(HHV(H,N1)-LLV(L,N1))*100;
RSV1:=EMA((C-LLV(L,12))/(HHV(H,12)-LLV(L,12))*100,2);
RSV2:=EMA(SMA((C-LLV(L,19))/(HHV(H,19)-LLV(L,19))*100,8,1),3);
K:=SMA(RSV0,3,1);
D:=SMA(K,3,1);
KK:=SMA(RSV0,3,1);
DD:=SMA(K,3,1);
N:=KK+DD;
关注区:STICKLINE(N<50,N,50,1,0),COLORRED;
风险区:STICKLINE(N>160,N,160,1,0),COLORGREEN;

操盘线:N,COLORMAGENTA,LINETHICK1;
买:DRAWICON(CROSS(N,50),50,34);
卖:DRAWICON(CROSS(160,N),160,35);

{CCI}
INDEX:=CCI(14);
CCI:=CROSS(INDEX,-100);
STICKLINE(CCI AND N<50,60,90,1,0),COLORYELLOW;
STICKLINE(CCI AND N<50 AND N>REF(N,1),60,70,3,0),COLORMAGENTA;
STICKLINE(CCI AND N<50 AND CROSS(RSV1,RSV2),80,90,3,0),COLORRED;
STICKLINE(CCI AND N>50,65,85,2,0),COLORBLUE;

{前瞻}
A18:=EMA(C,2);
A19:=EMA((((SLOPE(C,21))*20)+C),42);
A20:=HHV((MA(H,13)),13);
A21:=LLV((MA(H,13)),1);
A22:=EMA(C,4);
A23:=(A18>=A19 AND A21=A20 AND A18>A22 AND C>A21 AND REF(A21,1)<REF(A20,1));
A24:=BARSLAST(A23)+1;
A25:=(LLV(L,A24))*1.3;
A26:=(LLV(L,20))*1.418;
A27:=(A18>=A19 AND A21=A20 AND C/REF(C,1)>=1.07 AND A24<=30 AND C<=A25 AND C<=A26);
A28:=A27 AND FILTER(A27,A24);
A30:=(A18>=A19 AND A21=A20 AND C/REF(C,1)>=1.035 AND A24<=30 AND C<=A25 AND C<=A26);
A31:=A30 AND FILTER(A30,20);
前瞻《加号》:(A28 OR A31),NODRAW;
DRAWICON(前瞻《加号》,45,23);
LS:=C/REF(C,1)>1.01 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升《钱袋》:FILTER(LS,1),NODRAW;
DRAWICON(拉升《钱袋》,55,9);

短DIFF1:=EMA(CLOSE,3)-EMA(CLOSE,6);
短DEA1:=EMA(短DIFF1,4);
短低位金叉:=CROSS(短DIFF1,短DEA1) AND 短DIFF1<-0.1;
短JCCOUNT:=COUNT(CROSS(短DIFF1,短DEA1),BARSLAST(短DEA1>=0));
短二次金叉:=CROSS(短DIFF1,短DEA1) AND 短DEA1<0 AND COUNT(短JCCOUNT=2,21)=1;
短A111:=BARSLAST(REF(CROSS(短DIFF1,短DEA1),1));
短底背离:=REF(CLOSE,短A111+1)>CLOSE AND 短DIFF1>REF(短DIFF1,短A111+1) AND CROSS(短DIFF1,短DEA1);
DRAWICON(短低位金叉 AND 短二次金叉 AND 短底背离,100,26);

中DIFF1:=EMA(CLOSE,6)-EMA(CLOSE,13);
中DEA1:=EMA(中DIFF1,5);
中低位金叉:=CROSS(中DIFF1,中DEA1) AND 中DIFF1<-0.1;
中JCCOUNT:=COUNT(CROSS(中DIFF1,中DEA1),BARSLAST(中DEA1>=0));
中二次金叉:=CROSS(中DIFF1,中DEA1) AND 中DEA1<0 AND COUNT(中JCCOUNT=2,21)=1;
中A111:=BARSLAST(REF(CROSS(中DIFF1,中DEA1),1));
中底背离:=REF(CLOSE,中A111+1)>CLOSE AND 中DIFF1>REF(中DIFF1,中A111+1) AND CROSS(中DIFF1,中DEA1);
DRAWICON(中低位金叉 AND 中二次金叉 AND 中底背离,120,25);

长DIFF1:=EMA(C,12)-EMA(C,26);
长DEA1:=EMA(长DIFF1,9);
长低位金叉:=CROSS(长DIFF1,长DEA1) AND 长DIFF1<-0.1;
长JCCOUNT:=COUNT(CROSS(长DIFF1,长DEA1),BARSLAST(长DEA1>=0));
长二次金叉:=CROSS(长DIFF1,长DEA1) AND 长DEA1<0 AND COUNT(长JCCOUNT=2,21)=1;
长A111:=BARSLAST(REF(CROSS(长DIFF1,长DEA1),1));
长底背离:=REF(CLOSE,长A111+1)>CLOSE AND 长DIFF1>REF(长DIFF1,长A111+1) AND CROSS(长DIFF1,长DEA1);
DRAWICON(长低位金叉 AND 长二次金叉 AND 长底背离,140,24);



附件

操盘线在100轴以内的股票写预警信号

操盘线在100轴以内的股票写预警信号
许昌舍得
Lv.6
发表于 2019-12-4 19:36 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-5 15:05 编辑

供参考

附件

回复.txt [预览]

339 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
新手GM
Lv.2
发表于 2019-12-4 17:42 复制 查看全部楼层
许昌舍得 发表于 2019-12-4 17:37
LS:=C/REF(C,1)>1.01 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升《钱 ...

老师都不对,我要的是这个区间段的
许昌舍得
Lv.6
发表于 2019-12-4 17:37 复制 查看全部楼层
LS:=C/REF(C,1)>1.01 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升《钱袋》:=FILTER(LS,1);
XG:拉升《钱袋》;
许昌舍得
Lv.6
发表于 2019-12-4 17:33 复制 查看全部楼层
长DIFF1:=EMA(C,12)-EMA(C,26);
长DEA1:=EMA(长DIFF1,9);
长低位金叉:=CROSS(长DIFF1,长DEA1) AND 长DIFF1<-0.1;
长JCCOUNT:=COUNT(CROSS(长DIFF1,长DEA1),BARSLAST(长DEA1>=0));
长二次金叉:=CROSS(长DIFF1,长DEA1) AND 长DEA1<0 AND COUNT(长JCCOUNT=2,21)=1;
长A111:=BARSLAST(REF(CROSS(长DIFF1,长DEA1),1));
长底背离:=REF(CLOSE,长A111+1)>CLOSE AND 长DIFF1>REF(长DIFF1,长A111+1) AND CROSS(长DIFF1,长DEA1);
XG:长低位金叉 AND 长二次金叉 AND 长底背离;
新手GM
Lv.2
发表于 2019-12-4 16:34 复制 查看全部楼层
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表