手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助按要求把下面副图改写预警公式

[通达信]
设置
2580 8 新手GM Lv.2 发表于 · 2019-12-4 16:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
STICKLINE(涨停,0,5,6,0),COLORYELLOW;
DRAWTEXT(涨停,8,'涨停'),COLORYELLOW;
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
STICKLINE(PP2 AND HH,0,5,3,0),COLORRED;
STICKLINE(PP AND HH,0,5,3,0),COLORRED;
STICKLINE(PP3 AND HH,0,5,3,0),COLORRED;
DRAWTEXT(PP2 AND HH,8,'预警'),COLORRED;
DRAWTEXT(PP AND HH,8,'预警'),COLORRED;
DRAWTEXT(PP3 AND HH,8,'预警'),COLORRED;
A:=SMA(L,4,3) ;
绿色买入:IF (((A AND REF(PP,1) AND HH) OR (A AND REF(PP3,1) AND HH)),1,0 );
STICKLINE(A AND REF(PP,1) AND HH ,0,10,1,0),COLORGREEN;
DRAWICON(A AND REF(PP,1) AND HH,12,1);
STICKLINE(A AND REF(PP3,1) AND HH ,0,10,1,0)COLORGREEN;
DRAWICON(A AND REF(PP3,1) AND HH,12,1);


请老师根据下图写预警信叫,预警时个股必须满足周线金叉

附件

微信图片_20191204160148.png
新手GM
Lv.2
发表于 2019-12-4 19:24 复制 查看全部楼层
许昌舍得 发表于 2019-12-4 18:31
涨停:=IF(REF(C,1)*1.1-C=1;

A:=SMA(L,4,3) ;

谢谢老师
新手GM
Lv.2
发表于 2019-12-4 19:24 复制 查看全部楼层
老马识途10 发表于 2019-12-4 18:29
涨停:=IF(REF(C,1)*1.1-C=1;
A:=SMA(L,4,3) ;
X1:=A AND REF(PP,1) AND HH;

谢谢老师
许昌舍得
Lv.6
发表于 2019-12-4 18:31 复制 查看全部楼层

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);

MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;

A:=SMA(L,4,3) ;

红箭头:A AND REF(PP,1) AND HH;
查看全部打赏
  • 福阿德+5理想币 +5共享币 : 赠人玫瑰,手有余香。
老马识途10
Lv.7
发表于 2019-12-4 18:29 复制 查看全部楼层
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
震仓线:=45;
震仓线2:=50;
抄底线:=20;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
A:=SMA(L,4,3) ;
X1:=A AND REF(PP,1) AND HH;
X2:=A AND REF(PP3,1) AND HH;
X1 OR X2;
新手GM
Lv.2
发表于 2019-12-4 17:48 复制 查看全部楼层
许昌舍得 发表于 2019-12-4 17:31
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12) ...

公式过不了
新手GM
Lv.2
发表于 2019-12-4 17:38 复制 查看全部楼层
许昌舍得 发表于 2019-12-4 17:31
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12) ...

当前公式 : 涨停回马枪V1 (画线指标公式)  
错误句 :
HH:=COUNT(涨停,13)>=1
详细信息 : 未知字符串 涨停
错误起始位置 : 480 ; 长度: 4
许昌舍得
Lv.6
发表于 2019-12-4 17:31 复制 查看全部楼层
本帖最后由 许昌舍得 于 2019-12-4 18:31 编辑

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);

MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;

A:=SMA(L,4,3) ;

红箭头:A AND REF(PP,1) AND HH;
查看全部打赏
  • 新手GM+10理想币 : 很给力,理想因你而精彩;
新手GM
Lv.2
发表于 2019-12-4 17:25 复制 查看全部楼层
请老师编写出红箭头的预警公式
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表