手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙编写个选股器

[通达信]
设置
3290 3 萤火虫oo Lv.2 发表于 · 2019-12-5 01:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
麻烦老师帮忙编写4个选股器,分别如下
第一个:出现“M周金叉”
第二个:出现“K周金叉”
第三个:出现“M月金叉”
第四个:出现“K月金叉”




DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100,COLOR0000FF,LINETHICK2;
DEA:=EMA(DIF,9),COLORFFFFFF,LINETHICK2;
MACD:=(DIF-DEA)*2,COLORSTICK;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DIFW:="MACD.DIF#WEEK";
DEAW:="MACD.DEA#WEEK";
FCA:=FILTER(CROSS(DIFW,DEAW),0);
SCA:=FILTER(CROSS(DEAW,DIFW),0);
M周金叉:IF(CROSS("MACD.DIF#WEEK","MACD.DEA#WEEK"),-50,0),COLOR0000FF,LINETHICK2;
DRAWTEXT(FCA,-45,' MACD周金叉'),COLOR0000FF;

DIFM:="MACD.DIF#MONTH"; DEAM:="MACD.DEA#MONTH";
FCB:=FILTER(CROSS(DIFM,DEAM),0);
SCB:=FILTER(CROSS(DEAM,DIFM),0);
M月金叉:IF(CROSS("MACD.DIF#MONTH","MACD.DEA#MONTH"),-60,0),COLOR00FFFF,LINETHICK2;
DRAWTEXT(FCB,-55,' MACD月金叉'),COLOR00FFFF;

KKW:="KD.K#WEEK",COLORRED; KDW:="KD.D#WEEK",COLORYELLOW;
KCD:=FILTER(CROSS(KKW,KDW),0);
SCD:=FILTER(CROSS(KDW,KKW),0);
K周金叉:IF(CROSS("KDJ.K#WEEK","KDJ.D#WEEK"),50,0),COLOR0000FF,LINETHICK2;
DRAWTEXT(KCD,50,' KDJ周金叉'),COLOR0000FF;

KKM:="KDJ.K#MONTH",COLORRED;
KDM:="KDJ.D#MONTH",COLORYELLOW;
KDB:=FILTER(CROSS(KKM,KDM),0);
SDB:=FILTER(CROSS(KDM,KKM),0);
K月金叉:IF(CROSS("KDJ.K#MONTH","KDJ.D#MONTH"),60,0),COLOR00FFFF,LINETHICK2;
DRAWTEXT(KDB,60,' KDJ月金叉'),COLOR00FFFF;
休闲者68
Lv.6
发表于 2019-12-5 07:52 复制 查看全部楼层
M周金叉:CROSS("MACD.DIF#WEEK","MACD.DEA#WEEK");

K周金叉:CROSS("KDJ.K#WEEK","KDJ.D#WEEK");

M月金叉:CROSS("MACD.DIF#MONTH","MACD.DEA#MONTH");

K月金叉:CROSS("KDJ.K#MONTH","KDJ.D#MONTH");
独行者行天下
Lv.4
发表于 2019-12-5 07:20 复制 查看全部楼层
月金叉在每月的1号才有信号的 ,周金叉在每周1才有信号的,
独行者行天下
Lv.4
发表于 2019-12-5 07:16 复制 查看全部楼层
试试效果就可以了

附件

回复.txt [预览]

206 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表