手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙将通达信主图指标修改为选股预警公式

[通达信]
设置
4490 8 深圳广东人 Lv.2 发表于 · 2019-12-6 15:24 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{均线粘合就买}
{-----------------------☆功能开关------------------------}
{线}
主线:=EMA(EMA(C,1),5);
本:EMA(HHV(主线,5),1),COLOR00FFFF,LINETHICK2;
急:EMA(HHV(本,21),1),COLOR0089FF,LINETHICK2;
稳:EMA(HHV(急,21),2),COLORDB89FF,COLOR00FF00,LINETHICK2;
投:EMA(HHV(稳,21),3),COLOR8916FF,LINETHICK2;
散:EMA(HHV(投,21),4),COLORFFCC62,LINETHICK2;
集:EMA(HHV(散,21),5),COLORFF9D52,LINETHICK2;
马:EMA(HHV(集,21),6),COLORFF5B5E,LINETHICK2;
界:MA(CLOSE,60),COLORFF66FF,LINETHICK2;
K2:=BACKSET(界<REF(界,1),2);
IF(K2,界,DRAWNULL),COLOR00A600,LINETHICK2;
{-----------------【图解模板】---------------------}
{K线}
STICKLINE(O>=C,H,L,0,0),COLORCYAN;
STICKLINE(O>=C,C,O,3,0),COLORCYAN;
STICKLINE(C>=O,L,H,0,0),COLORRED;
STICKLINE(C>=O,C,O,3,1),COLORRED;
{线}
IF(本<REF(本,1),本,DRAWNULL),COLOR00FFFF;
IF(急<REF(急,1),急,DRAWNULL),COLORFF9D52;
IF(稳<REF(稳,1),稳,DRAWNULL),COLORCCCCFF,COLORWHITE;
{IF(投<REF(投,1),投,DRAWNULL),COLORCCCCFF,COLORWHITE;}
{PARTLINE(散<REF(散,1),散),COLOR9999CC,LINETHICK1;
PARTLINE(集<REF(集,1),集),COLORCC99CC,LINETHICK1;
PARTLINE(跑马场<REF(跑马场,1),跑马场),COLORFF99CC,LINETHICK1;};

想法如下:当本线同时上穿稳,投,散,集,马五条线时发出预警!谢谢老师!
独行者行天下
Lv.4
发表于 2019-12-6 20:10 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-7 12:05 编辑

不用这么复杂简单点

简单

附件

回复.txt [预览]

256 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
休闲者68
Lv.6
发表于 2019-12-6 17:43 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-7 12:04 编辑
深圳广东人 发表于 2019-12-6 16:44
休闲者老师你好:@休闲者68

    先前你帮我改编的公式我选了一下,还有一些不符合要求的股也选了出来, ...


附件

回复.txt [预览]

282 Bytes, 下载次数: 3, 下载积分: 共享币 -5 个

深圳广东人
Lv.2
发表于 2019-12-6 15:42 复制 查看全部楼层
休闲者68 发表于 2019-12-6 15:37
主线:=EMA(EMA(C,1),5);
本:=EMA(HHV(主线,5),1);
急:=EMA(HHV(本,21),1);

@休闲者68 感谢老师帮忙!公式可用!谢谢!
休闲者68
Lv.6
发表于 2019-12-6 15:37 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-7 12:03 编辑

供参考

附件

回复.txt [预览]

314 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
许昌舍得
Lv.6
发表于 2019-12-6 15:37 复制 查看全部楼层
本帖最后由 福阿德 于 2019-12-7 12:02 编辑

供参考

附件

回复.txt [预览]

422 Bytes, 下载次数: 2, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+10理想币 +10共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表