手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把以下通达信的指标改成文华财经的

[其 他]
设置
17302 2 酱油妹纸 Lv.3 发表于 · 2019-12-8 14:08 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
1、

M:=14;
N:=9;
N1:=6;


100,POINTDOT;
-100,POINTDOT;
TYP := (HIGH + LOW + CLOSE)/3;
CC1:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),COLORWHITE;
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);

DRAWBAND(CC1,RGB(0,244,244),0,RGB(255,200,90));
DRAWBAND(100,0,-100,0);

100,POINTDOT;
-100,POINTDOT;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:(RSI1-50)*5,LINETHICK2,COLORWHITE;

DRAWBAND(RSI,RGB(255,244,244),0,RGB(255,255,255));
DRAWBAND(100,0,-100,0);

R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:(K-50)*5,COLOR00FF00;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);


CC2:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),COLORFF00FF;


2、

N:=60;
K值:="KDJ.K";   
DD:=C=LLV(C,N);{60日最低点}
DDSJ:=BARSLAST(REF(DD,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;{股价趋势}
KDZB:=REF(K值,DDSJ+1)<K值;{KDJ.K指标趋势}
K底背离:=DDGJ AND KDZB;
GD:=C=HHV(C,N);{60日最高点}
GDSJ:=BARSLAST(REF(GD,1));{上一高点时间}
GDGJ:=REF(CLOSE,GDSJ+1)<CLOSE;{股价趋势}
KGZB:=REF(K值,GDSJ+1)>K值;
K顶背离:=GDGJ AND KGZB;
MACD:="MACD.MACD";
MDZB:=REF(MACD,DDSJ+1)<MACD;{MACD指标趋势}
M底背离:=DDGJ AND MDZB;
MGZB:=REF(MACD,GDSJ+1)>MACD;
M顶背离:=GDGJ AND MGZB;
RSI:="RSI.RSI1";
RDZB:=REF(RSI,DDSJ+1)<RSI;{RSI指标趋势}
R底背离:=DDGJ AND RDZB;
RGZB:=REF(RSI,GDSJ+1)>RSI;
R顶背离:=GDGJ AND RGZB;
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
CDZB:=REF(CCI,DDSJ+1)<CCI;{CCI指标趋势}
C底背离:=DDGJ AND CDZB;
CGZB:=REF(CCI,GDSJ+1)>CCI;
C顶背离:=GDGJ AND CGZB;
REFLINE: -5,15,30,COLORBLACK;
DRAWTEXT(ISLASTBAR,29,'KDJ顶背离'),LINETHICK2,COLORRED;
DRAWTEXT(K顶背离,IF(ISLASTBAR,27.5,29),'(×)'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,26,'MACD顶背离'),LINETHICK2,COLORMAGENTA;
DRAWTEXT(M顶背离,(ISLASTBAR,24.5,26),'(×)'),LINETHICK2,COLORMAGENTA,;
DRAWTEXT(ISLASTBAR,22.1,'RSI顶背离'),LINETHICK2,COLORBLUE;
DRAWTEXT(R顶背离,(ISLASTBAR,20.5,22.1),'(×)'),LINETHICK2,COLORBLUE;
DRAWTEXT(ISLASTBAR,18.1,'CCI顶背离'),LINETHICK2,COLORGREEN;
DRAWTEXT(C顶背离,(ISLASTBAR,16.6,18.1),'(×)'),LINETHICK2,COLORGREEN,;
DRAWTEXT(ISLASTBAR,14.2,'CCI底背离'),LINETHICK2,COLORGREEN;
DRAWTEXT(C底背离,IF(ISLASTBAR,12,14.2),'(√)'),LINETHICK2,COLORGREEN;
DRAWTEXT(ISLASTBAR,10,'RSI底背离'),LINETHICK2,COLORBLUE;
DRAWTEXT(R底背离,IF(ISLASTBAR,8.5,10),'(√)'),LINETHICK2,COLORBLUE;
DRAWTEXT(ISLASTBAR,6,'MACD底背离'),LINETHICK2,COLORMAGENTA;
DRAWTEXT(M底背离,IF(ISLASTBAR,4.5,6),'(√)'),LINETHICK2,COLORMAGENTA;
DRAWTEXT(ISLASTBAR,3,'KDJ底背离'),LINETHICK2,COLORRED;
DRAWTEXT(K底背离,IF(ISLASTBAR,1.5,3),'(√)'),LINETHICK2,COLORRED;

酱油妹纸
Lv.3
发表于 2019-12-8 21:52 复制 查看全部楼层
没有人理我
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表