手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

自用的综合主图(指标,副图,通达信,贴图)源码

[通达信] 精华 1 340个推荐340
设置
175543 30 三不戒 Lv.5 发表于 · 2019-12-9 21:31 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
主图包含基本资料,股东人数,人均持股,自动划分黄金分割线,箱体的顶底,获利筹码。

附件

主图

主图

综合主图.tn6

11.89 KB, 下载次数: 647, 下载积分: 共享币 -10 个

主图

本主题由 任务系统 于 2020-1-13 15:30 解除限时高亮
刚来2012
Lv.4
发表于 2020-1-26 21:24 复制 查看全部楼层
通不过编译
财富之海
Lv.2
发表于 2020-1-23 09:42 复制 查看全部楼层
配合其他指标用还是有用的,也有可能是每个人的用法观念不一样。
财富之海
Lv.2
发表于 2020-1-23 09:39 复制 查看全部楼层
测试未通过,把黄金分割线去掉就可以了。V7.35通达信可以的。
杨春荣2012
Lv.4
发表于 2020-1-18 14:14 复制 查看全部楼层
编译未通过,问题我知道是什么原因了,通达信版本问题,把数字换成字就可以解决了
比如里面写的%61_8,要把618写成六一八就搞定了,我厉害吧,哈哈
春天的微风
Lv.2
发表于 2020-1-11 19:40 复制 查看全部楼层
感谢老师分享..........
残雪2008
Lv.3
发表于 2020-1-11 19:13 复制 查看全部楼层
感谢共享     天天快乐
无心名
Lv.2
发表于 2020-1-11 16:27 复制 查看全部楼层
翻译未通过是什么情况
小一鱼一儿
Lv.2
发表于 2020-1-11 12:40 复制 查看全部楼层
你的翻译通过了吗
杨春荣2012
Lv.4
发表于 2020-1-10 11:11 复制 查看全部楼层
是真的通不过编译,不是乱说的
查看全部打赏
  • 三不戒+2共享币 : 感谢交流,感恩分享,收获正能量。
杨春荣2012
Lv.4
发表于 2020-1-10 10:25 复制 查看全部楼层
这个公式通不过,浪费币了,亏大亏大
查看全部打赏
  • 三不戒+2共享币 : 唉,5个共享币就亏大了,给您。
牛牛网络
Lv.4
发表于 2020-1-10 09:17 复制 查看全部楼层
编译未通过,通达信高版公式语法问题。把点号换成其他的即可:
顶部:REFDATE(顶1,DATE),COLOR666666;
%19_8:REFDATE(H1,DATE),COLOR666666;
%38_2:REFDATE(H2,DATE),COLOR666666;
%50:REFDATE(H3,DATE),COLOR666666;
%61_8:REFDATE(H4,DATE),COLOR666666;
%80_9:REFDATE(H5,DATE),COLOR666666;
底部:REFDATE(底1,DATE),COLOR666666;
DRAWTEXT(ISLASTBAR,顶部,' 顶部'),COLORGREEN;
DRAWTEXT(ISLASTBAR,%19_8,' 19.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%38_2,' 38.2%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%50,' 50%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%61_8,' 61.8%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%80_9,' 80.9%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,底部,' 底部'),COLORRED;
节奏之律
Lv.2
发表于 2020-1-10 00:28 复制 查看全部楼层
https://www.55188.com/forum.php? ... 9&pid=155593179
谢谢,把源码黄金分割部分去掉果然编译通过了!原因可能是券商版本,也可能是这个指标本身有点问题,因为同样是这个版本使用过无数的指标,基本没出通不过。
炒股带娃呀
Lv.2
发表于 2020-1-9 23:53 复制 查看全部楼层
谢谢分享!
三不戒
Lv.5
发表于 2020-1-9 23:41 复制 查看全部楼层
赌输赢 发表于 2020-1-9 22:27
{基本资料}{综合主图}
品种类型:=FINANCE(3);
所属板块:=HYBLOCK;

,一样的汽车,不同人开,不一样的速度。您安好即可。
赌输赢
Lv.4
发表于 2020-1-9 22:38 复制 查看全部楼层
{BS标志}
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);
赌输赢
Lv.4
发表于 2020-1-9 22:37 复制 查看全部楼层
BS小图标也是未来函数ZIG造出来的!这公式简直就是废物,浪费同志们的共享币!!!

赌输赢
Lv.4
发表于 2020-1-9 22:27 复制 查看全部楼层
{基本资料}{综合主图}
品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
股总市值:=ROUND(FINANCE(41)/100000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
{}
DRAWTEXT_FIX(1,0.008,0.01,0,'基本资料:'),COLORFFCC99;
DRAWTEXT_FIX(1,0.008,0.05,0,'品种类型:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.09,0,'行业板块:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.13,0,'上市天数:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.17,0,'股东人数:'),COLOR99CCFF;
DRAWTEXT_FIX(1,0.008,0.21,0,'人均持股:'),COLOR99CCFF;
{}
DRAWTEXT_FIX(品种类型=1,0.055,0.05,0,'沪 深 A 股'),COLORYELLOW;
DRAWTEXT_FIX(品种类型=2,0.055,0.05,0,' 中 小 板'),COLORYELLOW;
DRAWTEXT_FIX(品种类型=3,0.055,0.05,0,' 创 业 板'),COLORYELLOW;
DRAWTEXT_FIX(1,0.055,0.09,0,HYBLOCK),COLORYELLOW;{行业板块}
{数值}
DRAWNUMBER_FIX(1,0.050,0.13,0,上市天数),COLORGREEN;
DRAWNUMBER_FIX(1,0.050,0.17,0,股东人数),COLORGREEN;
DRAWNUMBER_FIX(1,0.050,0.21,0,人均持股),COLORGREEN;
{单位}
DRAWTEXT_FIX(1,0.08,0.13,0,'天'),COLORWHITE;
DRAWTEXT_FIX(1,0.08,0.17,0,'人'),COLORWHITE;
DRAWTEXT_FIX(1,0.08,0.21,0,'股'),COLORWHITE;
{所属板块}
DRAWTEXT_FIX(1,0.008,0.25,0,'地区板块:')COLOR99CCFF;
DRAWTEXT_FIX(1,0.048,0.25,0,DYBLOCK)COLORGREEN;
DRAWTEXT_FIX(1,0.088,0.25,0,'概念板块:')COLOR99CCFF;
DRAWTEXT_FIX(1,0.128,0.25,0,GNBLOCK)COLORGREEN;
DRAWTEXT_FIX(1,0.008,0.29,0,'风格板块:')COLOR99CCFF;
DRAWTEXT_FIX(1,0.048,0.29,0,FGBLOCK)COLORGREEN;



获利筹码:IF(WINNER(CLOSE),WINNER(CLOSE)*100,0),NODRAW,COLOR0080FF;
净资产:FINANCE(34),NODRAW,COLORRED;
公积金:FINANCE(18),NODRAW,COLORGREEN;
未分利润:FINANCE(32),NODRAW,COLORMAGENTA;
净资收益率:=STRCAT('净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
每股收益:=STRCAT('     每股收益: ',CON2STR(FINANCE(38),2));
主营利润率:=STRCAT('    主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT(' ',STRCAT(STRCAT(净资收益率,每股收益),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.62,1.2,0,当前业绩),COLORRED;     {主图显示}
利润增长:FINANCE(43),COLORYELLOW,NODRAW;开幅:100*(O/REF(C,1)-1),COLORYELLOW,NODRAW;

箱顶:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),DOTLINE,COLORCYAN,LINETHICK1;
N3:=60;
B3:=EMA(C,3);
B4:=SMA(SMA(B3,2,1),2,1);
LLV(EMA(B4,1),N3),DOTLINE,COLORCYAN,LINETHICK1;



F:EMA(CLOSE,21),COLORRED,LINETHICK2;
IF(F>REF(F,1),F,DRAWNULL),LINETHICK2,COLORRED;
IF(F<REF(F,1),F,DRAWNULL),LINETHICK2,COLORGREEN;



网13:EXPMA(CLOSE,13),COLORGRAY,LINETHICK1;
{黄金分割线}
M:=13;
顶1:=REFDATE(HHV(H,M),DATE);
底1:=REFDATE(LLV(L,M),DATE);
H1:=顶1-(顶1-底1)*0.191;
H2:=顶1-(顶1-底1)*0.382;
H3:=顶1-(顶1-底1)*0.5;
H4:=顶1-(顶1-底1)*0.618;
H5:=顶1-(顶1-底1)*0.809;
顶部:REFDATE(顶1,DATE),COLOR666666;
{%19.8:REFDATE(H1,DATE),COLOR666666;
%38.2:REFDATE(H2,DATE),COLOR666666;
%50:REFDATE(H3,DATE),COLOR666666;
%61.8:REFDATE(H4,DATE),COLOR666666;
%80.9:REFDATE(H5,DATE),COLOR666666;
底部:REFDATE(底1,DATE),COLOR666666;}
DRAWTEXT(ISLASTBAR,顶部,' 顶部'),COLORGREEN;
{DRAWTEXT(ISLASTBAR,%19.8,' 19.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%38.2,' 38.2%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%50,' 50%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%61.8,' 61.8%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%80.9,' 80.9%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,底部,' 底部'),COLORRED;}
{BS标志}
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);
{箱体}
{
箱顶:PEAK(CLOSE,N,1)*0.98,POINTDOT,LINETHICK3,COLORYELLOW;
箱底:TROUGH(CLOSE,N,1)*1.02,POINTDOT,LINETHICK3,COLORFFFF00;
箱高:100*(箱顶-箱底)/箱底,NODRAW;
};

总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);MA5:=MA(C,5);MA10:=MA(C,10);MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5))
AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND
MA10>REF(MA10,1);

{过左峰提示粉色}
VAR121:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR141:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR161:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR181:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
卖:=(VAR121+VAR141+VAR161+VAR181),LINETHICK2;SQ:DRAWLINE(卖,H,BARSLAST(卖)>=1,REF(H,BARSLAST(卖)),1),COLORWHITE,LINETHICK2;
过峰:=C>SQ AND REF(C,1)<SQ;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
预量:=VVOL/REF(V,1)>1.8;
现量:=V/REF(V,1)>1.5;
过峰1:STICKLINE( 过峰,C,O,5,0)COLORFF00FF;
预量1:DRAWICON(过峰 AND 预量, H*1.01,14);
现量1:DRAWICON(过峰 AND 现量,(O+C)/2,23);
前次低点:LLV(L*1,250)POINTDOT,COLORFF00FF,LINETHICK4;

ZIG未来函数一大片谁敢用呀?是谁给推荐的精华?afly!
刚来2012
Lv.4
发表于 2020-1-9 21:22 复制 查看全部楼层
总算开放回复。
小散乙
Lv.2
发表于 2020-1-9 14:18 复制 查看全部楼层
编辑未通过楼主麻烦看一下谢谢!
三不戒
Lv.5
发表于 2020-1-9 10:52 复制 查看全部楼层
本帖最后由 三不戒 于 2020-1-9 10:54 编辑

看到好些朋友说编辑未通过,应该都是券商自带软件版本惹得祸,如果通不过可以通过软件的编辑指标,把源码中关于黄金分割的部分删除,就能通过了。这里提供源码文本。

附件

自用.txt [预览]

5.76 KB, 下载次数: 19, 下载积分: 共享币 -10 个

放飞哥
Lv.2
发表于 2020-1-9 08:56 复制 查看全部楼层
编辑未通过楼主麻烦看一下谢谢!
天才老鸟
Lv.2
发表于 2020-1-9 01:53 复制 查看全部楼层
谢谢分享,xia za ishi shi
节奏之律
Lv.2
发表于 2020-1-8 23:42 复制 查看全部楼层
电脑显示“公式综合主图编译未通过”,哪位高手点拨一下?
节奏之律
Lv.2
发表于 2020-1-8 23:39 复制 查看全部楼层
我的也是编译未通过,为什么有的能通过有的不能,我用的中信证券至信全能版,电脑是win10.其他的指标基本都行啊,为什么这个不行?
楚凡兄
Lv.2
发表于 2019-12-10 09:07 复制 查看全部楼层
11111111111111111
气垫
Lv.6
发表于 2019-12-10 08:55 复制 查看全部楼层
感谢共享     天天快乐
气垫
Lv.6
发表于 2019-12-10 08:53 复制 查看全部楼层
感谢共享     天天快乐
松山食堂
Lv.4
发表于 2019-12-10 08:32 复制 查看全部楼层
主图定义重复没通过
阳光雨露88
Lv.4
发表于 2019-12-10 08:15 复制 查看全部楼层
研究课题似的
聊一聊
Lv.5
发表于 2019-12-10 07:58 复制 查看全部楼层
感谢老师分享..........
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表