手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改一下:更新后,指标不能显示了

[通达信]
设置
1911 9 涨水之鱼 Lv.3 发表于 · 2020-1-13 14:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
高:=REF(HHV(H,200),3);
低:=REF(LLV(L,200),3);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),COLORWHITE DOTLINE;
%19.8:REFDATE(H19,DATE),COLORYELLOW DOTLINE;
%38.2:REFDATE(H38,DATE),COLORMAGENTA DOTLINE;
%50:REFDATE(H中,DATE),COLORRED;
%61.8:REFDATE(H61,DATE),COLORMAGENTA DOTLINE;
%80.9:REFDATE(H80,DATE),COLORYELLOW DOTLINE;
低点:REFDATE(低,DATE),COLORWHITE DOTLINE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%19.8,'%19.8安全'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,%38.2,'%38.2'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'%61.8'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;


H1:MA(C,60)COLORGREEN,LINETHICK2;
H2:MA(C,120)COLORRED,LINETHICK2;


涨停:=(C/REF(C,1)-1)*100>=9.5;
ST涨停:=C=H AND (C/REF(C,1)-1)*100>=4.5 AND COUNT(ABS((C/REF(C,1)-1)*100)<=5.2,20)=20;
STICKLINE(涨停 OR ST涨停,C,O,2,0),COLOR00FFFF;
STICKLINE(涨停 OR ST涨停,L,H,0,0),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=70,顶点,CON2STR(顶点,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=70,%19.8,CON2STR(%19.8,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=70,%38.2,CON2STR(%38.2,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=70,%50,CON2STR(%50,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=70,%61.8,CON2STR(%61.8,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=70,%80.9,CON2STR(%80.9,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=70,低点,CON2STR(低点,2)),COLORWHITE;


IF(CURRBARSCOUNT<=60,CONST(O),DRAWNULL),COLORGREEN,LINETHICK;
IF(CURRBARSCOUNT<=100,CONST(REF(C,1)*1.1),DRAWNULL),COLORGREEN,LINETHICK1;
IF(CURRBARSCOUNT<=100,CONST(REF(C,1)*1.2),DRAWNULL),COLORGREEN,LINETHICK1;
IF(CURRBARSCOUNT<=100,CONST(REF(C,1)*1.3),DRAWNULL),COLORGREEN,LINETHICK1;

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;



当前公式 : WW (画线指标公式)  
错误句 :
%19.8:REFDATE(H19,DATE),COLORYELLOW DOTLINE
详细信息 : 在变量 8 前又错误的定义一次变量!
错误起始位置 : 218 ; 长度: 1


请老师帮助改一下!
涨水之鱼
Lv.3
发表于 2020-1-16 14:50 复制 查看全部楼层
网络漫步1 发表于 2020-1-13 16:09
高:=REF(HHV(H,200),3);
低:=REF(LLV(L,200),3);
H19:=高-(高-低)*0.191;


2引用.突破3#DAY,COLORGREEN,LINETHICK2;
2引用.突破4#DAY,COLORGREEN,LINETHICK2;
2引用.突破5#DAY,COLORGREEN,LINETHICK2;

均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;

高:=DYNAINFO(3)*1.1;
低:=DYNAINFO(3);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=DRAWNUMBER(高-(高-低)*0.5,LOW,C);
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),COLORWHITE DOTLINE;
%19.8:REFDATE(H19,DATE),COLORYELLOW DOTLINE;
%38.2:REFDATE(H38,DATE),COLORMAGENTA DOTLINE;
%50:REFDATE(H中,DATE),COLORGREEN  DOTLINE;
%61.8:REFDATE(H61,DATE),COLORMAGENTA DOTLINE;
%80.9:REFDATE(H80,DATE),COLORYELLOW DOTLINE;
低点:REFDATE(低,DATE),COLORWHITE DOTLINE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%19.8,'.'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,%38.2,'.'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%50,'.'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'.'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%80.9,'.'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'.'),COLORWHITE;


DRAWTEXT(CURRBARSCOUNT=70,顶点,CON2STR(顶点,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,%19.8,CON2STR(%19.8,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,%38.2,CON2STR(%38.2,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,%50,CON2STR(%50,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,%61.8,CON2STR(%61.8,2)),COLORMAGENTA;DRAWTEXT(CURRBARSCOUNT=2,%80.9,CON2STR(%80.9,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,低点,CON2STR(低点,2)),COLORWHITE;


H1:EMA(C,60)COLORRED,LINETHICK1;
H2:EMA(C,120)COLORGREEN,LINETHICK1;
涨停:=(C/REF(C,1)-1)*100>=9.5;
ST涨停:=C=H AND (C/REF(C,1)-1)*100>=4.5 AND COUNT(ABS((C/REF(C,1)-1)*100)<=5.2,20)=20;
STICKLINE(涨停 OR ST涨停,C,O,2,0),COLOR00FFFF;
STICKLINE(涨停 OR ST涨停,L,H,0,0),COLOR00FFFF;

BB:DYNAINFO(3)/1.0242792 ,COLORYELLOW DOTLINE;
CC:DYNAINFO(3)/1.0400616 ,COLORMAGENTA DOTLINE;
DD:DYNAINFO(3)/1.0530421 ,COLORGREEN  DOTLINE;
EE:DYNAINFO(3)/1.0655090 ,COLORMAGENTA DOTLINE;
GG:DYNAINFO(3)/1.0878323 ,COLORYELLOW DOTLINE;
YY:DYNAINFO(3)/1.1111111 ,DOTLINE;

DRAWTEXT(CURRBARSCOUNT=1,BB,CON2STR(BB,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,CC,CON2STR(CC,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,DD,CON2STR(DD,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,EE,CON2STR(EE,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,GG,CON2STR(GG,2)),COLORMAGENTA;DRAWTEXT(CURRBARSCOUNT=2,%80.9,CON2STR(%80.9,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,YY,CON2STR(YY,2)),COLORWHITE;



请老师改一下指标,你改的上一个可以能过,软件升级造成的!!
涨水之鱼
Lv.3
发表于 2020-1-16 13:39 复制 查看全部楼层
网络漫步1 发表于 2020-1-13 16:09
高:=REF(HHV(H,200),3);
低:=REF(LLV(L,200),3);
H19:=高-(高-低)*0.191;

2引用.突破3#DAY,COLORGREEN,LINETHICK2;




高:=DYNAINFO(3)*1.1;
低:=DYNAINFO(3);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=DRAWNUMBER(高-(高-低)*0.5,LOW,C);
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),COLORWHITE DOTLINE;
%19.8:REFDATE(H19,DATE),COLORYELLOW DOTLINE;
%38.2:REFDATE(H38,DATE),COLORMAGENTA DOTLINE;
%50:REFDATE(H中,DATE),COLORGREEN  DOTLINE;
%61.8:REFDATE(H61,DATE),COLORMAGENTA DOTLINE;
%80.9:REFDATE(H80,DATE),COLORYELLOW DOTLINE;
低点:REFDATE(低,DATE),COLORWHITE DOTLINE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%19.8,'111111'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,%38.2,'%38.2'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'%61.8'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;


H1:EMA(C,60)COLORRED,LINETHICK1;
H2:EMA(C,120)COLORGREEN,LINETHICK1;
涨停:=(C/REF(C,1)-1)*100>=9.5;
ST涨停:=C=H AND (C/REF(C,1)-1)*100>=4.5 AND COUNT(ABS((C/REF(C,1)-1)*100)<=5.2,20)=20;
STICKLINE(涨停 OR ST涨停,C,O,2,0),COLOR00FFFF;
STICKLINE(涨停 OR ST涨停,L,H,0,0),COLOR00FFFF;

BB:DYNAINFO(3)/1.0242792 ,COLORYELLOW DOTLINE;
CC:DYNAINFO(3)/1.0400616 ,COLORMAGENTA DOTLINE;
DD:DYNAINFO(3)/1.0530421 ,COLORGREEN  DOTLINE;
EE:DYNAINFO(3)/1.0655090 ,COLORMAGENTA DOTLINE;
GG:DYNAINFO(3)/1.0878323 ,COLORYELLOW DOTLINE;
YY:DYNAINFO(3)/1.1111111 ,DOTLINE;


均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;


请老师帮忙改一下这个!!谢谢
网络漫步1
Lv.5
发表于 2020-1-13 16:09 复制 查看全部楼层
涨水之鱼 发表于 2020-1-13 16:01
中信证券,刚刚升级软件,就能点击公式了

高:=REF(HHV(H,200),3);
低:=REF(LLV(L,200),3);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),COLORWHITE DOTLINE;
B19。8:REFDATE(H19,DATE),COLORYELLOW DOTLINE;
B38。2:REFDATE(H38,DATE),COLORMAGENTA DOTLINE;
B50:REFDATE(H中,DATE),COLORRED;
B61。8:REFDATE(H61,DATE),COLORMAGENTA DOTLINE;
B80。9:REFDATE(H80,DATE),COLORYELLOW DOTLINE;
低点:REFDATE(低,DATE),COLORWHITE DOTLINE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,B19。8,'%19。8安全'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,B38。2,'%38.2'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,B50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,B61。8,'%61.8'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,B80。9,'%80.9'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;


H1:MA(C,60)COLORGREEN,LINETHICK2;
H2:MA(C,120)COLORRED,LINETHICK2;


涨停:=(C/REF(C,1)-1)*100>=9.5;
ST涨停:=C=H AND (C/REF(C,1)-1)*100>=4.5 AND COUNT(ABS((C/REF(C,1)-1)*100)<=5.2,20)=20;
STICKLINE(涨停 OR ST涨停,C,O,2,0),COLOR00FFFF;
STICKLINE(涨停 OR ST涨停,L,H,0,0),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=70,顶点,CON2STR(顶点,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=70,B19。8,CON2STR(B19。8,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=70,B38。2,CON2STR(B38。2,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=70,B50,CON2STR(B50,2)),COLORRED;
DRAWTEXT(CURRBARSCOUNT=70,B61。8,CON2STR(B61。8,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=70,B80。9,CON2STR(B80。9,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=70,低点,CON2STR(低点,2)),COLORWHITE;


IF(CURRBARSCOUNT<=60,CONST(O),DRAWNULL),COLORGREEN,LINETHICK;
IF(CURRBARSCOUNT<=100,CONST(REF(C,1)*1.1),DRAWNULL),COLORGREEN,LINETHICK1;
IF(CURRBARSCOUNT<=100,CONST(REF(C,1)*1.2),DRAWNULL),COLORGREEN,LINETHICK1;
IF(CURRBARSCOUNT<=100,CONST(REF(C,1)*1.3),DRAWNULL),COLORGREEN,LINETHICK1;

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;
查看全部打赏
  • 涨水之鱼+4理想币 +2共享币 : 赠人玫瑰,手有余香。
涨水之鱼
Lv.3
发表于 2020-1-13 16:01 复制 查看全部楼层
中信证券,刚刚升级软件,就能点击公式了
涨水之鱼
Lv.3
发表于 2020-1-13 15:51 复制 查看全部楼层
112.png
许昌舍得
Lv.6
发表于 2020-1-13 15:46 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-1-13 15:48 编辑

问题类型截图

附件

tdxjietu1.JPG
涨水之鱼
Lv.3
发表于 2020-1-13 15:44 复制 查看全部楼层
许昌舍得 发表于 2020-1-13 15:16
高:=REF(HHV(H,200),3);
低:=REF(LLV(L,200),3);
H19:=高-(高-低)*0.191;

直接复制过去,还是显示错误呢,没有变化,是什么情况?
晴彦
Lv.6
发表于 2020-1-13 15:27 复制 查看全部楼层
谢谢楼主的辛勤劳动
许昌舍得
Lv.6
发表于 2020-1-13 15:16 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-13 16:05 编辑

供参考

附件

回复.txt [预览]

2 KB, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表