手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个箭头的选股公式

[通达信]
设置
2122 6 学网科技 Lv.4 发表于 · 2020-1-14 06:16 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
个股基数:=自适应参数.GGS1#DAY;
个股基数2:=自适应参数.GGB1#DAY;
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV,14,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
K1:=EMA(RSV,14);
D1:=EMA(D,5);
J1:=3*K1-2*D1;
JJX:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
H1:=C>REF(C,1) AND C/JJX>1.06;
L1:=C<REF(C,1) AND C/JJX<0.94;
DRAWICON(CROSS(个股基数2,K1) AND EVERY(K1<D1,5) AND D1<REF(D1,1) OR FILTER(L1,400) {OR (REF(D1,1)=0 AND REF(K1,1)=0 AND REF(J1,1)=0 AND J1>K1)},C*0.995,1);
DRAWICON(CROSS(K1,个股基数) AND EVERY(K1>D1,5) AND D1>REF(D1,1)  OR FILTER(H1,400),C*1.005,2);
学网科技
Lv.4
发表于 2020-1-14 09:12 复制 查看全部楼层
网络漫步1 发表于 2020-1-14 08:53
适应参数.GGB1   是被引用公式。只有你电脑里才有

DPBJS:=4.8;
DPSJS:=96.2;
DPS1:IF(REF(C,1)/REF(C,2)>1.02 OR REF(C,1)/REF(C,2)<0.99,DPSJS-3.2,DPSJS);
DPB1:IF(REF(C,1)/REF(C,2)>1.02 OR REF(C,1)/REF(C,2)<0.99,DPBJS+3.2,DPBJS);
GGBJS:=6.6;
GGSJS:=95;
GGS1:IF(REF(C,1)/REF(C,2)>1.04 OR REF(C,1)/REF(C,2)<0.97,GGSJS-3.2,GGSJS);
GGB1:IF(REF(C,1)/REF(C,2)>1.04 OR REF(C,1)/REF(C,2)<0.97,GGBJS+3.2,GGBJS);

找到了,
网络漫步1
Lv.5
发表于 2020-1-14 08:53 复制 查看全部楼层
学网科技 发表于 2020-1-14 08:51
我也不知道啊,我代码就只有这些,主图就会出红色箭头的

适应参数.GGB1   是被引用公式。只有你电脑里才有
学网科技
Lv.4
发表于 2020-1-14 08:51 复制 查看全部楼层
网络漫步1 发表于 2020-1-14 08:40
适应参数.GGB1   是什么只有你自个知道

我也不知道啊,我代码就只有这些,主图就会出红色箭头的
网络漫步1
Lv.5
发表于 2020-1-14 08:40 复制 查看全部楼层
学网科技 发表于 2020-1-14 08:36
当前公式 : 测试 (条件选股公式)  
错误句 : 个股基数2:=适应参数.GGB1#DAY
详细信息 : 某个操作数没 ...

适应参数.GGB1   是什么只有你自个知道
学网科技
Lv.4
发表于 2020-1-14 08:36 复制 查看全部楼层
休闲者68 发表于 2020-1-14 08:09
个股基数2:=适应参数.GGB1#DAY;
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV, ...

当前公式 : 测试 (条件选股公式)  
错误句 : 个股基数2:=适应参数.GGB1#DAY
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 0 ; 长度: 0

老师麻烦再看看
休闲者68
Lv.6
发表于 2020-1-14 08:09 复制 查看全部楼层
个股基数2:=适应参数.GGB1#DAY;
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV,14,1);
D:=SMA(K,5,1);
K1:=EMA(RSV,14);
D1:=EMA(D,5);
J1:=3*K1-2*D1;
JJX:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
L1:=C<REF(C,1) AND C/JJX<0.94;
红箭头:CROSS(个股基数2,K1) AND EVERY(K1<D1,10) AND D1<REF(D1,1) OR FILTER(L1,400);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表