手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写通达信的选股公式

[通达信]
设置
2063 1 万潮12 Lv.2 发表于 · 2020-1-14 08:06 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{筹码线捉妖股}
M1:MA(MA(L,3),3),COLORWHITE;
M2:HHV(M1,60),COLORWHITE;
M3:SQRT(M1*M2),COLORWHITE;
M4:SQRT(M1*M3),COLORWHITE;
M5:SQRT(M2*M3),COLORWHITE;
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>5,O,C,2,0),COLORLIRED;
STICKLINE(ZDT<-9.8,O,C,2,0),COLOR00FF00;
涨停:=ZDT>5;
不破价:=REF(L,BARSLAST(涨停));
SJ1:=(REF(HIGH,3) = HHV(HIGH,((2 * 3) + 1)));
SJ2:=FILTER(SJ1,3);
SJ3:=BACKSET(SJ2,(3 + 1));
SJ4:=FILTER(SJ3,3);
SJ5:=(REF(LOW,3) = LLV(LOW,((2 * 3) + 1)));
SJ6:=FILTER(SJ5,3);
SJ7:=BACKSET(SJ6,(3 + 1));
SJ8:=FILTER(SJ7,3);
SJ9:=((REF(LLV(LOW,(2 * 3)),1) + REF(HHV(HIGH,(2 * 3)),1)) / 2);
SJ10:=((HIGH + LOW) / 2);
SJ11:=(((SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10)))) OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ12:=(SJ8 AND NOT((SJ4 AND (SJ9 < SJ10))));
SJ13:=(SJ4 AND NOT((SJ8 AND (SJ9 >= SJ10))));
SJ14:=(REF(BARSLAST(SJ11),1) + 1);
SJ15:=BACKSET((SJ11 AND (COUNT(SJ12,SJ14) > 0)),LLVBARS(IF(SJ12,LOW,10000),SJ14));
SJ16:=(SJ15 > REF(SJ15,1));
SJ17:=BACKSET(SJ16,2);
SJ18:=(SJ17 > REF(SJ17,1));
SJ19:=((SJ18 OR BARSTATUS) OR (BARSCOUNT(CLOSE) = 1));
SJ20:=(REF(BARSLAST(SJ19),1) + 1);
SJ21:=BACKSET((SJ19 AND (COUNT(SJ13,SJ20) > 0)),HHVBARS(IF(SJ13,HIGH,0),SJ20));
SJ22:=(SJ21 > REF(SJ21,1));
SJ23:=BACKSET(SJ22,2);
SJ24:=(SJ23 > REF(SJ23,1));
SJ25:=BACKSET(BARSTATUS,(BARSLAST(SJ18) + 1));
SJ26:=(SJ25 > REF(SJ25,1));
SJ27:=BACKSET(BARSTATUS,(BARSLAST(SJ24) + 1));
SJ28:=(SJ27 > REF(SJ27,1));
{以下为三角形部分}
底:REF(LOW,BARSLAST(SJ26)),COLORMAGENTA;
顶:REF(HIGH,BARSLAST(SJ28)),COLORMAGENTA;
中:IF(CURRBARSCOUNT<=CONST(顶)+1 AND ABS((顶+底)/2-CLOSE)/CLOSE*100<20,(顶+底)/2,DRAWNULL),COLORMAGENTA;
{下跌三角形:绿色三角形画完介入}
STICKLINE(SJ26, 顶,底,0,0),COLORGREEN,LINETHICK2;
DRAWLINE(SJ28,HIGH,SJ26,LOW,0),COLORGREEN,LINETHICK2;{斜}
DRAWLINE(SJ28,HIGH,SJ26, 顶,0),COLORGREEN,LINETHICK2;
{上涨三角形:红色三角形画完出局}
STICKLINE(SJ28, 顶,底,0,0),COLORMAGENTA,LINETHICK2;
DRAWLINE(SJ26,LOW,SJ28,HIGH,0),COLORMAGENTA,LINETHICK2;{斜}
DRAWLINE(SJ26,LOW,SJ28,底,0),COLORMAGENTA,LINETHICK2;


这是主图的公式,此公式也来源于理想论坛,用后觉得甚好,特在此请热心的大神老师编写一个基于此主图的选股公式,选股思路要求选出主图内三角区域已经形成上升形态筹码线的个股,谢谢大神老师,具体示意如下图所示,一个是迈得医疗当前的主图显示,一个是弘宇股份当前的主图显示:

附件

微信图片_20200114075427.png
微信图片_20200114075443.png
休闲者68
Lv.6
发表于 2020-1-14 08:25 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-14 19:57 编辑

{指标发现未来函数BACKSET慎用!}

附件

回复.txt [预览]

1.18 KB, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
  • 万潮12+5理想币 +2共享币 : 刚试了一下,选出的比较多,很难精挑细选了,但还是谢谢你的热心付出。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表