手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助改个选股公式

[通达信]
设置
2178 3 拾豆豆 Lv.2 发表于 · 2020-1-14 17:38 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
AA:=H/REF(C,1)>=1.05;
BB:=H>HHV(REF(H,1),30);
CC:=H>MAX(O,C)*1.02;
XH:AA&&BB&&CC;

“XH”这个信号会出现多次
求改成:
1:收盘价大于最近一次“XH”信号出现时的最高价
2:开盘时跳空高开在最近一次“XH”信号出现时的最高价上方

共改两个指标,万分感谢。

如603031安德利
2020年1月9号这天是最近一次出现“XH”信号,1月14号两个指标都可以选出它。

相关股票

彪哥传说
Lv.2
发表于 2020-1-14 22:53 复制 查看全部楼层
就发货的时间吧   绝对是VB驹 吧驹
拾豆豆
Lv.2
发表于 2020-1-14 20:05 复制 查看全部楼层
休闲者68 发表于 2020-1-14 18:20
AA:=H/REF(C,1)>=1.05;
BB:=H>HHV(REF(H,1),30);
CC:=H>MAX(O,C)*1.02;

老师,谢谢您的回复。我发现这样出来的信号比较多,麻烦您再修改一下
跳空再加一个条件,即:在出现信号直到现在,收盘价都没有站上过出信号那天的最高价
比如说600030中信证券,19年12月17是最近一次出现“XH”信号,12月30号上穿了该信号的最高价,之后的价格全都在12月17的最高价上方了,那么之后的开盘价就不应该属于跳空
希望能像603031安德利一样,1月9号出信号,之后10号、13号的收盘价都没有站上9号的最高价,那么今天这个跳空才算。
休闲者68
Lv.6
发表于 2020-1-14 18:20 复制 查看全部楼层
AA:=H/REF(C,1)>=1.05;
BB:=H>HHV(REF(H,1),30);
CC:=H>MAX(O,C)*1.02;
XH:=AA&&BB&&CC;
T:=BARSLAST(XH);
SC:CROSS(C,REF(H,T));




AA:=H/REF(C,1)>=1.05;
BB:=H>HHV(REF(H,1),30);
CC:=H>MAX(O,C)*1.02;
XH:=AA&&BB&&CC;
T:=BARSLAST(XH);
TK:O>REF(H,T);
查看全部打赏
  • 拾豆豆+2理想币 +2共享币 : 很给力,理想因你而精彩;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表