手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙改成选股,谢谢

[通达信]
设置
1742 2 股气股气 Lv.5 发表于 · 2020-1-14 21:48 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

请老师帮忙,把下面公式改成选股,谢谢


UR:2    200    13

LR:2    200     13

VAR0:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20);
VAR1:=(2 * ABS(VAR0));
VAR2:=(100 - ((100 - (3 * SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1))));
VAR3:=(100 - ((100 - (3 * SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1))));
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR5:=((VAR4 - MA(VAR4,10)) / (0.015 * AVEDEV(VAR4,10)));
VAR6:=((VAR4 - MA(VAR4,30)) / (0.015 * AVEDEV(VAR4,30)));
VAR7:=IF(((((VAR5 >= 150) AND (VAR5 < 200)) AND (VAR6 >= 150)) AND (VAR6 < 200)),10,0);
VAR8:=IF(((((VAR5 <= (0 - 150)) AND (VAR5 > (0 - 200))) AND (VAR6 <= (0 - 150))) AND (VAR6 > (0 - 200))),(0 - 10),VAR7);
VAR9:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100);
VARA:=(100 - ABS(VAR9));
VARB:=((3 * SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1)));
VARC:=((3 * SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1)));
VARD:=(REF(LOW,1) * 0.9);
VARE:=(LOW * 0.9);
VARF:=(((VARE * VOL) + (VARD * (CAPITAL - VOL))) / CAPITAL);
VAR10:=EMA(VARF,30);
VAR11:=(VAR10 - CLOSE);
VAR12:=REF(CLOSE,1);
VAR13:=((SMA(MAX((CLOSE - VAR12),0),7,1) / SMA(ABS((CLOSE - VAR12)),7,1)) * 100);
VAR14:=((SMA(MAX((CLOSE - VAR12),0),13,1) / SMA(ABS((CLOSE - VAR12)),13,1)) * 100);
VAR15:=BARSCOUNT(CLOSE);
VAR16:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 100);
VAR17:=(((((0 - 100) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 50) * 2);
VAR18:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
VAR19:=((SMA(VAR18,4,1) - 50) * 2);
VAR1A:=SMA(VAR19,3,1);
VAR1B:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
VAR1C:=SMA(VAR1B,4,1);
VAR1D:=SMA(VAR1C,3,1);
VAR1E:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
VAR1F:=IF((((((((((VAR16 <= 25) AND (VAR17 < (0 - 95))) AND (VAR1E > 20)) AND (VAR1A < (0 - 30))) AND (VAR1D < 30)) AND (VAR11 >= (0 - 0.25))) AND (VAR13 < 22)) AND (VAR14 < 28)) AND (VAR15 > 50)),80,0);
VAR20:=IF((VARA < 90),VARA,100);
顶线:=IF((VAR0> 0),VAR0,0);
多方:=(0 - IF((VAR0 < 0),VAR1,0));
反弹:=VAR1F;
空方:=(IF((((VAR6 >= 200) AND (VAR5 >= 150)) OR CROSS(65,顶线)),15,IF(((VAR6 <= (0 - 200)) AND (VAR5 <= (0 - 150))),(0 - 15),VAR8)) + 65);
压力线:=((CLOSE > MA(CLOSE,20)) AND (MA(CLOSE,20) >= REF(MA(CLOSE,20),1)));
T1:=((CLOSE < MA(CLOSE,20)) AND (MA(CLOSE,20) < REF(MA(CLOSE,20),1)));
T2:=(((顶线 > 60) AND (空方 > 65)) AND (VAR20 = 100));
T3:=(((顶线 > 48) AND (空方 > 65)) AND (VAR20 < 100));
T4:=((多方 < (0 - 38)) AND (空方 < 65));
T5:=((反弹 > 50) AND (VAR20 < 90));
T6:=(((VAR2 > REF(VAR3,1)) AND (VOL > REF(VOL,1))) AND (CLOSE > REF(CLOSE,1)));
T7:=((((((VAR2 <= REF(VAR3,1)) AND (CLOSE < REF(CLOSE,1))) AND (空方 = 65)) AND (反弹 = 0)) AND (多方 >= REF(多方,1))) AND (VARB < REF(VARC,1)));
T8:=(AMOUNT / (100 * VOL));
VARAAA:=MA(T8,13);
CYC13:=MA(T8,34);
CYC34:=DMA(CLOSE,(VOL / CAPITAL));
CYCMAX:=(((CLOSE - VARAAA) / VARAAA) * 100);
CYS13:=(((CLOSE - CYC13) / CYC13) * 100);
CYS34:=(((CLOSE - CYC34) / CYC34) * 100);
超跌:=IF((CYCMAX <= (0 - 20)),42,0);
CYSMAX:=REF(CLOSE,1);
VA1:=((SMA(MAX((CLOSE - CYSMAX),0),7,1) / SMA(ABS((CLOSE - CYSMAX)),7,1)) * 100);
VA2:=((SMA(MAX((CLOSE - CYSMAX),0),13,1) / SMA(ABS((CLOSE - CYSMAX)),13,1)) * 100);
VA3:=BARSCOUNT(CLOSE);
VA4:=(((VA1 < 20) AND (VA2 < 25)) AND (VA3 > 50));
出宝剑红块买进:(VA4 * 60),LINETHICK4,COLOR10FFFF;
VAZ4:=(CLOSE-LLV(CLOSE,90))/(HHV(CLOSE,90)-LLV(CLOSE,90))*100;
VAZ24:=VAZ4=0;
STICKLINE(VAZ24>0,-3,-9,1,2),COLORRED,LINETHICK3 ;
VAZ25:=VAZ4=100;
STICKLINE(VAZ25>0,101,105,1,2),COLORGREEN,LINETHICK2;
DRAWTEXT_FIX(C>O,0.01,0.9,0,'订阅号:翔博软件工作室'),COLOR556699;
本主题由 任务系统 于 2020-1-14 21:48 审核通过
股气股气
Lv.5
发表于 2020-1-15 13:23 复制 查看全部楼层
休闲者68 发表于 2020-1-14 21:56
CYSMAX:=REF(CLOSE,1);
VA1:=((SMA(MAX((CLOSE-CYSMAX),0),7,1)/SMA(ABS((CLOSE-CYSMAX)),7,1))*100);
VA ...

谢谢老师的出手相助,非常感谢,祝您投资顺利
休闲者68
Lv.6
发表于 2020-1-14 21:56 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-15 17:10 编辑

供参考

附件

回复.txt [预览]

536 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表