手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助把这个通达信的公式改成飞狐

[飞 狐]
设置
1533 1 五行鼠 Lv.3 发表于 · 2020-1-14 23:49 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
{涨跌超前预知}


0,COLORGRAY;
DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
KDIF12:=3*(DIF12-DEA12);
KDEA12:=SMA(KDIF12,5,2);

微分DIF:=KDIF12*5,COLORWHITE,LINETHICK1;
微分DEA:=KDEA12*5,COLORYELLOW,LINETHICK1;
MACD2:2*(微分DIF-微分DEA),COLORBLACK;
MAMACD:=MA(MACD2,3),,COLORBLACK;

STICKLINE(MACD2>REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORRED;
STICKLINE(MACD2<=REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORYELLOW;
STICKLINE(MACD2<REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORCYAN;
STICKLINE(MACD2>=REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORMAGENTA;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD2 ,3, 0),COLORBLUE;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD2 , 3, 0),COLORLIRED;

微分DIF2:KDIF12*5,COLORRED,LINETHICK1;
微分DEA2:KDEA12*5,COLORMAGENTA,LINETHICK1;
NOTEXT强:IF(微分DIF2<MA(微分DIF2,2),微分DIF2,DRAWNULL),COLORGREEN;
NOTEXT弱:IF(微分DEA2<MAX(微分DEA2,REF(微分DEA2,1)),微分DEA2,DRAWNULL),COLORYELLOW;

N1:=6; N2:=12; N3:=24;

YLC:=周月RSI引用.LC#MONTH;
YY11:=周月RSI引用.YN11#MONTH;
YY12:=周月RSI引用.YN12#MONTH;

ZLC:=周月RSI引用.LC#WEEK;
ZY11:=周月RSI引用.YN11#WEEK;
ZY12:=周月RSI引用.YN12#WEEK;

YRSI1:=((MAX(C-YLC,0)+YY11*(N1-1))/N1)/((ABS(C-YLC)+YY12*(N1-1))/N1)*100;
ZRSI1:=((MAX(C-ZLC,0)+YY11*(N1-1))/N1)/((ABS(C-ZLC)+ZY12*(N1-1))/N1)*100;

月RI1:=YRSI1,COLORWHITE;
周RI1:=ZRSI1,COLORWHITE;

零:0,COLORBROWN,DOTLINE;
N:=50;
沧海行周J:="KDJ.J#WEEK" ,COLORGREEN,LINETHICK2;
沧海行周D:="KDJ.D#WEEK" ,COLOR33AAAA,LINETHICK1;
沧海行周MA:=50*"MACD.MACD#WEEK" ,COLORLIGREEN,DOTLINE;

零点:=(CONST(LLV(沧海行周MA,90))+CONST(HHV(沧海行周MA,90)))/2;
DI:=月RI1;
F分:=CONST(LLV(DI,90));
F百:=CONST(HHV(DI,90))-F分;
点:=CONST(LLV(沧海行周MA,90));
基:=CONST(HHV(沧海行周MA,90))-点;
F比:=(DI-F分)/F百;
XFX:=F比*基+点;

周零点:=(CONST(LLV(沧海行周MA,90))+CONST(HHV(沧海行周MA,90)))/2;
周DI:=周RI1;{月RSI1叠加}
周F分:=CONST(LLV(周DI,90));
周F百:=CONST(HHV(周DI,90))-周F分;
周点:=CONST(LLV(沧海行周MA,90));
周基:=CONST(HHV(沧海行周MA,90))-周点;
周F比:=(周DI-周F分)/周F百;
周XFX:=周F比*周基+周点;
周RSI1叠加:周XFX*2,COLORBROWN,LINETHICK2;

月RSI1叠加:XFX*3,LINETHICK1,COLORRED,LINETHICK3;

注册111
Lv.6
发表于 2020-1-15 07:12 复制 查看全部楼层
要有周月RSI引用公式
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表