手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将文华指标改成通达信的

[通达信]
设置
2834 2 邹云88 Lv.3 发表于 · 2020-1-15 03:22 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
感觉这个文华指标不错,恳请老师讲他改成通达信的
HH1:=IFELSE(H<REF(H,1)&&REF(H,1)<REF(H,2),REF(H,2),0);
LL1:=IFELSE(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);
LL2:=VALUEWHEN(LL1>0,LL1);
K1:=IFELSE(CLOSE>HH2,-3,IFELSE(CLOSE<LL2,1,0));
K2:=VALUEWHEN(K1<>0,K1);
G:=IFELSE(K2=1,HH2,LL2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(L>0,G1,G1,0,COLORCYAN);
W2:=OPEN-CLOSE;
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);
LT:=IFELSE(OPEN<CLOSE,OPEN,CLOSE);
DRAWLINE(K2=1,HIGH,K2=1,HT,COLORCYAN);
DRAWLINE(K2=1,LOW,K2=1,LT,COLORCYAN);
DRAWLINE(K2=-3,HIGH,K2=-3,HT,COLORRED);
DRAWLINE(K2=-3,LOW,K2=-3,LT,COLORRED);
STICKLINE(K2>0,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(K2<=0,OPEN,CLOSE,COLORRED,1);
STICKLINE(W2>0 AND K2<=0,OPEN,CLOSE,COLORRED,0);
STICKLINE(W2>0 AND K2>0,OPEN,CLOSE,COLORCYAN,0);
DRAWLINE(K2=1 AND REF(K2,1)=1,G,K2=1 AND REF(K2,1)=1,REF(G,1),COLORLIGHTGREEN);
DRAWLINE(K2=-3 AND REF(K2,1)=-3,G,K2=-3 AND REF(K2,1)=-3,REF(G,1),COLORYELLOW);
DRAWSL(K2=1,G,0,1,0,COLORLIGHTGREEN);
DRAWSL(K2=-3,G,0,1,0,COLORYELLOW);
AA:=VALUEWHEN(K2=-3,G);
CC:=VALUEWHEN(K2=1,G);
压力线:CC,COLORLIGHTGREEN,NODRAW;
支撑线:AA,COLORYELLOW,NODRAW;


附件

赢顺截图20200115032036.jpg
邹云88
Lv.3
发表于 2020-1-16 00:20 复制 查看全部楼层
休闲者68 发表于 2020-1-15 08:31
试试行不行
HH1:=IF(HREF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);

不行哦,看来这还蛮复杂的

附件

tdxjietu1.JPG
休闲者68
Lv.6
发表于 2020-1-15 08:31 复制 查看全部楼层
试试行不行
HH1:=IF(H<REF(H,1)&&REF(H,1)<REF(H,2),REF(H,2),0);
LL1:=IF(L>REF(L,1)&&REF(L,1)>REF(L,2),REF(L,2),0);
HH2:=VALUEWHEN(HH1>0,HH1);
LL2:=VALUEWHEN(LL1>0,LL1);
K1:=IF(CLOSE>HH2,-3,IF(CLOSE<LL2,1,0));
K2:=VALUEWHEN(K1<>0,K1);
G:=IF(K2=1,HH2,LL2);
G1:=VALUEWHEN(ISLASTBAR,G);
DRAWNUMBER(L>0,G1,G1),COLORCYAN;
W2:=OPEN-CLOSE;
HT:=IF(OPEN>CLOSE,OPEN,CLOSE);
LT:=IF(OPEN<CLOSE,OPEN,CLOSE);
DRAWLINE(K2=1,HIGH,K2=1,HT,0),COLORCYAN;
DRAWLINE(K2=1,LOW,K2=1,LT,0)COLORCYAN;
DRAWLINE(K2=-3,HIGH,K2=-3,HT,0)COLORRED;
DRAWLINE(K2=-3,LOW,K2=-3,LT,0)COLORRED;
STICKLINE(K2>0,OPEN,CLOSE,0,1)COLORCYAN;
STICKLINE(K2<=0,OPEN,CLOSE,0,1)COLORRED;
STICKLINE(W2>0 AND K2<=0,OPEN,CLOSE,0,0)COLORRED;
STICKLINE(W2>0 AND K2>0,OPEN,CLOSE,0,0)COLORCYAN;
DRAWLINE(K2=1 AND REF(K2,1)=1,G,K2=1 AND REF(K2,1)=1,REF(G,1),0),COLORGREEN;
DRAWLINE(K2=-3 AND REF(K2,1)=-3,G,K2=-3 AND REF(K2,1)=-3,REF(G,1),0)COLORYELLOW;
DRAWSL(K2=1,G,0,1,0)COLORGREEN,NODRAW;
DRAWSL(K2=-3,G,0,1,0)COLORYELLOW,NODRAW;
AA:=VALUEWHEN(K2=-3,G);
CC:=VALUEWHEN(K2=1,G);
压力线:CC,COLORGREEN,NODRAW;
支撑线:AA,COLORYELLOW,NODRAW;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表