手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个通达信选股公式

[通达信]
设置
2031 3 蜗牛啊 Lv.2 发表于 · 2020-1-15 12:14 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
公式源码:
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(BU,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;
主力:EMA(CLOSE,10),COLORRED;
散户:EMA(CLOSE,5),COLORYELLOW;
绿降:(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1;
操盘:MA(CLOSE,9),COLORWHITE,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLOR0000FF;
TIR:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=MA(TR,14);{大智慧加上这两句定义}
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1 = 1),(LOW - 0.6),'跟进'),COLORYELLOW;
DRAWTEXT((B2 = 1),(LOW - 0.6),'加码'),COLORFFAAFF;

选股公式要求是:出现红色向上箭头提示买点,选出来。谢谢老师

相关股票

兜里揣块糖
Lv.2
发表于 2020-1-16 00:53 复制 查看全部楼层
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
红箭头:CROSS(买线,卖线);
蜗牛啊
Lv.2
发表于 2020-1-15 13:09 复制 查看全部楼层
休闲者68 发表于 2020-1-15 12:31
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
BU:CROSS(买线,卖线);

谢谢老师,我试了很好用
休闲者68
Lv.6
发表于 2020-1-15 12:31 复制 查看全部楼层
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);  
BU:CROSS(买线,卖线);
查看全部打赏
  • 福阿德+6理想币 : 赠人玫瑰,手有余香。
  • 蜗牛啊+10理想币 +2共享币 : 感谢交流,感恩分享,收获正能量。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表