手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将两个条件选股公式合并成一个

[通达信]
设置
2156 4 日后相贱 Lv.2 发表于 · 2020-1-15 12:34 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
指标一:
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;

五191:=REFDATE(H5,DATE),COLORYELLOW;

TJ:CROSS(C,五191);




指标二:
参数    最小    最大        缺省
N       2.00    1000.00   5
N1     2.00    1000.00   10
N2     2.00    1000.00   20
N3     2.00    1000.00   60


A1:=MA(CLOSE,N); A2:=MA(CLOSE,N1); A3:=MA(CLOSE,N2); A4:=MA(CLOSE,N3); CLOSE>A1 AND A2>A3 AND A3>A4 AND CLOSE>OPEN AND (C+O)/2>(REF(C,1)+REF(O,1))/2 AND (REF(C,1)+REF(O,1))/2<(REF(C,2)+REF(O,2))/2 AND H>REF(H,2) AND C>REF(H,1);
日后相贱
Lv.2
发表于 2020-1-15 12:54 复制 查看全部楼层
谢谢各位老师,理想论坛真好,人才多,有问必答。
许昌舍得
Lv.6
发表于 2020-1-15 12:43 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-15 17:52 编辑

供参考

附件

回复.txt [预览]

755 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
网络漫步1
Lv.5
发表于 2020-1-15 12:43 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-15 17:51 编辑

供参考

附件

回复.txt [预览]

479 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
篙股道
Lv.4
发表于 2020-1-15 12:42 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-15 17:50 编辑

自己试试。。。。。。。。。。。。。。。。

参数    最小    最大        缺省
N       2.00    1000.00   5
N1     2.00    1000.00   10
N2     2.00    1000.00   20
N3     2.00    1000.00   60


附件

回复.txt [预览]

691 Bytes, 下载次数: 1, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表