手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将下面指标进行修改

[通达信]
设置
2007 3 宽仁律己 Lv.4 发表于 · 2020-1-15 14:04 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
在主图只显示天数和%,不显示划线


A6:=H=ZIG(1,6) AND ZIG(1,6)>REF(ZIG(1,6),1);
B6:=H=ZIG(1,6) AND ZIG(1,6)<REF(ZIG(1,6),1);
TA6:=BARSLAST(A6)+1;
TB6:=BARSLAST(B6)+1;
S6:=A6*REF(TB6,1)+1;
X6:=B6*REF(TA6,1)+1;
SF6:=(A6*H/REF(L,TB6)-1)*100;
XF6:=(B6*L/REF(H,TA6)-1)*100;
DRAWTEXT(A6,H*1.01,VARCAT(VARCAT(VAR2STR(S6,0),'天'),VARCAT(VAR2STR(SF6,0),'%'))),COLORLIGREEN;
DRAWTEXT(B6,L*0.99,VARCAT(VARCAT(VAR2STR(X6,0),'天'),VARCAT(VAR2STR(XF6,0),'%'))),COLORLIGREEN;
DRAWLINE(A6,H,B6,L,0),COLORLIGREEN,LINETHICK3;
DRAWLINE(B6,L,A6,H,0),COLORLIGREEN,LINETHICK3;
A20:=H=ZIG(1,20) AND ZIG(1,20)>REF(ZIG(1,20),1);
B20:=H=ZIG(1,20) AND ZIG(1,20)<REF(ZIG(1,20),1);
TA20:=BARSLAST(A20)+1;
TB20:=BARSLAST(B20)+1;
S20:=A20*REF(TB20,1)+1;
X20:=B20*REF(TA20,1)+1;
SF20:=(A20*H/REF(L,TB20)-1)*100;
XF20:=(B20*L/REF(H,TA20)-1)*100;
DRAWTEXT(A20,H*1.035,VARCAT(VARCAT(VAR2STR(S20,0),'天'),VARCAT(VAR2STR(SF20,0),'%'))),COLORYELLOW;
DRAWTEXT(B20,L*0.965,VARCAT(VARCAT(VAR2STR(X20,0),'天'),VARCAT(VAR2STR(XF20,0),'%'))),COLORYELLOW;
DRAWLINE(A20,H,B20,L,0),COLORYELLOW,LINETHICK1;
DRAWLINE(B20,L,A20,H,0),COLORYELLOW,LINETHICK1;
宽仁律己
Lv.4
发表于 2020-1-16 12:22 复制 查看全部楼层
我是九哥老师您好,我不能下载,谢谢
宽仁律己
Lv.4
发表于 2020-1-16 09:52 复制 查看全部楼层
我怎么下载不了,请帮助,谢谢
我是九哥
Lv.7
发表于 2020-1-15 15:37 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-15 17:56 编辑

供参考

附件

回复.txt [预览]

917 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表