手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个选股指标

[通达信]
设置
2183 3 兜里揣块糖 Lv.2 发表于 · 2020-1-15 22:40 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
搜狗截图20年01月15日2238_1.jpg

如图 ,红色三角,黄色块状, 2个选股公式,谢谢啦。

副图指标如下

T1:=5;
T2:=4;
P:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);
BB:=MA(P,3);
CC:=(SUM(IF((P > REF(P,1)),(P)*(VOL),0),4))/(SUM(IF((P < REF(P,1)),(P)*(VOL),0),4));
DD:=REF(100 - (100)/(1 + CC),1);
A1:=HHV(P,15);
A2:=LLV(P,15);
A3:=A1 - A2;
A4:=(EMA((P - A2)/(A3),2))*(100);
B1:=HHV(P,60);
B2:=LLV(P,60);
B3:=B1 - B2;
B4:=(EMA((P - B2)/(B3),2))*(100);
C1:=HHV(P,240);
C2:=LLV(P,240);
C3:=C1 - C2;
C4:=(EMA((P - C2)/(C3),2))*(100);
长风险:C4,LINETHICK2,COLOR443434;
中风险:B4,COLORAA7755;
短风险:A4,COLOR44AABB;
IF(FILTER((中风险 < REF(中风险,1)) AND (中风险 > 90) AND (BB < REF(BB,1)),5),92,100),LINETHICK2,COLOR44BB00;
IF(FILTER((中风险 > REF(中风险,1)) AND (中风险 < 5) AND (CLOSE > REF(CLOSE,1)),5),14,0),LINETHICK2,COLOR2222FF;
VAR4:=LLV(LOW,T1);
VAR5:=HHV(HIGH,T2);
散户:EMA(((P - VAR4)/(VAR5 - VAR4))*(100),T2),LINETHICK2,COLOR3333DD;
庄家:EMA((0.667)*(REF(散户,1)) + (0.333)*(散户),2),LINETHICK2,COLORDDCC00;
VAR6:=((HHV(HIGH,4) - P)/(HHV(HIGH,4) - LLV(LOW,4)))*(100) - 72;
VAR7:=((P - LLV(LOW,4))/(HHV(HIGH,4) - LLV(LOW,4)))*(100);
VAR8:=SMA(VAR7,2,1);
{DRAWTEXT(CROSS(散户,庄家) AND (散户 < 50) AND (29 < 散户),20,'▲'),COLORRED;
DRAWTEXT(CROSS(庄家,散户) AND (散户 > 40) AND (71 > 散户),70,'▼'),COLORFF0000;
DRAWTEXT(CROSS(散户,庄家) AND (散户 < 30),30,'吸'),COLORRED;}
{DRAWICON(CROSS(散户,庄家) AND (散户 < 30),20,1),COLORYELLOW;
DRAWICON(CROSS(庄家,散户) AND (散户 > 70),80,2),COLORFF00FF;}
VAR9:=CLOSE - REF(CLOSE,5);
VARA:=((EMA(EMA(VAR9,5),5))/(EMA(EMA(ABS(VAR9),5),5)))*(100);
VARB:=((EMA(EMA(VAR9,10),10))/(EMA(EMA(ABS(VAR9),10),10)))*(100);
VARC:=((EMA(EMA(VAR9,20),20))/(EMA(EMA(ABS(VAR9),20),20)))*(100);
卖出:=IF((VARA > 0) AND CROSS(VARC,VARA),10,0);
DRAWICON((卖出 > 0),60,2),COLOR00FF00;
CCI:=((P - MA(P,14))*(100))/((1.5)*(AVEDEV(P,14)));
RSI1:=((SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),6,1)))*(100);
STICKLINE((CCI > 100),106,100,3,0),COLOR00AC00;
STICKLINE((RSI1 > 80),105,102,3,0),COLOR00FE00;
STICKLINE((CCI < (-100)),(-6),0,3,0),COLORYELLOW;
STICKLINE((RSI1 < 25),(-6),(-2),3,0);
D1:=(中风险 > REF(中风险,1)) AND (短风险 > REF(短风险,1)) AND (长风险 > REF(长风险,1)) AND (长风险 < 8) AND (中风险 < 10) AND (短风险 < 15);
D2:=CROSS(短风险,中风险) AND (中风险 < 8);
D3:=CROSS(短风险,长风险) AND (长风险 < 8) AND (中风险 < 20);
DRAWICON(FILTER(D1 OR D2 OR D3 AND (DD < 15) AND (CLOSE > REF(CLOSE,1)),5),8,1),COLORFF0000;
DRAWICON(FILTER((中风险 < REF(中风险,1)) AND (短风险 < REF(短风险,1)) AND (长风险 < REF(长风险,1)) AND (中风险 > 95) AND (短风险 > 85) OR (长风险 > 100) AND (中风险 > 100) AND (短风险 > 100),5),95,2);
警戒:80,COLORDCDCDC;
启动:20,COLORYELLOW;
兜里揣块糖
Lv.2
发表于 2020-1-15 23:08 复制 查看全部楼层
许昌舍得 发表于 2020-1-15 23:00
P:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);

B1:=HHV(P,60);

谢谢你老师,祝您股市长虹,新春愉快!
许昌舍得
Lv.6
发表于 2020-1-15 23:00 复制 查看全部楼层
本帖最后由 福阿德 于 2020-1-16 16:03 编辑

供参考

附件

回复.txt [预览]

238 Bytes, 下载次数: 0, 下载积分: 共享币 -5 个

查看全部打赏
  • 福阿德+8理想币 +7共享币 : 赠人玫瑰,手有余香。
许昌舍得
Lv.6
发表于 2020-1-15 22:55 复制 查看全部楼层
黄柱:CCI < (-100);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表