手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写个250日均线平行的选股公式

[通达信]
设置
2152 6 黑马928 Lv.4 发表于 · 2020-1-16 11:35 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师写一个60日内,250日均线向上角度一直不大于5度(基本平行)选股公式,谢谢老师
糜正根
Lv.3
发表于 2020-1-18 17:17 复制 查看全部楼层
横有多长竖有多高,并且前期主力没短期暴涨过,这理念不错。还需添加其他的条件辅助。
250日线平行且朝上运行源码。

JD250:=(ATAN((MA(C,250)/REF(MA(C,250),1)-1)*100)*180/3.14115926)>5;
PX250:=COUNT(EVERY(JD250,1),60)<1;{60日内250日均线不存在角度大于5度以上的情况}

MA250:=MA(C,250)>=REF(MA(C,250),1);{250日均线由走平向上翘}

SQ250:=COUNT(EVERY(MA250,1),60)>=35;{60日内有35个交易日的时间250日线都是上翘的,股价的波段高低起伏以及主力的挖坑行为
可能会使250日线偶尔几日有稍微向下运行的情况,不可能天天处于上翘的方向}

JQ250:=COUNT(EVERY(MA250,2),15)>=1 AND MA250;{最近15日有250日均线连续两天都上翘的两次次以上的情况发生,并且今日250日线的状态是上翘方向}
XG250:PX250 AND SQ250 AND JQ250;
醉夕风
Lv.2
发表于 2020-1-16 23:05 复制 查看全部楼层
A1:=MA(CLOSE,250);
QP:=REF(A1,1)*1.04>A1;
QO:=REF(A1,2)*1.04>A1;
XG:=QP AND QO ;
EXIST(XG,60);
泉州玉真人
Lv.4
发表于 2020-1-16 22:58 复制 查看全部楼层
MG角度:=ATAN((MA(C,250)/REF(MA(C,250)-1)*100)*180/3.1816;
XG:EVERY(MG角度,60)<5;
泉州玉真人
Lv.4
发表于 2020-1-16 22:55 复制 查看全部楼层
MG角度:=ATAN((MA(/REF(MV5,1)-1)*100)*180/3.1816;
黑马928
Lv.4
发表于 2020-1-16 13:43 复制 查看全部楼层
稽山一客 发表于 2020-1-16 12:26
均线:MA(CLOSE,250); 平行:均线*1.15;

不正确老师
稽山一客
Lv.2
发表于 2020-1-16 12:26 复制 查看全部楼层
均线:MA(CLOSE,250); 平行:均线*1.15;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表