手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请大神编写选股公式

[通达信]
设置
2235 1 攀岩2015 Lv.2 发表于 · 2020-1-16 11:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
各位老师:中午好!请将下列公式出现红三角做一个选股公式。谢谢!

       N1:=18;N2:=50;N3:=32;

CPX:(MA(CLOSE,8)*N1/100+MA(CLOSE,30)*N2/100+MA(CLOSE,60)*N3/100)COLORYELLOW;

NOTEXTWS:=CPX>REF(CPX,1) AND MA(CLOSE,30)>REF(MA(CLOSE,30),1) AND CLOSE>CPX AND CLOSE>MA(CLOSE,30),NODRAW;

NOTEXTWX:=CPX<=REF(CPX,1) AND MA(CLOSE,30)<=REF(MA(CLOSE,30),1) AND CLOSE<CPX AND CLOSE<MA(CLOSE,30),NODRAW;

STICKLINE(C>=O,L,H,0,0),COLORYELLOW;

STICKLINE(C>=O,C,O,2,1),COLORYELLOW;

STICKLINE(C<O,L,H,0,0),COLORYELLOW;

STICKLINE(C<O,C,O,2,0),COLORYELLOW;

STICKLINE(C>=O AND NOTEXTWS=1,L,H,0,0),COLORRED;

STICKLINE(C>=O AND NOTEXTWS=1,C,O,2,1),COLORRED;

STICKLINE(C<O AND NOTEXTWS=1,L,H,0,0),COLORRED;

STICKLINE(C<O AND NOTEXTWS=1,C,O,2,0),COLORRED;

STICKLINE(C>=O AND NOTEXTWX=1,L,H,0,0),COLORCYAN;

STICKLINE(C>=O AND NOTEXTWX=1,C,O,2,1),COLORCYAN;

STICKLINE(C<O AND NOTEXTWX=1,L,H,0,0),COLORCYAN;

STICKLINE(C<O AND NOTEXTWX=1,C,O,2,0),COLORCYAN;

NOTEXT1:IF(NOTEXTWS=1,CPX,DRAWNULL),COLORRED;

NOTEXT2:IF(NOTEXTWX=1,CPX,DRAWNULL),COLORFFFF00;

DRAWICON(NOTEXTWS=1 AND NOT(REF(NOTEXTWS,1)) AND COUNT(NOTEXTWS=1,BARSLAST(NOTEXTWX=1))=1,CPX,38);

DRAWICON(NOTEXTWX=1 AND NOT(REF(NOTEXTWX,1)) AND COUNT(NOTEXTWX=1,BARSLAST(NOTEXTWS=1))=1,CPX,39);
稽山一客
Lv.2
发表于 2020-1-16 12:06 复制 查看全部楼层
N1:=18;N2:=50;N3:=32;

CPX:=(MA(CLOSE,8)*N1/100+MA(CLOSE,30)*N2/100+MA(CLOSE,60)*N3/100);

NOTEXTWS:=CPX>REF(CPX,1) AND MA(CLOSE,30)>REF(MA(CLOSE,30),1) AND CLOSE>CPX AND CLOSE>MA(CLOSE,30);

NOTEXTWX:=CPX<=REF(CPX,1) AND MA(CLOSE,30)<=REF(MA(CLOSE,30),1) AND CLOSE<CPX AND CLOSE<MA(CLOSE,30);

NOTEXTWS=1 AND NOT(REF(NOTEXTWS,1)) AND COUNT(NOTEXTWS=1,BARSLAST(NOTEXTWX=1))=1;

您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表