手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助作个绿块转成红块时选股

[通达信]
设置
2515 8 灰方块 Lv.2 发表于 · 2020-1-16 17:29 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请老师作个绿块转成红块时选股
*********************************

N1:=21;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
有利可图:=IF(VAR6A>N1,VAR6A-N1,0),COLORLIRED;
STICKLINE(REF(有利可图,1)<有利可图,有利可图,REF(有利可图,1),3,0),COLORRED;
STICKLINE(REF(有利可图,1)>有利可图,有利可图,REF(有利可图,1),3,0),COLOR00FF00;
跌底
Lv.2
发表于 2020-1-17 11:00 复制 查看全部楼层
休闲者68 发表于 2020-1-17 08:55
请你将5楼‘’不贪主图2‘’的公式源码发我,帮你看一下问题出在哪里。

谢谢老师了,上面有个老师帮我搞了
休闲者68
Lv.6
发表于 2020-1-17 08:55 复制 查看全部楼层
跌底 发表于 2020-1-16 22:29
就是可以在日线图上文字输出支撑,阻力的价位
,获取的值都是上一个交易日的数据
,例如输出的 支点, ...

请你将5楼‘’不贪主图2‘’的公式源码发我,帮你看一下问题出在哪里。
注册111
Lv.6
发表于 2020-1-17 07:42 复制 查看全部楼层
跌底 发表于 2020-1-16 22:29
就是可以在日线图上文字输出支撑,阻力的价位
,获取的值都是上一个交易日的数据
,例如输出的 支点, ...

在日线上显示,主副图都可。
昨天最高价:REF (H ,1),NODRAW;
昨天最低价:REF (L ,1),NODRAW;
昨天收盘价:REF (C ,1 ),NODRAW;
支点:=(昨天最高价+昨天最低价+昨天收盘价)/3;
阻力1:=(2 * 支点 - 昨天最低价);
支撑1:=(2 * 支点 - 昨天最高价);
阻力2:=(支点 + (阻力1 - 支撑1));
支撑2:=(支点 - (阻力1 - 支撑1));
阻力3:=(昨天最高价 +2*(支点-昨天最低价));
支撑3:=(昨天最低价 -2*(昨天最高价-支点));
DRAWTEXT_FIX(1,0.00,0.1,0,STRCAT('支点: ',CON2STR(支点,2))),COLORRED;
DRAWTEXT_FIX(1,0.00,0.2,0,STRCAT('阻力1: ',CON2STR(阻力1,2))),COLORRED;
DRAWTEXT_FIX(1,0.00,0.3,0,STRCAT('支撑1:',CON2STR(支撑1,2))),COLORRED;

附件

捕获.JPG
查看全部打赏
  • 跌底+5理想币 : 每天进步一点点,希望的火苗不熄灭。
跌底
Lv.2
发表于 2020-1-16 22:38 复制 查看全部楼层
休闲者68 发表于 2020-1-16 22:23
不知你想怎样调试?

老师,我的公式,赋值,是不是错了,才显示不出正确的啊
跌底
Lv.2
发表于 2020-1-16 22:29 复制 查看全部楼层
休闲者68 发表于 2020-1-16 22:23
不知你想怎样调试?

就是可以在日线图上文字输出支撑,阻力的价位
,获取的值都是上一个交易日的数据
,例如输出的 支点,阻力,支撑

附件

微信截图_20200116222802.png
休闲者68
Lv.6
发表于 2020-1-16 22:23 复制 查看全部楼层
跌底 发表于 2020-1-16 21:57
老师,您能帮我调试一下这个公式吗,在分时图上输出的。我没有够共享币发贴了,我在这里给您打赏币。麻烦 ...

不知你想怎样调试?
跌底
Lv.2
发表于 2020-1-16 21:57 复制 查看全部楼层
休闲者68 发表于 2020-1-16 17:38
N1:=21;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;

老师,您能帮我调试一下这个公式吗,在分时图上输出的。我没有够共享币发贴了,我在这里给您打赏币。麻烦了





昨天最高价:REF (H ,1) ;
昨天最低价:REF (L ,1) ;
昨天收盘价:REF (C ,1 );

支点:=(昨天最高价+昨天最低价+昨天收盘价)/3;
阻力1:=(2 * 支点 - 昨天最低价);
支撑1:=(2 * 支点 - 昨天最高价);

阻力2:=(支点 + (阻力1 - 支撑1));
支撑2:=(支点 - (阻力1 - 支撑1));

阻力3:=(昨天最高价 +2*(支点-昨天最低价));
支撑3:=(昨天最低价 -2*(昨天最高价-支点));


DRAWTEXT_FIX(1,0.00,0.17,0,'支点:'),COLORRED;
DRAWNUMBER_FIX(1,0.05,0.17,0,支点),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.21,0,'阻力1:'),COLORRED;
DRAWNUMBER_FIX(1,0.05,0.21,0,阻力1),COLORYELLOW;
DRAWTEXT_FIX(1,0.00,0.26,0,'支撑1:'),COLORRED;
DRAWNUMBER_FIX(1,0.05,0.26,0,支撑1),COLORYELLOW;
休闲者68
Lv.6
发表于 2020-1-16 17:38 复制 查看全部楼层
N1:=21;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
有利可图:=IF(VAR6A>N1,VAR6A-N1,0);
绿块转成红块:CROSS(REF(有利可图,1)<有利可图,0.5);
查看全部打赏
  • 跌底+5理想币 : 知识的价值在于分享,点赞是价值认同。
  • 灰方块+10理想币 +2共享币 : 谢谢老师
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表