手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改个通达信副图选股公式

[通达信]
设置
2605 3 新手路边过 Lv.1 发表于 · 2020-1-16 21:00 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA20:=MA(CLOSE,20);

JXX:=BARSLASTCOUNT(C<MA20);

JXX1:=BACKSET((JXX>=4)*JXX,JXX);

JXS:=BARSLASTCOUNT(C>MA20);

JXS1:=BACKSET((JXS>=4)*JXS,JXS);

KGC:=BARSLASTCOUNT(NOT(JXX1 OR JXS1));

JXL:=BARSLASTCOUNT(REF(JXX1>0,KGC));

JXH:=BARSLASTCOUNT(REF(JXS1>0,KGC));

XWZ:=FILTERX(LLV(L,JXL)=L,JXL);

SWZ:=FILTERX(HHV(H,JXH)=H,JXH);

A:=DRAWLINE(XWZ,L,SWZ,H,0);

高:=REF(H,BARSLAST(SWZ));

低:=REF(L,BARSLAST(XWZ));

BB:=BARSLAST(JXL=1);

顶点2:=REF(高,BARSLAST(JXL));

低点2:=REF(低,BB);

H61:=((顶点2-低点2)*0.618+低点2);

A8:=REFDATE(H61,DATE);

都满足:=REF(C,1)>A8+0.01 AND V<REF(V,1);

第一种:=RANGE(O,A8-0.01,A8+0.01) AND C>O;

第二种:=O>A8+0.01 AND RANGE(C,A8-0.01,A8+0.01) AND C<O;

第三种:=C>A8+0.01 AND RANGE(L,A8-0.01,A8+0.01);

选股:都满足 AND (第一种 OR 第二种 OR 第三种)

以上公式是收盘价,开盘价,下影线回轴0.618选股公式。
求高手加2个条件:①回轴顶点1,出信号。②回轴1.618,出信号。
许昌舍得
Lv.6
发表于 2020-1-16 22:21 复制 查看全部楼层
MA20:=MA(CLOSE,20);
JXX:=BARSLASTCOUNT(C<MA20);
JXX1:=BACKSET((JXX>=4)*JXX,JXX);
JXS:=BARSLASTCOUNT(C>MA20);
JXS1:=BACKSET((JXS>=4)*JXS,JXS);
KGC:=BARSLASTCOUNT(NOT(JXX1 OR JXS1));
JXL:=BARSLASTCOUNT(REF(JXX1>0,KGC));
JXH:=BARSLASTCOUNT(REF(JXS1>0,KGC));
XWZ:=FILTERX(LLV(L,JXL)=L,JXL);
SWZ:=FILTERX(HHV(H,JXH)=H,JXH);
A:=DRAWLINE(XWZ,L,SWZ,H,0);
高:=REF(H,BARSLAST(SWZ));
低:=REF(L,BARSLAST(XWZ));
BB:=BARSLAST(JXL=1);
顶点2:=REF(高,BARSLAST(JXL));
低点2:=REF(低,BB);
H1.618:=((顶点2-低点2)*1.618+低点2);
A8:=REFDATE(顶点2,DATE);
都满足:=REF(C,1)>A8+0.01 AND V<REF(V,1);
第一种:=RANGE(O,A8-0.01,A8+0.01) AND C>O;
第二种:=O>A8+0.01 AND RANGE(C,A8-0.01,A8+0.01) AND C<O;
第三种:=C>A8+0.01 AND RANGE(L,A8-0.01,A8+0.01);
选股:都满足 AND (第一种 OR 第二种 OR 第三种);



顶点2
休闲者68
Lv.6
发表于 2020-1-16 22:19 复制 查看全部楼层
缺少轴顶点1赋值。
许昌舍得
Lv.6
发表于 2020-1-16 22:17 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-1-16 22:20 编辑

MA20:=MA(CLOSE,20);
JXX:=BARSLASTCOUNT(C<MA20);
JXX1:=BACKSET((JXX>=4)*JXX,JXX);
JXS:=BARSLASTCOUNT(C>MA20);
JXS1:=BACKSET((JXS>=4)*JXS,JXS);
KGC:=BARSLASTCOUNT(NOT(JXX1 OR JXS1));
JXL:=BARSLASTCOUNT(REF(JXX1>0,KGC));
JXH:=BARSLASTCOUNT(REF(JXS1>0,KGC));
XWZ:=FILTERX(LLV(L,JXL)=L,JXL);
SWZ:=FILTERX(HHV(H,JXH)=H,JXH);
A:=DRAWLINE(XWZ,L,SWZ,H,0);
高:=REF(H,BARSLAST(SWZ));
低:=REF(L,BARSLAST(XWZ));
BB:=BARSLAST(JXL=1);
顶点2:=REF(高,BARSLAST(JXL));
低点2:=REF(低,BB);
H161:=((顶点2-低点2)*1.618+低点2);
A8:=REFDATE(H61,DATE);
都满足:=REF(C,1)>A8+0.01 AND V<REF(V,1);
第一种:=RANGE(O,A8-0.01,A8+0.01) AND C>O;
第二种:=O>A8+0.01 AND RANGE(C,A8-0.01,A8+0.01) AND C<O;
第三种:=C>A8+0.01 AND RANGE(L,A8-0.01,A8+0.01);
选股:都满足 AND (第一种 OR 第二种 OR 第三种);





1.618的
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表