手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助做个选股公式

[通达信]
设置
3766 2 风中蒲公英1 Lv.2 发表于 · 2020-1-20 01:09 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
N1:=9;N2:=5;
AVPRICE:=(2*OPEN+2*CLOSE+2*HIGH+2*LOW)/8;
INDEXAVP:=(2*INDEXH+2*INDEXL+2*INDEXO+2*INDEXC)/8;
F:=(AVPRICE - REF(AVPRICE,1))/REF(AVPRICE,1);
F1:=(INDEXAVP - REF(INDEXAVP,1))/REF(INDEXAVP,1);
AA:=AVPRICE;
BB:=((VOL)*((AA)*(2) - HIGH - LOW))/(HIGH - LOW);
CC:=IF((HIGH = LOW) AND (AA < REF(AA,1)),((-1))*(VOL),VOL);
A:=IF((HIGH = LOW),CC,BB);
B:=SUM(A,11);
BBD:=(((B)/((CAPITAL)*(11)))*(10000));
BB1:=IF((BBD < 150) AND (BBD > (-150)),BBD,150);
买方能量指标:=IF((BB1 > 0),BB1,0);

主动买量:IF((BB1 > 0),BB1,0),COLOR00FFFF,NODRAW;
主动卖量:IF((BB1<0),BB1,0),COLOR00FF00,NODRAW;
A16:=(SUM((AVPRICE)*(VOL),16))/(SUM(VOL,16));
A11:=(SUM((AVPRICE)*(VOL),11))/(SUM(VOL,11));
A6:=(SUM((AVPRICE)*(VOL),6))/(SUM(VOL,6));
A7:=(SUM((AVPRICE)*(VOL),7) - (AVPRICE)*(VOL))/(SUM(VOL,7) - VOL);
A0:=((A11 - A16)/(AVPRICE))*(1000);
A00:=IF((A0 > 50),50,IF((A0 < (-50)),(-50),A0));
A1:=((A6 - A11)/(AVPRICE))*(1000);
AA11:=IF((A1 > 50),50,IF((A1 < (-50)),(-50),A1));
A2:=((((A6 - A7)/(A7))*(5))/(4))*(1000);
A22:=IF((A2 > 50),50,IF((A2 < (-50)),(-50),A2));
{STICKLINE((BB1 < 0),0,(-BB1),2,0),COLOR00FF00;};
主力资金:EMA(100*(C-LLV(LOW,30))/(HHV(H,30)-LLV(LOW,30)),3), COLORRED,LINETHICK2;
即将爆发线: 65,COLOR00FF00;
起爆线:80,COLORWHITE,LINETHICK1;
DRAWTEXT(CROSS(主力资金,起爆线),主力资金,'◆爆发!') ,COLORYELLOW;
TMD:=C-REF(C,1);
金线:100*EMA(EMA(TMD,N1),N1)/EMA(EMA(ABS(TMD),N1),N1),COLORWHITE,LINETHICK1;
银线:MA(金线,N2),COLOR00FF00,LINETHICK1;
STICKLINE(金线>银线 , 金线,银线 ,1.5,0),COLORRED,LINETHICK2;
STICKLINE(银线>金线,金线,银线,1.5,0),COLORGREEN,LINETHICK2;
爆发线:30,COLORFF00FF,LINETHICK1;
起步线:0,COLORWHITE,LINETHICK1;

抄底线:-25,COLORWHITE,LINETHICK1;

LC:= REF(C,1);
顶:=85;
中:=50;
底:=20;
VAR11:=HHV(HIGH,9)-LLV(LOW,9);
VAR12:=HHV(HIGH,9)-CLOSE;
VAR13:=CLOSE-LLV(LOW,9);
VAR14:=VAR12/VAR11*100-70;
VAR15:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR13/VAR11*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR14,9,1);
VARA:=IF(VAR9>100,VAR9-100,0);
VARB:=HHV(HIGH,34);
AA1:= VARA*2;
BB5:= EMA((VAR6-VAR8)/(VARB-VAR8)*100,13);
VARC:=EMA(0.667*REF(BB5,1)+0.333*BB5,2);
CC5:SMA(VAR15,20,1),COLOR000000;
CC1:SMA(CC5,5,1),COLOR000000;
出击:IF((CROSS(CC5,CC1) AND (CC1 < 顶) ),80,0),COLOR00FF00;



请老师以第一天出现红色柱为条件做个选股公式,谢谢
辛亥2011
Lv.4
发表于 2020-1-20 09:57 复制 查看全部楼层
注册111
Lv.6
发表于 2020-1-20 07:27 复制 查看全部楼层
N1:=9;N2:=5;
TMD:=C-REF(C,1);
金线:=100*EMA(EMA(TMD,N1),N1)/EMA(EMA(ABS(TMD),N1),N1);
银线:=MA(金线,N2);
CROSS(金线,银线);
查看全部打赏
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表