手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助编写3条线变一条线的公式

[通达信]
设置
3151 1 木木夕嘟嘟 Lv.2 发表于 · 2020-1-20 08:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
原公式

N:=10;{N自定义}
MAH:MA(HIGH,N);
MAL:MA(LOW,N);
MAC:MA(CLOSE,N);


HX:=IF(MAH>=MAL AND MAL>=MAC,1,0);
IF(HX,MAH,DRAWNULL);
IF(HX,MAL,DRAWNULL);
IF(HX,MAC,DRAWNULL);



3根线同时向上变红色线,同时向下变绿色线,
只要3根线同时是涨和同时是跌才出现 谢谢
休闲者68
Lv.6
发表于 2020-1-20 15:20 复制 查看全部楼层
N:=10;{N自定义}
MAH:MA(HIGH,N);
MAL:MA(LOW,N);
MAC:MA(CLOSE,N);


HX:=IF(MAH>=MAL AND MAL>=MAC,1,0);
IF(HX,MAH,DRAWNULL);
IF(HX,MAL,DRAWNULL);
IF(HX,MAC,DRAWNULL);
同涨:MAH>REF(MAH,1) AND MAL>REF(MAL,1) AND MAC>REF(MAC,1);
同跌:MAH<REF(MAH,1) AND MAL<REF(MAL,1) AND MAC<REF(MAC,1);
IF(MAH>REF(MAH,1),MAH,DRAWNULL)COLORRED,LINETHICK3;
IF(MAL>REF(MAL,1),MAL,DRAWNULL)COLORRED,LINETHICK3;
IF(MAC>REF(MAC,1),MAC,DRAWNULL)COLORRED,LINETHICK3;
IF(MAH<REF(MAH,1),MAH,DRAWNULL)COLORGREEN,LINETHICK3;
IF(MAL<REF(MAL,1),MAL,DRAWNULL)COLORGREEN,LINETHICK3;
IF(MAC<REF(MAC,1),MAC,DRAWNULL)COLORGREEN,LINETHICK3;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表