手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮忙修改下跌指标

[通达信]
设置
3537 8 好好230 Lv.3 发表于 · 2020-1-29 18:55 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
MA15:=EMA(C,15);
MA50:=EMA(C,50);
MA120:=EMA(C,120);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
NX:=(10*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORGREEN{COLORRED};
A:=MAX(MA(C,120),MA(C,120));
B:=MIN(MA(C,120),MA(C,120));
E:=MAX(MA(C,90),MA(C,90));
F:=MIN(MA(C,90),MA(C,90));
J:=MAX(MA(C,60),MA(C,60));
K:=MIN(MA(C,60),MA(C,60));
ZQ:=EMA(EMA(CLOSE,5)-EMA(CLOSE,34),5);
MB:=MA(ZQ,20);
R:=POW(ZQ-MB,2);
X1:=MA(R,20);
X:=SQRT(X1);
AA:=MB+1.96*X;
BB:=MB-1.96*X;
TJ1:=(MA50>REF(MA50,1))&&((REF(MA15,1) (REF(MA15,1)))) &&(MA15>MA50)&&(MA120>MA15);
TJ2:=(C>NX)&&(C>A)&&(C>E)&&(C>J);
TJ3:=(ZQ>0)&&(AA>(REF(AA,1)));
TJ1&&TJ2&&TJ3;  
好好230
Lv.3
发表于 2020-1-31 14:18 复制 查看全部楼层
黑龙江师哥 发表于 2020-1-30 07:35
卖出  :  XG < 1 ;
加上这句就可以了

谢谢各位老师,问题解决了
黑龙江师哥
Lv.2
发表于 2020-1-30 07:35 复制 查看全部楼层
卖出  :  XG < 1 ;
加上这句就可以了
好好230
Lv.3
发表于 2020-1-29 20:45 复制 查看全部楼层
许昌舍得 发表于 2020-1-29 20:36
MA15:=EMA(C,15);
MA50:=EMA(C,50);
MA120:=EMA(C,120);

加卖出图标选股
许昌舍得
Lv.6
发表于 2020-1-29 20:36 复制 查看全部楼层
好好230 发表于 2020-1-29 20:16
买进信号修改成卖出信号选股

MA15:=EMA(C,15);
MA50:=EMA(C,50);
MA120:=EMA(C,120);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
NX:=(10*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORGREEN{COLORRED};
A:=MAX(MA(C,120),MA(C,120));
B:=MIN(MA(C,120),MA(C,120));
E:=MAX(MA(C,90),MA(C,90));
J:=MAX(MA(C,60),MA(C,60));
ZQ:=EMA(EMA(CLOSE,5)-EMA(CLOSE,34),5);
MB:=MA(ZQ,20);F:=MIN(MA(C,90),MA(C,90));
R:=POW(ZQ-MB,2);
X1:=MA(R,20);
X:=SQRT(X1);
AA:=MB+1.96*X;
TJ1:=(MA50>REF(MA50,1))&&((REF(MA15,1) (REF(MA15,1)))) &&(MA15>MA50)&&(MA120>MA15);
TJ2:=(C>NX)&&(C>A)&&(C>E)&&(C>J);
TJ3:=(ZQ>0)&&(AA>(REF(AA,1)));
XG:TJ1&&TJ2&&TJ3;  
好好230
Lv.3
发表于 2020-1-29 20:27 复制 查看全部楼层
天下小龙 发表于 2020-1-29 20:20
还是没看懂噢,
买进信号 或者 卖出信号 都是个信号,你看到的信号认为是买入,他看到信号认为是卖出,这 ...

我要的是卖出提示信号,改成选股公式,谢谢
天下小龙
Lv.2
发表于 2020-1-29 20:20 复制 查看全部楼层
本帖最后由 天下小龙 于 2020-1-29 20:21 编辑

还是没看懂噢,
买进信号 或者 卖出信号 都是个信号,你看到的信号认为是买入,他看到信号认为是卖出,这个信号没有买入卖出之分。
你是要改成选股公式吗?
好好230
Lv.3
发表于 2020-1-29 20:16 复制 查看全部楼层
天下小龙 发表于 2020-1-29 19:14
没明白你的需求?能详细描述一下么?

买进信号修改成卖出信号选股 微信截图_20200129201338.png
天下小龙
Lv.2
发表于 2020-1-29 19:14 复制 查看全部楼层
没明白你的需求?能详细描述一下么?
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表