手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助修改如下选股公式

[通达信]
设置
2347 4 大路简 Lv.3 发表于 · 2020-2-7 16:56 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
如图中选股,请老师写成如图中均线多头后站上5日线第一个6%以上大阳(包括涨停板)时选股,谢谢。均线是5 10 20 30 60 90 120 250

附件

多多.png
大路简
Lv.3
发表于 2020-2-7 19:02 复制 查看全部楼层
许昌舍得 发表于 2020-2-7 18:50
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);

老师,这次从1月11至今选不出股。

附件

多选.png
许昌舍得
Lv.6
发表于 2020-2-7 18:50 复制 查看全部楼层
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,30);
MA5:=MA(CLOSE,60);
MA6:=MA(CLOSE,90);
MA7:=MA(CLOSE,120);
MA8:=MA(CLOSE,250);
DT:=C>MA1 AND MA1>MA2 AND MA2>MA3 AND MA3>MA4 AND MA4>MA5
AND MA5>MA6 AND MA6>MA7 AND MA7>MA8;

T:=BARSLAST(DT);

XG:COUNT(C/REF(C,1)>1.06,T)=1 AND EVERY(DT,T);
大路简
Lv.3
发表于 2020-2-7 17:39 复制 查看全部楼层
许昌舍得 发表于 2020-2-7 17:14
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);

老师,选出的35个股大多数不合适,像浩云科技1月14号,惠伦晶体2月25(6%大阳改成5%大阳也行)和26号就是标准的均线多头后站上5均线第一个大阳

附件

多选.png
许昌舍得
Lv.6
发表于 2020-2-7 17:14 复制 查看全部楼层
本帖最后由 许昌舍得 于 2020-2-7 18:51 编辑

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
MA4:=MA(CLOSE,30);
MA5:=MA(CLOSE,60);
MA6:=MA(CLOSE,90);
MA7:=MA(CLOSE,120);
MA8:=MA(CLOSE,250);
DT:=C>MA1 AND MA1>MA2 AND MA2>MA3 AND MA3>MA4 AND MA4>MA5
AND MA5>MA6 AND MA6>MA7 AND MA7>MA8;

T:=BARSLAST(DT);

XG:COUNT(C/REF(C,1)>1.06,T)=1 AND EVERY(DT,T);
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表