手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助根据这个指标编写个选股公式

[通达信]
设置
2574 4 佛山无影没脚 Lv.2 发表于 · 2020-2-7 20:12 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
请根据这年技术指标编写关于这个紫色指标的选股公式

附件

888.png
佛山无影没脚
Lv.2
发表于 2020-2-8 11:17 复制 查看全部楼层
暴富的蜗牛 发表于 2020-2-8 09:31
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1. ...

谢谢你的回复!
暴富的蜗牛
Lv.2
发表于 2020-2-8 09:31 复制 查看全部楼层
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
A3:=STICKLINE(VAR7,0,VAR7/50,4,0);
A4:=STICKLINE(VAR7,0,VAR7/50,3,0);
A5:=STICKLINE(VAR7,0,VAR7/50,2,0);
A6:=STICKLINE(VAR7,0,VAR7/50,1,0);
A7:A3>A4>A5>A6>1;
佛山无影没脚
Lv.2
发表于 2020-2-7 21:18 复制 查看全部楼层
我研究了下,这个紫色的指标原码应该是:

附件

999.png
佛山无影没脚
Lv.2
发表于 2020-2-7 20:12 复制 查看全部楼层
本帖最后由 佛山无影没脚 于 2020-2-7 20:14 编辑

VA1:=EMA(EMA(CLOSE,20),20);
K:=(VA1-REF(VA1,1))/REF(VA1,1);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
主线:=(DIF-DEA)*2;
MACK:=EMA(主线,5);
HARB:=EMA(EMA(EMA(CLOSE,5),5),5);
HARX:=(HARB-REF(HARB,1))/REF(HARB,1)*100;

0;
HF:EMA(HARX,10),COLORLIMAGENTA;
HC:EMA(HARX,20),COLORGREEN;
STICKLINE(主线>MACK AND K>REF(K,1) AND HARX>0,0,HARX,1,0),COLORRED;
STICKLINE(主线>MACK AND K>REF(K,1) AND HARX<=0,0,HARX,1,-1)COLORGRAY;
STICKLINE(主线<=MACK AND K<=REF(K,1),0,HARX,1,-1)COLORGRAY;
STICKLINE(主线<=MACK AND K>REF(K,1),0,HARX,1,-1)COLORGRAY;
STICKLINE(主线>MACK AND K<=REF(K,1),0,HARX/2,1,0)COLORBLUE;


VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
吸筹3:STICKLINE(VAR7,0,VAR7/50,4,0),COLORBB00FF;
吸筹4:STICKLINE(VAR7,0,VAR7/50,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR7,0,VAR7/50,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR7,0,VAR7/50,1,0),COLORFF66FF;



上面的是技术原码,只想要一个紫色柱大于1.0的选股公式,谢谢!
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表