手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师帮助将大智慧主图改成通达信主图公式

[通达信]
设置
1836 6 悠雅 Lv.2 发表于 · 2020-2-8 09:52 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
各代码如下:

参数: short(12,1,100,1) long(26,1,100,1) M(9,1,100,1)

DIFF :=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA  :=EMA(DIFF,M);
MACD :=2*(DIFF-DEA);
jcsc:=(M-1)/(M+1)*dea/(1-2/(m+1));{计算出金叉死叉时的Diff值}
dd:=(macd/2+(dea*(m-1)/(M+1)))/(1-2/(m+1));{计算出明日macd=macd时的Diff值}
xx:(diff*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算今日Diff=diff的对应股价}
js:(jcsc*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算金叉死叉的对应股价}
ddd:(dd*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算macd柱体变向时的对应股价}

代码源于本论坛 https://www.55188.com/thread-4166762-1-1.html

麻烦各位老师帮忙改成通达信,谢谢!

相关股票

悠雅
Lv.2
发表于 2020-2-9 21:48 复制 查看全部楼层
注册111 发表于 2020-2-9 12:24
参数自填
DIFF :=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA  :=EMA(DIFF,M);

谢谢!理想因你而精彩
注册111
Lv.6
发表于 2020-2-9 12:24 复制 查看全部楼层
悠雅 发表于 2020-2-9 10:08
谢谢!已解决.能帮忙写个选股公式吗?选股条件ddd和xx同时上穿js

参数自填
DIFF :=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA  :=EMA(DIFF,M);
MACD :=2*(DIFF-DEA);
jcsc:=(M-1)/(M+1)*dea/(1-2/(m+1));{计算出金叉死叉时的Diff值}
dd:=(macd/2+(dea*(m-1)/(M+1)))/(1-2/(m+1));{计算出明日macd=macd时的Diff值}
xx:=(diff*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算今日Diff=diff的对应股价}
js:=(jcsc*(short+1)*(long+1)-(long+1)*(short-1)*ema(c,short)+(short+1)*(long-1)*ema(c,long))/(2*((long+1)-(short+1)));{计算金叉死叉的对应股价}
cross(xx,js);
查看全部打赏
  • 悠雅+10理想币 : 很给力,理想因你而精彩;
悠雅
Lv.2
发表于 2020-2-9 10:08 复制 查看全部楼层
注册111 发表于 2020-2-8 18:26
看图。。。。。。。。。。。。。。

谢谢!已解决.能帮忙写个选股公式吗?选股条件ddd和xx同时上穿js
注册111
Lv.6
发表于 2020-2-8 18:26 复制 查看全部楼层
悠雅 发表于 2020-2-8 16:23
填了,不行。改了下参数可以了,谢谢谢你!

看图。。。。。。。。。。。。。。

附件

捕获.PNG
捕获.PNG
悠雅
Lv.2
发表于 2020-2-8 16:23 复制 查看全部楼层
注册111 发表于 2020-2-8 12:58
把参数填写在参数表中short(12,1,100,1) long(26,1,100,1) M(9,1,100,1),公式就通过了。

填了,不行。改了下参数可以了,谢谢谢你!
注册111
Lv.6
发表于 2020-2-8 12:58 复制 查看全部楼层
把参数填写在参数表中short(12,1,100,1) long(26,1,100,1) M(9,1,100,1),公式就通过了。
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表